0% found this document useful (0 votes)
596 views

Ccna2 Practical Exam

This document contains configuration examples for routers and switches to implement VLANs, OSPF routing, DHCP services, static and dynamic NAT, and access control lists. Router R1, R2, and R3 are configured with interfaces, OSPF routing, and DHCP services. Switch S3 is configured with VLANs and trunk/access port settings. Router R2 implements static NAT for a web server, dynamic NAT for internal networks, and access lists for security and traffic filtering.

Uploaded by

aniram267
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
0% found this document useful (0 votes)
596 views

Ccna2 Practical Exam

This document contains configuration examples for routers and switches to implement VLANs, OSPF routing, DHCP services, static and dynamic NAT, and access control lists. Router R1, R2, and R3 are configured with interfaces, OSPF routing, and DHCP services. Switch S3 is configured with VLANs and trunk/access port settings. Router R2 implements static NAT for a web server, dynamic NAT for internal networks, and access lists for security and traffic filtering.

Uploaded by

aniram267
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
You are on page 1/ 2

CCNA2-PRACTICAL EXAM

R1(config)#interface s0/0/0
R1(config-if)#description s0/0/0_R1
R1(config-if)#ip address 172.16.12.1 255.255.255.252
R1(config-if)#clock rate 128000
R1(config-if)#no shutdown
R1(config)#ip route 0.0.0.0 0.0.0.0 s0/0/0
R2(config)#interface s0/0/0
R2(config-if)#ip address 172.16.12.2 255.255.255.252
R2(config-if)#description s0/0/0_R2
R2(config-if)#no shutdown
R2(config)#interface s0/0/1
R2(config-if)#description s0/0/1_R2
R2(config-if)#ip address 172.16.23.1 255.255.255.252
R2(config-if)#clock rate 128000
R2(config-if)#no shutdown
R2(config)#interface lo0
R2(config-if)#description webserver
R2(config-if)#ip address 10.10.10.10 255.255.255.255
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface g0/0
R2(config-if)#description connection to internet
R2(config-if)#ip address 209.165.200.225
255.255.255.248
R2(config-if)#no shutdown
R2(config)#ip route 0.0.0.0 0.0.0.0 g0/0
R3(config)#interface s0/0/1
R3(config-if)#description s0/0/1_R3
R3(config-if)#ip address 172.16.23.2 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#int lo4
R3(config-if)#ip address 192.168.4.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#int lo5
R3(config-if)#ip address 192.168.5.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#int
R3(config)#interface lo6
R3(config-if)#ip address 192.168.6.1 255.255.255.0
R3(config-if)#no shutdown
R3(config)#ip route 0.0.0.0 0.0.0.0 s0/0/1

VLAN
S3(config)#vlan 31 (similar configuration for S1)
S3(config-vlan)#name accounting
S3(config-vlan)#vlan 33
S3(config-vlan)#name engineering
S3(config-vlan)#vlan 99
S3(config-vlan)#name managment
S3(config-vlan)#exit
S3(config)#int vlan 99
S3(config-if)#ip address 192.168.99.3 255.255.255.0
S3(config-if)#no shutdown
S3(config-if)#exit
S3(config)#ip default-gateway 192.168.99.1
S3(config)#interface f0/3
S3(config-if)#switchport mode trunk
S3(config-if)#switchport trunk native VLAN1
S3(config-if)#int range fa0/1-2, fa0/4-24
S3(config-if-range)#switchport mode access
S3(config-if-range)#exit
S3(config)#interface fa0/18
S3(config-if)#switchport mode access
S3(config-if)#switchport access vlan 33
S3(config-if)#exit
S3(config)#interface range fa0/1-2, fa0/4-17, fa0/19-24
S3(config-if-range)#shutdown
R1(config)#interface g0/1.31
R1(config-subif)#description accounting LAN
R1(config-subif)#encapsulation dot1Q 31
R1(config-subif)#ip address 192.168.31.1 255.255.255.0
R1(config-subif)#exit
R1(config)#interface g0/1.33
R1(config-subif)#description engineering LAN
R1(config-subif)#encapsulation dot1Q 33
R1(config-subif)#ip address 192.168.33.1 255.255.255.0
R1(config-subif)#exit
R1(config)#interface g0/1.99
R1(config-subif)#description managment LAN
R1(config-subif)#encapsulation dot1Q 99
R1(config-subif)#ip address 192.168.99.1 255.255.255.0
R1(config-subif)#exit
R1(config)#interface g0/1
R1(config-if)#no shutdown

OSPF
R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 172.16.12.0 0.0.0.3 area 0
R1(config-router)#network 192.168.31.0 0.0.0.255 area 0
R1(config-router)#network 192.168.33.0 0.0.0.255 area 0
R1(config-router)#network 192.168.99.0 0.0.0.255 area 0
R1(config-router)#passive-interface g0/1.31
R1(config-router)#passive-interface g0/1.33
R1(config-router)#passive-interface g0/1.99
R1(config-router)#auto-cost reference-bandwidth 1000
R1(config-router)#exit
R1(config)#interface s0/0/0
R1(config-if)#bandwidth 128
R1(config-if)#ip ospf cost 7500
R2(config)#router ospf 1
R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 172.16.12.0 0.0.0.3 area 0
R2(config-router)#network 172.16.23.0 0.0.0.3 area 0
??R2(config-router)#network 10.10.10.0 0.0.0.0 area 0 ?
R2(config-router)#exit
R2(config)#router ospf 1
R2(config-router)#passive-interface g0/1
R2(config-router)#auto-cost reference-bandwidth 1000
R2(config-router)#exit
R2(config)#interface s0/0/0
R2(config-if)#bandwidth 128
R2(config-if)#exit
R2(config)#interface s0/0/1
R2(config-if)#bandwidth 128
R2(config-if)#exit
R2(config)#interface s0/0/0
R2(config-if)#ip ospf cost 7500
R2(config-if)#
R3(config)#router ospf 1
R3(config-router)#router-id 3.3.3.3
R3(config-router)#network 172.16.23.0 0.0.0.3 area 0
R3(config-router)#network 192.168.4.0 0.0.3.255 area 0
R3(config-router)#passive-interface lo4
R3(config-router)#passive-interface lo5
R3(config-router)#passive-interface lo6
R3(config-router)#auto-cost reference-bandwidth 1000
R3(config-router)#exit
R3(config)#interface s0/0/1
R3(config-if)#bandwidth 128
R3(config-if)#exit
DHCP
R1(config)#ip dhcp excluded-address 192.168.31.1
192.168.31.20
R1(config)#ip dhcp excluded-address 192.168.33.1
192.168.33.20
R1(config)#ip dhcp pool accounting
R1(dhcp-config)#dns-server 10.10.10.11
R1(dhcp-config)#domain-name ccna-sba.com
R1(dhcp-config)#default-router 192.168.31.1
R1(dhcp-config)#network 192.168.31.0 255.255.255.0
R1(dhcp-config)#exit
R1(config)#ip dhcp pool enginering
R1(dhcp-config)#dns-server 10.10.10.11

R1(dhcp-config)#domain-name ccna-sba.com
R1(dhcp-config)#default-router 192.168.33.1
R1(dhcp-config)#network 192.168.33.0 255.255.255.0
R1(dhcp-config)#
STATIC AND DYNAMIC NAT
R2(config)#user webuser privilege 15 secret cisco12345
R2(config)#ip http server
R2(config)#ip http authetication local
R2(config)#ip nat inside source static 10.10.10.10 ?
209.165.200.229
R2(config)#interface g0/0
R2(config-if)#ip nat outside
R2(config-if)#exit
DYNAMIC NAT INSIDE ACL
R2(config)#access-list 1 permit 192.168.31.0 0.0.0.255
R2(config)#access-list 1 permit 192.168.33.0 0.0.0.255
R2(config)#access-list 1 permit 192.168.4.0 0.0.3.255
DEFINE NAT POOL
R2(config)#ip nat pool INTERNET 209.165.200.225
209.165.200.228 netmask 255.255.255.248
DEFINE DYNAMIC NAT TRANSALTION
R2(config)#ip nat inside source list 1 pool INTERNET
R2(config)#
PART 6
R2(config)#ip access-list standard ADMIN-MGT
R2(config-std-nacl)#permit host 172.16.12.1
R2(config-std-nacl)#exit
R2(config)#line vty 0 4
R2(config-line)#access-class ADMIN-MGT in
R2(config-line)# exit
CONFIGURE EXTENDED ACL
R2(config)#access-list 101 permit tcp any host
209.165.200.229 eq 80
R2(config)#access-list 101 permit icmp any any echoreply
R2(config)#interface g0/0
R2(config-if)#ip access-group 101 in
R2(config-if)#exit
R2(config)#interface s0/0/0
R2(config-if)#ip access-group 101 out
R2(config-if)#exit
R2(config)#interface s0/0/1
R2(config-if)#ip access-group 101 out
R2(config-if)#exit
R2(config)#interface lo0
R2(config-if)#ip access-group 101 out
R2(config-if)#exit

You might also like