0% found this document useful (0 votes)
40 views

BGP P 1: Attribute Types About BGP

This document provides an overview of the Border Gateway Protocol (BGP) including its attributes, path selection process, configuration, and troubleshooting. BGP is used to exchange routing information for IP-based networks between autonomous systems (AS). It uses TCP port 179 to establish peering sessions between routers in different AS to exchange routing updates. BGP attributes include AS path, next hop, origin, and community tags which influence the path selection process.

Uploaded by

Luis CP
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
0% found this document useful (0 votes)
40 views

BGP P 1: Attribute Types About BGP

This document provides an overview of the Border Gateway Protocol (BGP) including its attributes, path selection process, configuration, and troubleshooting. BGP is used to exchange routing information for IP-based networks between autonomous systems (AS). It uses TCP port 179 to establish peering sessions between routers in different AS to exchange routing updates. BGP attributes include AS path, next hop, origin, and community tags which influence the path selection process.

Uploaded by

Luis CP
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
You are on page 1/ 2

BGP PART 1

packetlife.net
Attribute Types

About BGP
Type Path Vector

Well-known Mandatory Must be supported and propagated


Well-known Discretionary Must be supported; propagation optional
Optional Transitive Marked as partial if unsupported by neighbor

Algorithm Path Selection


eBGP AD 20
iBGP AD 200

Optional Nontransitive Deleted if unsupported by neighbor

Standard RFC 4271

Attributes
Name

Type Description

Protocols IP

Aggregator

OT

Transport TCP 179

ID and AS of router which performed


summarization

AS Path

WM

List of autonomous systems the


advertisement has traversed

Atomic Aggregate

WD

Includes AS which have been


dropped due to route aggregation

Cluster ID

ON

Originating cluster

Community

OT

Route tag

Local Preference

WD

Metric for internal neighbors to


reach external paths; default 100

Terminology
Autonomous System (AS) A logical
domain under the control of a single entity
External BGP (eBGP) BGP neighborships
formed between autonomous systems

Multiple Exit
Discriminator (MED)

ON

Metric for external neighbors to


reach the AS; default 0

Next Hop

WM

External peer in neighboring AS

Origin

WM

Origin type (IGP, EGP, or unknown)

Originator ID

ON

Identifies route reflector

Weight

Cisco proprietary, not


communicated to peers; default 0

Internal BGP (iBGP) BGP between peers


within a single autonomous system
Synchronization requirement Asserts
that a route must be known by an IGP before
it may be advertised to BGP peers

Packet Types
Open

Update

Keepalive

Notification

Neighbor States
Idle Neighbor is not responding

Path Selection
Order

Authentication MD5

Connect TCP session established

Description

Preference

1 Weight

Administrative preference

Highest

2 Local
Preference

Communicated between peers


within an AS

Highest

3 Self-Originated

Prefer paths originated locally

True

4 AS Path

Minimize AS hops

Shortest

show ip bgp

5 Origin

Prefer IGP-learned routes over


EGP, and EGP over unknown

IGP

show ip bgp summary

6 MED

Used externally to enter an AS

Lowest

7 External

Prefer eBGP routes over iBGP

eBGP

8 IGP Cost

Consider IGP attributes

Lowest

9 eBGP Peering

Favor more stable routes

Oldest

Tie breaker

Lowest

10 Router ID

Open Sent Open message sent


Open Confirm Response received
Established Neighborship established

Troubleshooting

show ip bgp neighbors


show ip route [bgp]
clear ip bgp * [soft]
debug ip bgp events
debug ip bgp updates

Influencing Path Selection


Weight neighbor 172.16.0.1 weight 200
MED default-metric 400
by Jeremy Stretch

Local Preference bgp default local-preference 100


Route Map neighbor 172.16.0.1 route-map Foo
v1.1

BGP PART 2

packetlife.net
Configuration Example
Router A
interface Serial1/0
description Backbone to B
ip address 172.16.0.1 255.255.255.252
!
interface Serial1/1
description Backbone to C
ip address 172.16.0.5 255.255.255.252
!
interface FastEthernet2/0
description LAN
ip address 192.168.1.1 255.255.255.0
!
router bgp 65100
no synchronization
network 172.16.0.0 mask 255.255.255.252
network 172.16.0.4 mask 255.255.255.252
network 192.168.1.0
neighbor South peer-group
neighbor South remote-as 65200
neighbor 172.16.0.2 peer-group South
neighbor 172.16.0.6 peer-group South
no auto-summary

Router B

Router C

interface FastEthernet0/0
description Local to C
ip address 10.0.0.1 255.255.255.252
!
interface Serial1/0
description Backbone to A
ip address 172.16.0.2 255.255.255.252
!
interface FastEthernet2/0
description LAN
ip address 192.168.2.1 255.255.255.0
!
router ospf 100
network 10.0.0.1 0.0.0.0 area 0
network 192.168.2.0 0.0.0.255 area 1
!
router bgp 65200
no synchronization
redistribute ospf 100 route-map LAN_Subnets
neighbor 10.0.0.2 remote-as 65200
neighbor 172.16.0.1 remote-as 65100
no auto-summary
!
access-list 10 permit 192.168.0.0 0.0.255.255
!
route-map LAN_Subnets permit 10
match ip address 10
set metric 100

interface FastEthernet0/0
description Local to B
ip address 10.0.0.2 255.255.255.252
!
interface Serial1/0
description Backbone to A
ip address 172.16.0.6 255.255.255.252
!
interface FastEthernet2/0
description LAN
ip address 192.168.3.1 255.255.255.0
!
router ospf 100
network 10.0.0.2 0.0.0.0 area 0
network 192.168.3.0 0.0.0.255 area 2
!
router bgp 65200
no synchronization
redistribute ospf 100 route-map LAN_Subnets
neighbor 10.0.0.1 remote-as 65200
neighbor 172.16.0.5 remote-as 65100
no auto-summary
!
access-list 10 permit 192.168.0.0 0.0.255.255
!
route-map LAN_Subnets permit 10
match ip address 10
set metric 100

Router A Routing Table

C
C
C
B
B

172.16.0.0/30 is subnetted, 2 subnets


172.16.0.4 is directly connected, S1/1
172.16.0.0 is directly connected, S1/0
192.168.1.0/24 is directly connected, F2/0
192.168.2.0/24 [20/100] via 172.16.0.2
192.168.3.0/24 [20/100] via 172.16.0.2

by Jeremy Stretch

Router B Routing Table

B
C
C
B
C
O

172.16.0.0/30 is subnetted, 2 subnets


172.16.0.4 [20/0] via 172.16.0.1
172.16.0.0 is directly connected, S1/0
10.0.0.0/30 is subnetted, 1 subnets
10.0.0.0 is directly connected, F0/0
192.168.1.0/24 [20/0] via 172.16.0.1
192.168.2.0/24 is directly connected, F2/0
IA 192.168.3.0/24 [110/2] via 10.0.0.2, F0/0

v1.1

You might also like