0% found this document useful (0 votes)
17 views

Useful Tips AIX

1. Check the top 15 high memory processes by PID and view details with ps -efa 2. List the top 15 processes taking swap space by PID and view details with ps -efa 3. Display disk usage and sort output to view progress of alternate disk installation, removing /alt_inst from paths

Uploaded by

Jhakaas Sameer
Copyright
© Attribution Non-Commercial (BY-NC)
Available Formats
Download as DOC, PDF, TXT or read online on Scribd
0% found this document useful (0 votes)
17 views

Useful Tips AIX

1. Check the top 15 high memory processes by PID and view details with ps -efa 2. List the top 15 processes taking swap space by PID and view details with ps -efa 3. Display disk usage and sort output to view progress of alternate disk installation, removing /alt_inst from paths

Uploaded by

Jhakaas Sameer
Copyright
© Attribution Non-Commercial (BY-NC)
Available Formats
Download as DOC, PDF, TXT or read online on Scribd
You are on page 1/ 1

1.

Check high memory utilizing processes for pid in `ps gv | sort nr k7 | awk {print $1}|head -15` do ps efa | grep w $pid done 2. List top few processes taking Swap for pid in `svmon Pt15 | perl -e 'while(<>){print if($.==2||$&&&!$s++);$.=0 if(/^-+$/)}' | tail +3 | awk {print $1}` do ps efa | grep w $pid done 3. When taking manual alt_disk_install, and wanna see the progress of alt (lsvgfs rootvg ; lsvgfs altinst_rootvg)|xargs -I {} df -g {} | awk '{print $1" "$2" "$3" "$4" "$5" "$6" "$7}'| sed e 's/ \/alt_inst/ /g' e 's/alt_//g' | sort -k7|grep -v ^Filesystem 4. Get LPAR ID Hex. No. echo "ibase=A;obase=16;`uname -L|awk '{print $1}'`"|bc 5. To know Dir usage when there are sub dirs as File Systems. E.g. to know /clocal dir usage, while there are FSW like /clocal/A /clocal/B /clocal/A/C , normal du smx * will list these Filesystems. cd /clocal PWD=`pwd` for i in `ls -ld */. | awk '{print $NF}' |awk -F'/' '{print $1}'` do df -g | awk '{print $NF}' | grep -w "${PWD}/${i}"$>>/dev/null if [ "$?" -ne "0" ] then du -smx $i fi done | sort -n Above script will not list sub File systems.

You might also like