10.3.1.1 Lab C - Configure Clientless Remote Access SSL VPNs Using ASDM - Instructor
10.3.1.1 Lab C - Configure Clientless Remote Access SSL VPNs Using ASDM - Instructor
Topology
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 1 of 31
CCNA Security Chapter 10 Lab C
IP Addressing Table
Objectives
Part 1: Basic Router/Switch/PC Configuration
Cable the network and clear previous device settings, as shown in the topology.
Configure basic settings for routers.
Configure PC host IP settings.
Verify connectivity.
Save the basic running configuration for each router and switch.
Part 2: Access the ASA Console and ASDM
Access the ASA console.
Clear the previous ASA configuration settings.
Bypass Setup mode.
Configure the ASA by using the CLI script.
Access ASDM.
Part 3: Configuring Clientless SSL VPN Remote Access Using ASDM
Start the VPN wizard.
Configure the SSL VPN user interface.
Configure AAA user authentication.
Configure the VPN group policy.
Configure a bookmark list (clientless connections only).
Review the configuration summary and deliver the commands to the ASA.
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 2 of 31
CCNA Security Chapter 10 Lab C
Background / Scenario
In addition to stateful firewall and other security features, the ASA can provide both site-to-site and remote
access VPN functionality. The ASA provides two main deployment modes that are found in Cisco SSL remote
access VPN solutions:
Clientless SSL VPN—Clientless, browser-based VPN that lets users establish a secure, remote-access
VPN tunnel to the ASA using a web browser and built-in SSL to protect VPN traffic. After authentication,
users are presented with a portal page and can access specific, predefined internal resources from the
portal.
Client-Based SSL VPN—Provides full-tunnel SSL VPN connection, but requires a VPN client application
to be installed on the remote host. After authentication, users can access any internal resource as if they
were physically on the local network. The ASA supports both SSL and IPsec client-based VPNs.
In Part 1 of this lab, you will configure the topology and non-ASA devices. In Part 2, you will prepare the ASA
for ASDM access. In Part 3, you will use the ASDM VPN wizard to configure a clientless SSL remote access
VPN and verify access using a remote PC with a browser.
Your company has two locations connected to an ISP. Router R1 represents a CPE device managed by the
ISP. Router R2 represents an intermediate Internet router. Router R3 connects users at the remote branch
office to the ISP. The ASA is an edge security device that connects the internal corporate network and DMZ
to the ISP while providing NAT services to inside hosts.
Management has asked you to provide VPN access, using the ASA as a VPN concentrator, to teleworkers.
They want you to test the clientless access model, using SSL and a browser for client access.
Note: The router commands and output in this lab are from a Cisco 1941 router with Cisco IOS Release
15.4(3)M2 (with a Security Technology Package license). Other routers and Cisco IOS versions can be used.
See the Router Interface Summary Table at the end of the lab to determine which interface identifiers to use
based on the equipment in the lab. Depending on the router model and Cisco IOS version, the commands
available and output produced might vary from what is shown in this lab.
The ASA used with this lab is a Cisco model 5505 with an 8-port integrated switch, running OS version 9.2(3)
and ASDM version 7.4(1) and comes with a Base license that allows a maximum of three VLANs.
Note: Before beginning, ensure that the routers and switches have been erased and have no startup
configurations.
Instructor Note: Instructions for erasing switches and routers are provided in Chapter 0.0.0.0.
Required Resources
1 ASA 5505 (OS version 9.2(3) and ASDM version 7.4(1) and Base license or comparable)
3 routers (Cisco 1941 with Cisco IOS Release 15.4(3)M2 image with a Security Technology package
license)
3 switches (Cisco 2960 or comparable) (not required)
3 PCs (Windows 7 or Windows 8.1, with SSH Client software installed)
Serial and Ethernet cables, as shown in the topology
Console cables to configure Cisco networking devices
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 3 of 31
CCNA Security Chapter 10 Lab C
hostname R1
security passwords min-length 10
enable algorithm-type scrypt secret cisco12345
username admin01 algorithm-type scrypt secret admin01pass
ip domain name ccnasecurity.com
line con 0
login local
exec-timeout 5 0
logging synchronous
exit
line vty 0 4
login local
transport input ssh
exec-timeout 5 0
logging synchronous
exit
interface gigabitethernet 0/0
ip address 209.165.200.225 255.255.255.248
no shut
exit
int serial 0/0/0
ip address 10.1.1.1 255.255.255.252
clock rate 2000000
no shut
exit
ip route 0.0.0.0 0.0.0.0 Serial0/0/0
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 4 of 31
CCNA Security Chapter 10 Lab C
hostname R2
security passwords min-length 10
enable algorithm-type scrypt secret cisco12345
username admin01 algorithm-type scrypt secret admin01pass
ip domain name ccnasecurity.com
line con 0
login local
exec-timeout 5 0
logging synchronous
exit
line vty 0 4
login local
transport input ssh
exec-timeout 5 0
logging synchronous
exit
interface serial 0/0/0
ip address 10.1.1.2 255.255.255.252
no shut
exit
interface serial 0/0/1
ip address 10.2.2.2 255.255.255.252
clock rate 2000000
no shut
exit
ip route 209.165.200.224 255.255.255.248 Serial0/0/0
ip route 172.16.3.0 255.255.255.0 Serial0/0/1
crypto key generate rsa general-keys modulus 1024
hostname R3
security passwords min-length 10
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 5 of 31
CCNA Security Chapter 10 Lab C
Step 7: Save the basic running configuration for each router and switch.
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 6 of 31
CCNA Security Chapter 10 Lab C
b. Use the reload command to restart the ASA. This causes the ASA to display in CLI Setup mode. If you
see the System config has been modified. Save? [Y]es/[N]o: message, type n, and press
Enter.
hostname CCNAS-ASA
domain-name ccnasecurity.com
enable password cisco12345
!
interface Ethernet0/0
switchport access vlan 2
no shut
!
interface Ethernet0/1
switchport access vlan 1
no shut
!
interface Ethernet0/2
switchport access vlan 3
no shut
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 7 of 31
CCNA Security Chapter 10 Lab C
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 8 of 31
CCNA Security Chapter 10 Lab C
d. At the privileged EXEC mode prompt, issue the write mem (or copy run start) command to save the
running configuration to the startup configuration and the RSA keys to non-volatile memory.
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 9 of 31
CCNA Security Chapter 10 Lab C
b. Review the on-screen text and topology diagram, and then click Next to continue.
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 10 of 31
CCNA Security Chapter 10 Lab C
Note: By default, the ASA uses a self-signed certificate to send to the client for authentication. Optionally,
the ASA may be configured to use a third-party certificate that is purchased from a well-known certificate
authority, such as VeriSign, to connect clients. In the event that a certificate is purchased, it may be
selected in the Digital Certificate drop-down menu.
The SSL VPN Interface screen provides links in the Information section. These links identify the URLs
that need to be used for the SSL VPN service access (log in) and for Cisco ASDM access (to access the
Cisco ASDM software).
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 11 of 31
CCNA Security Chapter 10 Lab C
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 12 of 31
CCNA Security Chapter 10 Lab C
b. In the Configure GUI Customization Objects window, click Add to open the Add Bookmark List window.
Name the list Web-Server.
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 13 of 31
CCNA Security Chapter 10 Lab C
Note: If the Web-Server bookmark list is shown as available from a previous configuration, you can delete
it in ASDM and re-create it.
c. In the Add Bookmark List window, click Add to open the Select Bookmark Type window.
d. As shown in the figure, the ASDM can create three types of bookmarks. Select the URL with GET or
POST method, click OK.
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 14 of 31
CCNA Security Chapter 10 Lab C
e. Enter the bookmark title and enter the server destination IP address or hostname as the URL to be used
with the bookmark entry. In this example, the Bookmark Title of Web-Mail is entered and an internal IP
address of 192.168.2.3 (the DMZ server) is specified. If this server has HTTP web services with web mail
installed and functional, the outside users are able to access the server from the ASA portal when they
connect.
f. Click OK to continue and return to the Add Bookmark List window which now displays the Web-Server
bookmark title and URL.
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 15 of 31
CCNA Security Chapter 10 Lab C
g. Click OK to continue and return to the Configure GUI Customization Objects window which now displays
the Web-Server bookmark.
h. Click OK to continue and return to the Bookmark List window and click Next to continue.
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 16 of 31
CCNA Security Chapter 10 Lab C
Step 6: Review the configuration summary and deliver the commands to the ASA.
The Summary page is displayed next. Verify that the information configured in the SSL VPN wizard is correct.
Click Back to make changes, or click Cancel and restart the VPN wizard. Click Finish to complete the
process and deliver the commands to the ASA
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 17 of 31
CCNA Security Chapter 10 Lab C
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 18 of 31
CCNA Security Chapter 10 Lab C
Step 10: View the clientless remote user session using the ASDM Monitor.
While the remote user at PC-C is still logged in and on the ASA portal page, you can view the session
statistics using ASDM monitor.
From the ASDM menu bar on PC-B, click Monitoring and then select VPN > VPN Statistics > Sessions.
Click the Filter By pull-down list and select Clientless SSL VPN. You should see the SSL-VPN-USER
session logged in from PC-C (172.16.3.3).
Note: You may need to click Refresh to display the remote user session.
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 19 of 31
CCNA Security Chapter 10 Lab C
Reflection
1. What are some benefits of clientless vs. client-based VPNs?
_______________________________________________________________________________________
_______________________________________________________________________________________
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 20 of 31
CCNA Security Chapter 10 Lab C
_______________________________________________________________________________________
_______________________________________________________________________________________
_______________________________________________________________________________________
_______________________________________________________________________________________
They are easier to setup because only a browser is required and no client software needs to be installed.
They can be used to limit access to very specific resources based on URLs that are defined by network
administration.
2. What are some differences when using SSL as compared to IPsec for remote access tunnel encryption?
_______________________________________________________________________________________
_______________________________________________________________________________________
_______________________________________________________________________________________
_______________________________________________________________________________________
_______________________________________________________________________________________
_______________________________________________________________________________________
Client-based VPNs can offer a more secure tunnel, if using IPsec, but are somewhat more complex to
configure.
Router Model Ethernet Interface #1 Ethernet Interface #2 Serial Interface #1 Serial Interface #2
1800 Fast Ethernet 0/0 Fast Ethernet 0/1 Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
(F0/0) (F0/1)
1900 Gigabit Ethernet 0/0 Gigabit Ethernet 0/1 Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
(G0/0) (G0/1)
2801 Fast Ethernet 0/0 Fast Ethernet 0/1 Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
(F0/0) (F0/1)
2811 Fast Ethernet 0/0 Fast Ethernet 0/1 Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
(F0/0) (F0/1)
2900 Gigabit Ethernet 0/0 Gigabit Ethernet 0/1 Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
(G0/0) (G0/1)
Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many
interfaces the router has. There is no way to effectively list all the combinations of configurations for each router
class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device.
The table does not include any other type of interface, even though a specific router may contain one. An
example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be
used in Cisco IOS commands to represent the interface.
Device Configs
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 21 of 31
CCNA Security Chapter 10 Lab C
: Saved
:
: Serial Number: JMX15364086
: Hardware: ASA5505, 512 MB RAM, CPU Geode 500 MHz
:
ASA Version 9.2(3)
!
hostname CCNAS-ASA
domain-name ccnasecurity.com
enable password 9D8jmmmgkfNZLETh encrypted
xlate per-session deny tcp any4 any4
xlate per-session deny tcp any4 any6
xlate per-session deny tcp any6 any4
xlate per-session deny tcp any6 any6
xlate per-session deny udp any4 any4 eq domain
xlate per-session deny udp any4 any6 eq domain
xlate per-session deny udp any6 any4 eq domain
xlate per-session deny udp any6 any6 eq domain
names
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
switchport access vlan 3
!
interface Ethernet0/3
shutdown
!
interface Ethernet0/4
shutdown
!
interface Ethernet0/5
shutdown
!
interface Ethernet0/6
shutdown
!
interface Ethernet0/7
shutdown
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 22 of 31
CCNA Security Chapter 10 Lab C
nameif outside
security-level 0
ip address 209.165.200.226 255.255.255.248
!
interface Vlan3
no forward interface Vlan1
nameif dmz
security-level 70
ip address 192.168.2.1 255.255.255.0
!
ftp mode passive
dns server-group DefaultDNS
domain-name ccnasecurity.com
object network inside-net
subnet 192.168.1.0 255.255.255.0
object network dmz-server
host 192.168.2.3
access-list OUTSIDE-DMZ extended permit ip any host 192.168.2.3
pager lines 24
mtu inside 1500
mtu outside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
!
object network inside-net
nat (inside,outside) dynamic interface
object network dmz-server
nat (dmz,outside) static 209.165.200.227
access-group OUTSIDE-DMZ in interface outside
route outside 0.0.0.0 0.0.0.0 209.165.200.225 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
aaa authentication telnet console LOCAL
aaa authentication ssh console LOCAL
aaa authentication http console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 23 of 31
CCNA Security Chapter 10 Lab C
no snmp-server contact
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 10
ssh stricthostkeycheck
ssh 192.168.1.0 255.255.255.0 inside
ssh timeout 10
ssh key-exchange group dh-group1-sha1
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
enable outside
group-policy SSL-VPN-POLICY internal
group-policy SSL-VPN-POLICY attributes
vpn-tunnel-protocol ssl-clientless
webvpn
url-list value Web-Server-
username SSL-VPN-USER password dd5hS0YgTYVkRgxL encrypted privilege 0
username SSL-VPN-USER attributes
vpn-group-policy SSL-VPN-POLICY
username admin01 password UsMZmktANM6Z2Y9I encrypted
tunnel-group SSL-VPN type remote-access
tunnel-group SSL-VPN general-attributes
default-group-policy SSL-VPN-POLICY
!
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect ip-options
inspect netbios
inspect rsh
inspect rtsp
inspect skinny
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 24 of 31
CCNA Security Chapter 10 Lab C
inspect esmtp
inspect sqlnet
inspect sunrpc
inspect tftp
inspect sip
inspect xdmcp
inspect icmp
!
service-policy global_policy global
prompt hostname context
call-home reporting anonymous prompt 2
call-home
profile CiscoTAC-1
no active
destination address http
https://tools.cisco.com/its/service/oddce/services/DDCEService
destination address email [email protected]
destination transport-method http
subscribe-to-alert-group diagnostic
subscribe-to-alert-group environment
subscribe-to-alert-group inventory periodic monthly
subscribe-to-alert-group configuration periodic monthly
subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:34769acca234634ad350833c85e020b9
: end
CCNAS-ASA(config)#
Router R1
R1#show run
Building configuration...
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 25 of 31
CCNA Security Chapter 10 Lab C
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
cts logging verbose
!
username admin01 secret 9
$9$5GtoxBiNFw5p9k$upl/WwRQGzsvRp6m4PWRoti1TWCR5G97MxBKnugrW6M
!
redundancy
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address 209.165.200.225 255.255.255.248
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
ip address 10.1.1.1 255.255.255.252
clock rate 2000000
!
interface Serial0/0/1
no ip address
shutdown
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 Serial0/0/0
!
control-plane
!
line con 0
exec-timeout 5 0
logging synchronous
login local
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 26 of 31
CCNA Security Chapter 10 Lab C
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
exec-timeout 5 0
logging synchronous
login local
transport input telnet
!
scheduler allocate 20000 1000
!
end
Router R2
R2# show run
Building configuration...
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 27 of 31
CCNA Security Chapter 10 Lab C
redundancy
!
interface Embedded-Service-Engine0/0
no ip address
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
ip address 10.1.1.2 255.255.255.252
!
interface Serial0/0/1
ip address 10.2.2.2 255.255.255.252
clock rate 2000000
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 172.16.3.0 255.255.255.0 Serial0/0/1
ip route 209.165.200.224 255.255.255.248 Serial0/0/0
!
control-plane
!
line con 0
exec-timeout 5 0
logging synchronous
login local
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 28 of 31
CCNA Security Chapter 10 Lab C
exec-timeout 5 0
logging synchronous
login local
transport input telnet
!
scheduler allocate 20000 1000
!
end
Router R3
R3# show run
Building configuration...
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 29 of 31
CCNA Security Chapter 10 Lab C
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 172.16.3.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
clock rate 2000000
!
interface Serial0/0/1
ip address 10.2.2.1 255.255.255.252
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 Serial0/0/1
!
control-plane
!
line con 0
exec-timeout 5 0
logging synchronous
login local
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
exec-timeout 5 0
logging synchronous
login local
transport input telnet
!
scheduler allocate 20000 1000
!
end
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 30 of 31
CCNA Security Chapter 10 Lab C
Switches S1, S2 and S3 – Use default configs, except for host name
© 2018 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 31 of 31