Configuring Multi Protocol Label Switching
Configuring Multi Protocol Label Switching
This chapter describes how to configure your network to perform Multiprotocol Label Switching
(MPLS). For a complete description of the MPLS commands, see the chapter “MPLS Commands” in the
Cisco IOS Switching Services Command Reference. For documentation of other commands that appear
in this chapter, you can use the command reference master index or search online.
This chapter contains the following sections:
• Configuring MPLS Levels of Control
• Configuring MPLS Traffic Engineering
• Configuring MPLS Traffic Engineering Paths
• Configuring MPLS Virtual Private Networks
• Configuring MPLS CoS Backbone Support
• Configuring MPLS CoS
• Configuring the Label Switch Controller
• MPLS Configuration Examples
For more information about the Cisco IOS CLI commands, see the chapter “MPLS Commands” in the
Cisco IOS Switching Services Command Reference.
Figure 21 shows a router-only MPLS network with Ethernet interfaces. The following sections outline
the procedures for configuring MPLS and displaying MPLS information in a network based on the
topology shown in Figure 21.
Note Ethernet interfaces are shown in Figure 21, but any of the interfaces that are supported
could be used instead. ATM interfaces operating as TC-ATM interfaces are the exception
to this statement.
Command Purpose
Step 1 At R1: Enables MPLS between R1 and R3.
Router# configuration terminal
Router(config)# ip cef distributed In order to configure distributed VIP MPLS, you
Router(config)# tag-switching advertise-tags must configure distributed CEF switching. Enter the
Router(config)# interface e0/1 ip cef distributed command on all routers.
Router(config-if)# tag-switching ip
Router(config-if)# exit
At R3:
Router# configuration terminal
Router(config)# ip cef distributed
Router(config)# tag-switching advertise-tags
Router(config)# interface e0/1
Router(config-if)# tag-switching ip
Step 2 At R3: Enables MPLS between R3 and R4.
Router(config)# interface e0/2
Router(config-if)# tag-switching ip
Router(config-if)# exit
At R4:
Router# configuration terminal
Router(config)# ip cef distributed
Router(config)# tag-switching advertise-tags
Router(config)# interface e0/2
Router(config-if)# tag-switching ip
Router(config-if)# exit
After you perform these steps, R1 applies labels to packets that are forwarded through interface e0/1,
with a next hop to R3.
You can enable MPLS throughout the rest of the network by repeating steps 1 and 2 as appropriate on
other routers until all routers and interfaces are enabled for MPLS. See the example in the “Enabling
MPLS Incrementally in a Network Example” section.
Command Purpose
Step 1 Router(config)# access-list 1 permit A Limits label distribution by using an access
list.
(Enter the actual network address and
netmask in place of permit A. For example,
access-list 1 permit 192.5.34. 0 0.0.0.255.)
Step 2 Router(config)# tag-switching advertise-tags for 1 Instructs the router to advertise for network
A only to all adjacent label switch routers.
Any labels for other destination networks
that the router may have distributed before
this step are withdrawn.
Command Purpose
Step 1 Router(config)# no tag-switching advertise-tags Configures R2 to distribute no labels.
Step 2 Router(config)# no tag-switching advertise-tags Configures R5 to distribute no labels.
Step 3 Router(config)# no tag-switching advertise-tags Configures R8 to distribute no labels
Command Purpose
Step 4 Router(config)# access-list 2 permit R1 Configures R3 by defining an access list and
Router(config)# no tag-switching advertise-tags for 1 by instructing the router to distribute labels
Router(config)# tag-switching advertise-tags for 1 to 2
Router(config)# exit
for the networks permitted by access list 1
(created as part of Case 2) to the routers
permitted by access list 2.
The access list 2 permit R1 command
permits R1 and denies all other routers.
(Enter the actual network address and
netmask in place of permit R1. For example,
access-list 1 permit 192.5.34.0 0.0.0.255.)
Step 5 Router(config)# access-list 1 permit A Configures R3.
Router(config)# access-list 2 permit R1
Router(config)# tag-switching advertise-tags for 1 to 2 (Enter the actual network address and
Router(config)# exit netmask in place of permit R1. For example,
access-list 1 permit 192.5.34.0 0.0.0.255.)
Step 6 Router(config)# access-list 1 permit A Configures R4.
Router(config)# access-list 2 permit R3
Router(config)# tag-switching advertise-tags for 1 to 2 (Enter the actual network address and
Router(config)# exit netmask in place of permit R1. For example,
access-list 1 permit 192.5.34.0 0.0.0.255.)
Step 7 Router(config)# access-list 1 permit A Configures R6.
Router(config)# access-list 2 permit R4
Router(config)# tag-switching advertise-tags for 1 to 2 (Enter the actual network address and
Router(config)# exit netmask in place of permit R1. For example,
access-list 1 permit 192.5.34.0 0.0.0.255.)
Step 8 Router(config)# access-list 1 permit A Configures R7.
Router(config)# access-list 2 permit R6
Router(config)# tag-switching advertise-tags for 1 to 2 (Enter the actual network address and
Router(config)# exit netmask in place of permit R1. For example,
access-list 1 permit 192.5.34.0 0.0.0.255.)
Command Purpose
Step 1 Router(config)# ip cef Enables standard CEF operation.
For information about CEF configuration and command
syntax, see the Cisco IOS Switching Services
Configuration Guide and Cisco IOS Switching Services
Command Reference.
Step 2 Router(config)# mpls traffic-eng tunnels Enables the MPLS traffic engineering tunnel feature on a
device.
Note You need to enable the tunnel feature and specify the amount of reservable RSVP
bandwidth if you have an interface that supports MPLS traffic engineering.
Command Purpose
Step 1 Router(config-if)# mpls traffic-eng tunnels Enables the MPLS traffic engineering tunnel feature on an
interface.
Step 2 Router(config-if)# ip rsvp bandwidth bandwidth Enables RSVP for IP on an interface and specify amount
of bandwidth to be reserved.
For a description of IP RSVP command syntax, see the
Cisco IOS Quality of Service Command Reference.
Command Purpose
Step 1 Router(config)# interface tunnel1 Configures an interface type and enter interface
configuration mode.
Step 2 Router(config-if)# tunnel destination A.B.C.D Specifies the destination for a tunnel.
Step 3 Router(config-if)# tunnel mode mpls traffic-eng Sets encapsulation mode of the tunnel to MPLS traffic
engineering.
Step 4 Router(config-if)# tunnel mpls traffic-eng Configures bandwidth for the MPLS traffic engineering
bandwidth bandwidth tunnel.
Step 5 Router(config-if)# tunnel mpls traffic-eng Configures a named IP explicit path.
path-option 1 explicit name test
Step 6 Router(config-if)# tunnel mpls traffic-eng Configures a backup path to be dynamically calculated
path-option 2 dynamic from the traffic engineering topology database.
Command Purpose
Step 1 Router(config)# router isis Enables IS-IS routing and specify an IS-IS process for IP,
which places you in router configuration mode.
Step 2 Router(config-router)# mpls traffic-eng level 1 Turns on MPLS traffic engineering for IS-IS level 1.
Step 3 Router(config-router)# mpls traffic-eng Specifies the traffic engineering router identifier for the
router-id loopback0 node to be the IP address associated with interface
loopback0.
Step 4 Router(config-router)# metric-style wide Configures a router to generate and accept only new-style
TLVs.
Command Purpose
Step 1 Router(config-if)# interface tunnel1 Configures an interface type and enters interface
configuration mode.
Step 2 Router(config-router)# tunnel mpls traffic-eng Causes the IGP to use the tunnel in its enhanced
autoroute announce SPF calculation.
Defining VPNs
To define VPN routing instances, use the following commands in router configuration mode on the PE
router:
Command Purpose
Step 1 Router(config)# ip vrf vrf-name Enters VRF configuration mode and define the
VPN routing instance by assigning a VRF name.
Step 2 Router(config-vrf)# rd route-distinguisher Creates routing and forwarding tables.
Step 3 Router(config-vrf)# route-target {import | export | Creates a list of import and/or export route target
both} route-target-ext-community communities for the specified VRF.
Step 4 Router(config-vrf)# import map route-map (Optional) Associates the specified import route
map with the VRF.
Step 5 Router(config-vrf)# export map route-map (Optional) Associates the specified export route
map with the VRF.
Step 6 Router(config-if)# ip vrf forwarding vrf-name Associates a VRF with an interface or
subinterface.
Command Purpose
Step 1 Router(config)# router bgp autonomous-system Configures the BGP routing process with the
autonomous system number passed along to other
BGP routers.
Step 2 Router(config-router)# neighbor {ip-address | Specifies a neighbor’s IP address or BGP peer
peer-group-name} remote-as number group identifying it to the local autonomous
system.
Step 3 Router(config-router)# neighbor ip-address activate Activates the advertisement of the IPv4 address
family.
Command Purpose
Step 1 Router(config-router)# address-family vpnv4 [unicast | Defines IBGP parameters for VPNv4 NLRI
multicast] exchange.
Step 2 Router(config-router-af)# neighbor address remote-as Defines an IBGP session to exchange VPNv4
as-number NLRIs.
Step 3 Router(config-router-af)# neighbor address activate Activates the advertisement of the IPv4 address
family.
Command Purpose
Step 1 Router(config-router)# address-family ipv4 [unicast] Defines EBGP parameters for PE to CE routing
vrf vrf-name sessions.
Command Purpose
Step 2 Router(config-router-af)# neighbor address remote-as Defines an EBGP session between PE and CE
as-number routers.
Step 3 Router(config-router-af)# neighbor address activate Activates the advertisement of the IPv4 address
family.
Command Purpose
Step 1 Router(config)# router rip Enables RIP.
Step 2 Router(config-router-af)# address-family ipv4 Defines RIP parameters for PE to CE routing
[unicast] vrf vrf-name sessions.
Command Purpose
Step 1 Router(config)# ip route vrf vrf-name Defines static route parameters for every PE to CE
session.
Step 2 Router(config-router)# address-family ipv4 [unicast] Defines static route parameters for every BGP PE
vrf vrf-name to CE routing session.
Step 3 Router(config-router-af)# redistribute static Redistributes VRF static routes into the VRF BGP
table.
Step 4 Router(config-router-af)# redistribute static Redistributes directly connected networks into the
connected VRF BGP table.
Command Purpose
Router# show ip vrf Displays the set of defined VRFs and interfaces.
Router# show ip vrf [{brief | detail | interfaces}] vrf-name Displays information about defined VRFs and
associated interfaces.
Router# show ip route vrf vrf-name Displays the IP routing table for a VRF.
Router# show ip protocols vrf vrf-name Displays the routing protocol information for a VRF.
Router# show ip cef vrf vrf-name Displays the CEF forwarding table associated with a
VRF.
Router# show ip interface interface-number Displays the VRF table associated with an interface.
Router# show ip bgp vpnv4 all [tags] Displays information about all BGP VPN-IPv4
prefixes.
Router# show tag-switching forwarding vrf vrf-name [prefix Displays label forwarding entries that correspond to
mask/length][detail] VRF routes advertised by this router.
LSRs
LSRs at the core of the MPLS backbone are usually either Cisco 7200 and Cisco 7500 series routers
running MPLS software. Packets are processed as follows:
1. IP packets enter into the edge of the MPLS network.
2. The edge LSRs invoke CAR to classify the IP packets and possibly set IP precedence. Alternatively,
IP packets can be received with their IP precedence already set.
3. For each packet, the router performs a lookup on the IP address to determine the next-hop LSR.
4. The appropriate label is placed on the packet with the IP precedence bits copied into every label
entry in the MPLS header.
5. The labeled packet is then forwarded to the appropriate output interface for processing.
6. The packets are differentiated by class. This is done according to drop probability (WRED) or
according to bandwidth and delay (WFQ). In either case, LSRs enforce the defined differentiation
by continuing to employ WRED or WFQ on each hop.
ATM LSRs
ATM LSRs at the core implement the multiple label virtual circuit model (LVC). In the multiple LVC
model, one label is assigned for each service class for each destination. The operation of the edge LSR
is the same as that described previously for the LSR case, except that the output is an ATM interface.
WRED is used to define service classes and determine discard policy during congestion.
In the multiple LVC model, however, class-based WFQ is used to define the amount of bandwidth
available to each service class. Packets are scheduled by class during congestion. The ATM LSRs
participate in the differentiation of classes with WFQ and intelligently drop packets when congestion
occurs. The mechanism for this discard activity is weighted early packet discard (WEPD).
ATM Switches
When the core network uses ATM switches and the edge of the network uses MPLS-enabled edge LSRs,
the edge LSRs are interconnected through a mesh of ATM Forum PVCs (CBR, VBR, or UBR) over the
ATM core switches. The edge LSRs invoke WFQ on a per-VC basis to provide differentiation based on
the delay of each MPLS CoS multiplexed onto the ATM Forum PVC. Optionally, WRED can also be
used on a per-VC basis to manage drop priority between classes when congestion occurs on the edge
LSR.
Table 17 lists the MPLS CoS features supported on packet interfaces.
MPLS CoS Packet Feature Cisco 7500 Cisco 7200 Cisco 4x00 Cisco 36x0 Cisco 2600
Series Series Series Series Series
Per-interface WRED X X X X Untested
Per-interface, per-flow X X X X Untested
WFQ
Per-interface, per-class X X X X Untested
WFQ
MPLS CoS ATM Forum PVCs Cisco 7500 Cisco 7200 Cisco 4x00 Cisco 36x0 Cisco 2600
Feature Series Series Series Series Series
Per-VC WRED X1 X1 — — —
1
Per-VC WRED and — X — — —
per VC, per-class WFQ
MPLS CoS Multi-VC or LBR
Feature
Per-interface WRED X2 X2 — — —
2 2
Per-interface, per-class X X — — —
WFQ
1. This feature is only available on the PA-A3.
2. This feature is only available on the PA-A1.
LightStream
MPLS CoS ATM Forum BPX 8650 MGX 8800 1010 ATM Catalyst 8540
PVCs Feature Series Series Switch1 MSR1
MPLS CoS ATM Forum X X X X
PVCs
MPLS CoS Multi-VC or X — — —
LBR—per-class WFQ
1. This can be used for the core only.
Command Purpose
Step 1 Router(config)# interface type number point-to-point Configures a point-to-point ATM subinterface.
Step 2 Router(config-subif)# ip unnumbered Loopback0 Assigns IP address to the subinterface.
Step 3 Router(config-subif)# pvc 4/40 Creates a PVC on the subinterface.
Step 4 Router(config-if-atm-vc)# random-detect attach Activates (D)WRED on the interface.
groupname
Step 5 Router(config-if-atm-vc)# encapsulation aal5snap Sets encapsulation type for the PVC.
Command Purpose
Step 6 Router(config-subif)# exit Exits from PVC mode and enters subinterface
mode.
Step 7 Router(config-subif)# tag-switching ip Enables MPLS IP on the point-to-point interface.
Note The default for the multi-VC mode creates four VCs for each MPLS destination.
Command Purpose
Step 1 Router(config)# interface type number tag-switching Configures an ATM MPLS subinterface.
Step 2 Router(config-subif)# ip unnumbered Loopback0 Assigns IP address to the subinterface.
Step 3 Router(config-subif)# tag-switching atm multi-vc Enables ATM multi-VC mode on the subinterface.
Step 4 Router(config-subif)# tag-switching ip Enables MPLS on the ATM subinterface.
Command Purpose
Step 1 Router(config)# tag-switching cos-map cos-map number Creates a CoS map.
Step 2 Router(config-tag-cos-map)# class 1 premium Enters the cos-map submode and maps premium
and standard classes to label VCs.
This CoS map assigns class 1 traffic to share the
same label VC as class 2 traffic. The numbers you
assign to the CoS map range from 0 to 3.
The defaults are:
• class 0 is available
• class 1 is standard
• class 2 is premium
• class 3 is control
Step 3 Router(config-tag-cos-map)# exit Exits the MPLS CoS map submode.
Command Purpose
Step 4 Router(config)# access-list access-list-number permit Creates an access list.
destination
The access list acts on traffic going to the
specified destination address.
Step 5 Router(config)# tag-switching prefix-map prefix-map Configures the router to use a specified CoS map
access-list access-list cos-map cos-map when a MPLS destination prefix matches the
specified access list.
Command Purpose
Step 1 Router(config)# interface type number Specifies the interface type and number.
Step 2 Router(config-if)# fair-queue tos Configures an interface to use fair queueing
Step 3 Router(config)# fair-queue tos class weight Changes the class weight on the specified
interface.
Command Purpose
Step 1 Router# show tag-switching interfaces interfaces Displays detailed information about label
switching interfaces.
Step 2 Router# show tag-switching cos-map Displays the CoS map used to assign VCs.
Step 3 Router# show tag-switching prefix-map Displays the prefix map used to assign a CoS map
to network prefixes.
Switch Control
Port (12.1)
6.1 12.2
Controlled Switch
(BPX)
6.2
S6856
Command Purpose
Step 1 Router(config)# interface atm1/0 Enables the VSI protocol on the control interface
Router(config-if)# tag-control-protocol vsi (ATM1/0).
Step 2 Router(config-if)# interface XTagATM61 Creates an extended label ATM (XmplsATM)
Router(config-if)# extended-port atm1/0 bpx 6.1 virtual interface and bind it to BPX port 6.1.
Step 3 Router(config-if)# ip address 192.103.210.5 Configures MPLS on the extended label ATM
255.255.255.0 interface. (extended label ATM interfaces differ
Router(config-if)# tag-switching ip
Router(config-if)# exit
from ordinary ATM interfaces in that MPLS is
configured on the primary interface of an extended
label ATM interface, whereas it is configured on a
MPLS subinterface of an ordinary ATM
interface.)
Step 4 Router(config)# ip cef switch Enables Cisco Express Forwarding (CEF)
switching.
Note This command displays downstream mode bindings. For label VC bindings, see the show
tag-switching atm-tdp bindings command.
Matching entries:
tib entry: 10.92.0.0/16, rev 28
local binding: tag: imp-null(1)
remote binding: tsr: 172.27.32.29:0, tag: imp-null(1)
tib entry: 10.102.0.0/16, rev 29
local binding: tag: 26
remote binding: tsr: 172.27.32.29:0, tag: 26
tib entry: 10.105.0.0/16, rev 30
local binding: tag: imp-null(1)
remote binding: tsr: 172.27.32.29:0, tag: imp-null(1)
tib entry: 10.205.0.0/16, rev 31
local binding: tag: imp-null(1)
remote binding: tsr: 172.27.32.29:0, tag: imp-null(1)
tib entry: 10.211.0.7/32, rev 32
local binding: tag: 27
remote binding: tsr: 172.27.32.29:0, tag: 28
tib entry: 10.220.0.7/32, rev 33
local binding: tag: 28
remote binding: tsr: 172.27.32.29:0, tag: 29
tib entry: 99.101.0.0/16, rev 35
local binding: tag: imp-null(1)
remote binding: tsr: 172.27.32.29:0, tag: imp-null(1)
tib entry: 100.101.0.0/16, rev 36
local binding: tag: 29
remote binding: tsr: 172.27.32.29:0, tag: imp-null(1)
tib entry: 171.69.204.0/24, rev 37
local binding: tag: imp-null(1)
remote binding: tsr: 172.27.32.29:0, tag: imp-null(1)
tib entry: 172.27.32.0/22, rev 38
local binding: tag: imp-null(1)
remote binding: tsr: 172.27.32.29:0, tag: imp-null(1)
tib entry: 210.10.0.0/16, rev 39
local binding: tag: imp-null(1)
tib entry: 210.10.0.8/32, rev 40
remote binding: tsr: 172.27.32.29:0, tag: 27
The following shows sample output from the show tag-switching interfaces command when you
specify detail:
Router# show tag-switching interface detail
Interface Hssi3/0:
IP tagging enabled
TSP Tunnel tagging enabled
Tagging not operational
MTU = 4470
Interface ATM4/0.1:
IP tagging enabled
TSP Tunnel tagging enabled
Tagging operational
MTU = 4470
ATM tagging: Tag VPI = 1, Control VC = 0/32
Interface Ethernet5/0/0:
IP tagging not enabled
TSP Tunnel tagging enabled
Tagging operational
MTU = 1500
Interface Ethernet5/0/1:
IP tagging enabled
TSP Tunnel tagging not enabled
Tagging operational
MTU = 1500
Interface Ethernet5/0/2:
IP tagging enabled
TSP Tunnel tagging not enabled
Tagging not operational
MTU = 1500
Interface Ethernet5/0/3:
IP tagging enabled
TSP Tunnel tagging not enabled
Tagging operational
MTU = 1500
To shorten the previous path, delete the hop by entering the following commands:
Router(config)# interface tunnel 2003
Router(config-if)# no tunnel tsp-hop 2
Router(config-if)# tunnel tsp-hop 1 10.10.0.12 lasthop
Router(config-if)# exit
Signalling Summary:
TSP Tunnels Process: running
RSVP Process: running
Forwarding: enabled
interface s1/0
ip address 131.0.0.1 255.255.0.0
ip router isis
mpls traffic-eng tunnels
ip rsvp bandwidth 1000
mpls traffic-eng administrative-weight 10
router isis
net 47.0000.0011.0011.00
is-type level-1
metric-style wide
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-1
This example includes the commands for configuring a dynamic tunnel from Router 1 to Router 5.
configure terminal
interface tunnel1
ip unnumbered loopback 0
tunnel destination 17.17.17.17
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng bandwidth 100
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng path-option 1 dynamic
To verify that the tunnel is up and traffic is routed through the tunnel, enter these commands:
show mpls traffic-eng tunnel
show ip route 17.17.17.17
show mpls traffic-eng autoroute
ping 17.17.17.17
show interface tunnel1 accounting
show interface s1/0 accounting
To add a second tunnel to the same destination with an explicit path, enter these commands:
configure terminal
interface tunnel2
ip unnumbered loopback 0
tunnel destination 17.17.17.17
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng bandwidth 100
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng path-option 1 explicit identifier 1
To verify that the tunnel is up and traffic is routed through the tunnel, enter these commands:
show mpls traffic-eng tunnel
show ip route 17.17.17.17
show mpls traffic-eng autoroute
ping 17.17.17.17
show interface tunnel1 accounting
show interface s1/0 accounting
interface atm5/0
no ip address
no ip directed-broadcast
atm clock INTERNAL
no atm ilmi-keepalive
interface Ethernet1/0
ip address 3.3.3.5 255.255.0.0
no ip directed-broadcast
no ip mroute-cache
no keepalive
hssi internal-clock
encaps fr
frame-relay intf-type dce
frame-relay lmi-type ansi
!
interface hssi 10/1/0.16 point-to-point
ip vrf forwarding vrf2
ip address 10.20.1.13 255.255.255.0
frame-relay interface-dlci 16 ! Set up Frame Relay PVC subinterface as link to another
! ! CE router
LSC1 LSC2
(Cisco 7200 (Cisco 7200
series) series)
ATM 3/0 ATM 3/0
1.1 1.1
Edge LSR2
ATM 2/0/0 2.2 1.3 1.3 2.2 ATM 2/0/0
Edge LSR1 (Cisco 7200
Cisco BPX1 Cisco BPX2 series)
S6908
ATM-LSR ATM-LSR
LSC1 Configuration
7200 TSC1:
ip cef switch
!
interface ATM3/0
no ip address
tag-control-protocol vsi
!
interface XTagATM13
extended-port ATM3/0 bpx 1.3
!
ip address 142.4.133.13 255.255.0.0
tag-switching ip
!
interface XTagATM22
extended-port ATM3/0 bpx 2.2
!
ip address 142.6.133.22 255.255.0.0
tag-switching ip
!
LSC2 Configuration
7200 TSC2:
ip cef switch
!
interface ATM3/0
no ip address
tag-control-protocol vsi slaves 2
!
interface XTagATM13
extended-port ATM3/0 bpx 1.3
!
ip address 142.4.143.13 255.255.0.0
tag-switching ip
!
interface XTagATM22
extended-port ATM3/0 bpx 2.2
!
ip address 142.2.143.22 255.255.0.0
tag-switching ip
!
18970
a0/0/3 a0/0/1 a0/1/1
lo0:15.15.15.15 a0/0/0 a0/0/0
Switch 2 a1/1/0 a1/1/0 Switch 1
lo0:16.16.16.16 lo0:17.17.17.17
Running IP on Router 2
The following commands enable IP routing on Router 2. All routers must have IP enabled.
!
ip routing
!
hostname R2
!
interface Loopback0
ip address 10.10.10.10 255.255.255.255
!
interface POS0/3
ip unnumbered Loopback0
crc 16
clock source internal
!
router ospf 100
network 10.0.0.0 0.255.255.255 area 100
!
Running IP on Router 1
The following commands enable IP routing on Router 1.
ip routing
!
hostname R1
!
interface Loopback0
ip address 15.15.15.15 255.255.255.255
!
interface POS0/3
ip unnumbered Loopback0
crc 16
clock source internal
!
router ospf 100
network 15.0.0.0 0.255.255.255 area 100
Configuring CAR
Lines 3 and 4 of the following sample configuration contain the CAR rate policies. Line 3 sets the
committed information rate (CIR) at 155,000,000 bits and the normal burst/maximum burst size at
200,000/800,000 bytes. The conform action (action to take on packets) sets the IP precedence and
transmits the packets that conform to the rate limit. The exceed action sets the IP precedence and
transmits the packets when the packets exceed the rate limit.
!
interface POS3/0/0
ip unnumbered Loopback0
rate-limit input 155000000 2000000 8000000 conform-action set-prec-transmit 5
exceed-action set-prec-transmit 1
ip route-cache distributed
!
router ospf 100
network 11.0.0.0 0.255.255.255 area 100
network 90.0.0.0 0.255.255.255 area 100
The following commands configure WRED on an ATM interface. In this example, the commands refer
to a PA-A1 port adapter.
!
interface ATM1/1/0
ip route-cache distributed
atm clock INTERNAL
random-detect
!
The following commands configure interface ATM1/1/0 for multi-VC mode. In this example, the
commands refer to a PA-A1 port adapter.
!
interface ATM1/1/0.1 tag-switching
ip unnumbered Loopback0
tag-switching atm multi-vc
tag-switching ip
!
The commands to configure a PA-A3 port adapter differ slightly from the commands to configure a
PA-A1 port adapter as shown previously.
On an PA-A3 port-adapter interface, (D)WRED is supported only per-VC, not per-interface.
To configure a PA-A3 port adapter, enter the following commands:
!
interface ATM1/1/0
ip route-cache distributed
atm clock INTERNAL
!
interface ATM 1/1/0.1 tag-switching
ip unnumbered Loopback0
tag-switching multi-vc
tag-switching random detect attach groupname
!
The following commands configure per VC WRED on a PA-A3 port adapter only.
Note The PA-A1 port adapter does not support the per-VC WRED drop mechanism.
!interface ATM2/0/0
no ip address
ip route-cache distributed
Lines 5 and 6 of the following sample configuration contain the commands for configuring WRED and
WFQ on interface Hssi2/1/0.
!
interface Hssi2/1/0
ip address 91.0.0.1 255.0.0.0
ip route-cache distributed
tag-switching ip
random-detect
fair queue tos
hssi internal-clock
!
Configuring CAR
Lines 3 and 4 of the following sample configuration contain the CAR rate policies. Line 3 sets the
committed information rate (CIR) at 155,000,000 bits and the normal burst/maximum burst size at
200,000/800,000 bytes. The conform action (action to take on packets) sets the IP precedence and
transmits the packets that conform to the rate limit. The exceed action sets the IP precedence and
transmits the packets when the packets exceed the rate limit.
!
interface POS3/0/0
ip unnumbered Loopback0
rate-limit input 155000000 2000000 8000000 conform-action set-prec-transmit 2
exceed-action set-prec-transmit 2
ip route-cache distributed
!
router ospf 100
network 12.0.0.0 0.255.255.255 area 100
network 90.0.0.0 0.255.255.255 area 100
network 91.0.0.0 0.255.255.255 area 100
!
ip route 93.0.0.0 255.0.0.0 Hssi2/1/0 91.0.0.2
!
interface ATM0/0/2
no ip address
no ip directed-broadcast
!
interface ATM0/0/3
ip unnumbered Loopback0
tag-switching ip
!
interface ATM1/1/0
ip unnumbered Loopback0
tag-switching ip
!
router ospf 100
network 16.0.0.0 0.255.255.255 area 100
!
Line 3 of the following sample configuration contains the configuration command for an ATM Forum
PVC.
!
interface ATM0/1/1
ip unnumbered Loopback0
atm pvc 10 100 interface ATM0/0/0 10 100
tag-switching ip
!
interface ATM1/1/0
ip unnumbered Loopback0
tag-switching ip
!
router ospf 100
network 17.0.0.0 0.255.255.255 area 100
!