Chapter 5 Lab 5-1, Configure and Verify Path Control Using PBR Topology
Chapter 5 Lab 5-1, Configure and Verify Path Control Using PBR Topology
Chapter 5 Lab 5-1, Configure and Verify Path Control Using PBR
Topology.
Objectives
Configure and verify policy-based routing.
Select the required tools and commands to configure policy-based routing operations.
Verify the configuration and operation by using the proper show and debug commands.
Background
You want to experiment with policy-based routing (PBR) to see how it is implemented and to study how it
could be of value to your organization. To this end, you have interconnected and configured a test network
with four routers. All routers are exchanging routing information using EIGRP.
Note: This lab uses Cisco 1941 routers with Cisco IOS Release 15.2 with IP Base. Depending on the router
or switch model and Cisco IOS Software version, the commands available and output produced might vary
from what is shown in this lab.
Required Resources
4 routers (Cisco IOS Release 15.2 or comparable)
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 1 of 17
CCNPv7 ROUTE Lab 5-1, Configure and Verify Path Control Using PBR
interface Serial0/0/1
description R2 --> R3
ip address 172.16.23.2 255.255.255.248
clock rate 128000
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 2 of 17
CCNPv7 ROUTE Lab 5-1, Configure and Verify Path Control Using PBR
bandwidth 128
no shutdown
!
end
Router R3
hostname R3
!
interface Lo3
description R3 LAN
ip address 192.168.3.1 255.255.255.0
!
interface Serial0/0/0
description R3 --> R1
ip address 172.16.13.3 255.255.255.248
clock rate 64000
bandwidth 64
no shutdown
!
interface Serial0/0/1
description R3 --> R2
ip address 172.16.23.3 255.255.255.248
bandwidth 128
no shutdown
!
interface Serial0/1/0
description R3 --> R4
ip address 172.16.34.3 255.255.255.248
clock rate 64000
bandwidth 64
no shutdown
!
end
Router R4
hostname R4
!
interface Lo4
description R4 LAN A
ip address 192.168.4.1 255.255.255.128
!
interface Lo5
description R4 LAN B
ip address 192.168.4.129 255.255.255.128
!
interface Serial0/0/0
description R4 --> R3
ip address 172.16.34.4 255.255.255.248
bandwidth 64
no shutdown
!
End
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 3 of 17
CCNPv7 ROUTE Lab 5-1, Configure and Verify Path Control Using PBR
c. Verify the configuration with the show ip interface brief, show protocols, and show interfaces
description commands. The output from router R3 is shown here as an example.
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 4 of 17
CCNPv7 ROUTE Lab 5-1, Configure and Verify Path Control Using PBR
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 5 of 17
CCNPv7 ROUTE Lab 5-1, Configure and Verify Path Control Using PBR
Router R4
router eigrp 1
network 192.168.4.0
network 172.16.34.0 0.0.0.7
no auto-summary
You should see EIGRP neighbor relationship messages being generated.
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 6 of 17
CCNPv7 ROUTE Lab 5-1, Configure and Verify Path Control Using PBR
foreach address {
172.16.12.1
172.16.12.2
172.16.13.1
172.16.13.3
172.16.23.2
172.16.23.3
172.16.34.3
172.16.34.4
192.168.1.1
192.168.2.1
192.168.3.1
192.168.4.1
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 7 of 17
CCNPv7 ROUTE Lab 5-1, Configure and Verify Path Control Using PBR
192.168.4.129
} { ping $address }
You should get ICMP echo replies for every address pinged. Make sure to run the Tcl script on each
router.
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 8 of 17
CCNPv7 ROUTE Lab 5-1, Configure and Verify Path Control Using PBR
e. On R4, use the traceroute command to the R1 LAN address and source the ICMP packet from R4 LAN
A and LAN B.
Note: You can specify the source as the interface address (for example 192.168.4.1) or the interface
designator (for example, Fa0/0).
R4# traceroute 192.168.1.1 source 192.168.4.1
Type escape sequence to abort.
Tracing the route to 192.168.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 172.16.34.3 12 msec 12 msec 16 msec
2 172.16.23.2 20 msec 20 msec 20 msec
3 172.16.12.1 24 msec * 24 msec
R4#
R4# traceroute 192.168.1.1 source 192.168.4.129
Type escape sequence to abort.
Tracing the route to 192.168.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 172.16.34.3 12 msec 16 msec 12 msec
2 172.16.23.2 28 msec 20 msec 16 msec
3 172.16.12.1 24 msec * 24 msec
R4#
Notice that the path taken for the packets sourced from the R4 LANs are going through R3 --> R2 --> R1.
Why are the R4 interfaces not using the R3 --> R1 path?
Porque las interfaces seriales entre los routers R1 y R3 se han configurado con un bandwidth menor de
64 Kb / s, lo que le da una métrica más alta. Todas las demás interfaces seriales utilizan la configuración
de bandwith de 128 Kb / s. R3 elige enviar todos los paquetes a R2 debido a su métrica más baja.
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 9 of 17
CCNPv7 ROUTE Lab 5-1, Configure and Verify Path Control Using PBR
f. On R3, use the show ip route command and note that the preferred route from R3 to R1 LAN
192.168.1.0/24 is via R2 using the R3 exit interface S0/0/1.
R3# show ip route | begin Gateway
Gateway of last resort is not set
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 10 of 17
CCNPv7 ROUTE Lab 5-1, Configure and Verify Path Control Using PBR
Notice that the bandwidth of the serial link between R3 and R1 (S0/0/0) is set to 64 Kb/s, while the
bandwidth of the serial link between R3 and R2 (S0/0/1) is set to 128 Kb/s.
h. Confirm that R3 has a valid route to reach R1 from its serial 0/0/0 interface using the show ip eigrp
topology 192.168.1.0 command.
R3# show ip eigrp topology 192.168.1.0
EIGRP-IPv4 Topology Entry for AS(1)/ID(192.168.3.1) for 192.168.1.0/24
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 21152000
Descriptor Blocks:
172.16.23.2 (Serial0/0/1), from 172.16.23.2, Send flag is 0x0
Composite metric is (21152000/20640000), route is Internal
Vector metric:
Minimum bandwidth is 128 Kbit
Total delay is 45000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 2
Originating router is 192.168.1.1
172.16.13.1 (Serial0/0/0), from 172.16.13.1, Send flag is 0x0
Composite metric is (40640000/128256), route is Internal
Vector metric:
Minimum bandwidth is 64 Kbit
Total delay is 25000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
Originating router is 192.168.1.1
R3#
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 11 of 17
CCNPv7 ROUTE Lab 5-1, Configure and Verify Path Control Using PBR
As indicated, R4 has two routes to reach 192.168.1.0. However, the metric for the route to R1
(172.16.13.1) is much higher (40640000) than the metric of the route to R2 (21152000), making the route
through R2 the successor route.
i. Create a route map called R3-to-R1 that matches PBR-ACL and sets the next-hop interface to the R1
serial 0/0/1 interface.
R3(config)# route-map R3-to-R1 permit
R3(config-route-map)# description RM to forward LAN B traffic to R1
R3(config-route-map)# match ip address PBR-ACL
R3(config-route-map)# set ip next-hop 172.16.13.1
R3(config-route-map)# exit
R3(config)#
j. Apply the R3-to-R1 route map to the serial interface on R3 that receives the traffic from R4. Use the ip
policy route-map command on interface S0/1/0.
R3(config)# interface s0/1/0
R3(config-if)# ip policy route-map R3-to-R1
R3(config-if)# end
R3#
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 12 of 17
CCNPv7 ROUTE Lab 5-1, Configure and Verify Path Control Using PBR
k. On R3, display the policy and matches using the show route-map command.
R3# show route-map
route-map R3-to-R1, permit, sequence 10
Match clauses:
ip address (access-lists): PBR-ACL
Set clauses:
ip next-hop 172.16.13.1
Policy routing matches: 0 packets, 0 bytes
R3#
Note: There are currently no matches because no packets matching the ACL have passed through R3
S0/1/0.
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 13 of 17
CCNPv7 ROUTE Lab 5-1, Configure and Verify Path Control Using PBR
m. Test the policy from R4 with the traceroute command, using R4 LAN A as the source network.
R4# traceroute 192.168.1.1 source 192.168.4.1
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 14 of 17
CCNPv7 ROUTE Lab 5-1, Configure and Verify Path Control Using PBR
Why is the traceroute traffic not using the R3 --> R1 path as specified in the R3-to-R1 policy?
No toma la ruta especificada por PBR porque LAN A no cumple con los criterios especificados en la lista
de acceso PBR-ACL.
n. Test the policy from R4 with the traceroute command, using R4 LAN B as the source network.
R4# traceroute 192.168.1.1 source 192.168.4.129
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 15 of 17
CCNPv7 ROUTE Lab 5-1, Configure and Verify Path Control Using PBR
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 16 of 17
CCNPv7 ROUTE Lab 5-1, Configure and Verify Path Control Using PBR
© 2014 Cisco and/or its affiliates. All rights reserved. This document is Cisco Public. Page 17 of 17