0% found this document useful (0 votes)
41 views

Atharva Sawant/7388

The document describes configurations made on a router. It configures interfaces, IP addresses, routes, SSH settings and access control lists. Serial interface 0/0/0 and GigabitEthernet interface 0/0 are configured with IP addresses and as gateways in different subnets. SSH is enabled and settings like timeout, authentication retries and version are configured. Access lists are created to permit SSH access from a specific host and to allow only FTP traffic between subnets on GigabitEthernet interface 0/0.
Copyright
© © All Rights Reserved
Available Formats
Download as DOCX, PDF, TXT or read online on Scribd
0% found this document useful (0 votes)
41 views

Atharva Sawant/7388

The document describes configurations made on a router. It configures interfaces, IP addresses, routes, SSH settings and access control lists. Serial interface 0/0/0 and GigabitEthernet interface 0/0 are configured with IP addresses and as gateways in different subnets. SSH is enabled and settings like timeout, authentication retries and version are configured. Access lists are created to permit SSH access from a specific host and to allow only FTP traffic between subnets on GigabitEthernet interface 0/0.
Copyright
© © All Rights Reserved
Available Formats
Download as DOCX, PDF, TXT or read online on Scribd
You are on page 1/ 7

ATHARVA SAWANT/7388

Router>enable
Router#conf t
Router(config)#int se0/0/0
Router(config-if)#ip address 10.10.10.1 255.0.0.0
Router(config-if)#clock rate 64000
Router(config-if)#bandwidth 56
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int gi0/0
Router(config-if)#ip address 130.16.0.1 255.255.0.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#ip route 0.0.0.0 0.0.0.0 10.10.10.2

Router(config)#int se0/0/0
Router(config-if)#ip address 10.10.10.2 255.0.0.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int gi0/0
Router(config-if)#ip address 130.17.0.1 255.255.0.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#ip route 0.0.0.0 0.0.0.0 10.10.10.1
ATHARVA SAWANT/7388
ATHARVA SAWANT/7388

Router(config)#ip domain-name ccnasecurity


Router(config)#username sshadmin privilege 15 secret ciscossh
Router(config)#line vty 0 4
Router(config-line)#login local
Router(config-line)#transport input ssh
ATHARVA SAWANT/7388

Router(config-line)#exit
Router(config)#crypto key zeroize rsa
% No Signature RSA Keys found in configuration.

Router(config)#crypto key generate rsa


% Please define a hostname other than Router.
Router(config)#hostname atharva
atharva(config)#crypto key generate rsa
The name for the keys will be: atharva.ccnasecurity
Choose the size of the key modulus in the range of 360 to 2048 for your
General Purpose Keys. Choosing a key modulus greater than 512 may take
a few minutes.

How many bits in the modulus [512]: 1024


% Generating 1024 bit RSA keys, keys will be non-exportable...[OK]

atharva(config)#crypto key zeroize rsa


*Mar 1 0:26:36.636: %SSH-5-ENABLED: SSH 1.99 has been enabled
% All RSA keys will be removed.
% All router certs issued using these keys will also be removed.
Do you really want to remove these keys? [yes/no]: n
atharva#

atharva#show ip ssh
SSH Enabled - version 1.99
Authentication timeout: 120 secs; Authentication retries: 3
atharva#conf t
Enter configuration commands, one per line. End with CNTL/Z.
atharva(config)#ip ssh time-out 90
atharva(config)#ip ssh authentication-retries 2
atharva(config)#ip ssh version 2
atharva(config)#exit
ATHARVA SAWANT/7388

atharva(config)#access-list 10 permit host 130.16.0.2


atharva(config)#line vty 0 4
atharva(config-line)#access-class 10 in
atharva(config-line)#exit
atharva(config)#
ATHARVA SAWANT/7388

atharva(config)#access-list 120 permit tcp 130.16.0.9 0.0.0.0 130.17.0.2 0.0.0.0 eq ftp


atharva(config)#access-list 120 deny tcp any any
atharva(config)#int gi 0/0
atharva(config-if)#ip access-group 120 in
atharva(config-if)#exit
atharva(config)#
ATHARVA SAWANT/7388

You might also like