Command Line Interface Cross-Reference Guide: Extremexos, Eos, Voss, Boss, Cisco Ios
Command Line Interface Cross-Reference Guide: Extremexos, Eos, Voss, Boss, Cisco Ios
Version: 1.0
Extreme Networks and the Extreme Networks logo are trademarks or registered trademarks of Extreme Networks, Inc. in the United States and/or other countries. All other names are the property of their respective
owners. All other registered trademarks, trademarks, and service marks are property of their respective owners. For additional information on Extreme Networks trademarks, see
www.extremenetworks.com/company/legal/trademarks.
9035422-00
CLI Cross-Reference Guide
Legal Notice
Extreme Networks, Inc. reserves the right to make changes in specifications and other information contained in
this document and its website without prior notice. The reader should in all cases consult representatives of
Extreme Networks to determine whether any such changes have been made.
The hardware, firmware, software or any specifications described or referred to in this document are subject to
change without notice.
Trademarks
Extreme Networks and the Extreme Networks logo are trademarks or registered trademarks of Extreme
Networks, Inc. in the United States and/or other countries.
All other names (including any product names) mentioned in this document are the property of their
respective owners and may be trademarks or registered trademarks of their respective companies/owners.
Software Licensing
Some software files have been licensed under certain open source or third-party licenses. Enduser license
agreements and open source declarations can be found at:
www.extremenetworks.com/support/policies/software-licensing
Support
For product support, phone the Global Technical Assistance Center (GTAC) at 1-800-998-2408 (toll-free in
U.S. and Canada) or +1-408-579-2826. For the support phone number in other countries, visit:
http://www.extremenetworks.com/support/contact/
Table of Contents
Introduction to the CLI Cross-Reference Guide......................................................................... 6
Text Conventions ..................................................................................................................................................................................6
Providing Feedback to Us ................................................................................................................................................................6
Getting Help .............................................................................................................................................................................................7
Using the Alias Command to Transition to ExtremeXOS ....................................................... 8
Switch Models and Versions Used.................................................................................................. 9
Connecting to, Logging In, and Clearing Configuration .......................................................... 11
Console Cable .........................................................................................................................................................................................11
Default Login ...........................................................................................................................................................................................12
Clearing Switch Configuration .......................................................................................................................................................14
Changing Passwords ..........................................................................................................................................................................15
Recovering Passwords ......................................................................................................................................................................16
SNMPv1 ..................................................................................................................................................................... 29
SNMPv2 .................................................................................................................................................................... 32
SNMPv3 .................................................................................................................................................................... 34
Layer 3 Commands.............................................................................................................................. 93
Configuring VLAN IP Addresses ..................................................................................................................................................93
Configuring Inter-VLAN Routing .................................................................................................................................................94
Configuring Routing Information Protocol (RIP) Routing .............................................................................................96
Configuring Open Shortest Path First (OSPF) Routing ..................................................................................................98
Configuring Static Routing ..............................................................................................................................................................100
Configuring Border Gateway Protocol (BGP) Routing ...................................................................................................101
Configuring Virtual Router Redundancy Protocol (VRRP) ...........................................................................................104
Configuring Multicast ..........................................................................................................................................................................109
Text Conventions
The following tables list text conventions that are used throughout this guide.
Convention Description
The words enter and type When you see the word “enter” in this guide, you must
type something, and then press the Return or Enter
key. Do not press the Return or Enter key when an
instruction simply says “type.”
[Key] names Key names are written with brackets, such as [Return]
or [Esc]. If you must press two or more keys
simultaneously, the key names are linked with a plus
sign (+). Example:
Press [Ctrl]+[Alt]+[Del]
Words in italicized type Italics emphasize a point or denote new terms at the
place where they are defined in the text. Italics are also
used when referring to publication titles.
Providing Feedback to Us
We are always striving to improve our documentation and help you work better, so we want to hear from you!
We welcome all feedback but especially want to know about:
• Ideas for improvements to our documentation so you can find the information you need faster.
If you would like to provide feedback to the Extreme Networks Information Development team about this
document, please contact us using our short online feedback form. You can also email us directly at
[email protected].
Getting Help
If you require assistance, contact Extreme Networks using one of the following methods:
– Phone: 1-800-998-2408 (toll-free in U.S. and Canada) or +1 408-579-2826. For the support phone number
in your country, visit: www.extremenetworks.com/support/contact
– Email: [email protected]. To expedite your message, enter the product name or model
number in the subject line.
• Extreme Portal — Search the GTAC knowledgebase, manage support cases and service contracts, download
software, and obtain product licensing, training, and certifications.
• The Hub — A forum for Extreme customers to connect with one another, answer questions, and share ideas
and feedback. This community is monitored by Extreme Networks employees, but is not intended to replace
specific guidance from GTAC.
Before contacting Extreme Networks for technical support, have the following information ready:
• Your Extreme Networks service contract number and/or serial numbers for all involved Extreme Networks
products
• A description of your network environment (such as layout, cable type, other relevant environmental
information)
• The device history (for example, if you have returned the device before, or if this is a recurring problem)
For example, you can create an alias named set for configure commands:
You can now substitute the command set for all configure commands. For example, you can type set vlan
vlan_name tag tag instead of configure vlan vlan_name tag tag.
For more information about the ExtremeXOS alias command, see the latest ExtremeXOS Command Reference.
version: 21.1.3.7
ExtremeXOS
System Type: X460
version: 16.1.3.6
version: 6.81.09.0001
EOS
version: 8.62.04.0001
version: 8.62.04.0001
version: 6.1.0.0
version: 6.1.0.0
version: 6.1.0.0
version: 7.4.0
BOSS
version: 7.4.0
version: 6.1.0.005
version: 12.2(55)SE6
Cisco IOS
System Type: WS-3750-X
version: 12.2(55)SE
Terminal Emulation
1 1
2 2
3 3
4 4
5 5
6 6
7 7
8 8
9 9
Default Login
ro N/A read-only
rw N/A read-write
password: rwa
rw rw read-write
ro ro read-only
l1 l1 layer 1
l2 l2 layer 2
l3 l3 layer 3
RW secure read-write-all
RO user read-only
Note
ERS 4800 and earlier models offered two software images—Standard and Secure.
• For the standard image, the default password for RO is user, and secure for RW.
• For the secure software image, the default password for RO is userpasswd, and
securepasswd for RW.
Switch>enable
Switch#
ExtremeXOS EXAMPLE:
EOS EXAMPLE:
VOSS EXAMPLE:
EXAMPLE:
CPU restarts. If you change this flag, you must restart the switch
BOSS EXAMPLE:
3626GTS#boot default Reboot the stack/switch and use the factory default
configurations
Or
write erase
EXAMPLE:
Switch>enable
Switch#write erase <or erase startup-config>
Erasing the nvram filesystem will remove all configuration files! Continue? [con
firm]
[OK]
Erase of nvram: complete
Delete the VLAN information from Flash or NVRAM, and reload the switch.
Switch#delete flash:vlan.dat
Delete filename [vlan.dat]?
Delete flash:vlan.dat? [confirm]
Switch#reload
Proceed with reload? [confirm]
#After reboot
Would you like to enter the initial configuration dialog? [yes/no]: no
Changing Passwords
EXAMPLE:
EXAMPLE:
EXAMPLES:
In Configure Mode:
EXAMPLE:
In Configure Mode:
4826GTS-PWR+(config)#username RO password
4826GTS-PWR+(config)#username RW password
EXAMPLE:
Enable
Switch>enable
Switch#configure terminal
Switch(config)# enable password <password>
Switch#write memory
Console
Switch(config)#line con 0
Switch(config-line)#password <password>
Switch(config-line)#login
Switch(config-line)#end
Switch#write memory
Telnet
Switch(config)# line vty 0 4
Switch(config-line)#password <password>
Switch(config-line)#login
Switch(config-line)#end
Switch#write memory
Recovering Passwords
EXAMPLE:
switch: flash_init
switch: load_helper
switch: rename flash:config.text flash:config.old
switch: boot
after the switch boots and you are at the enable prompt, type this:
If you have lost all admin passwords to the switch, use one of the recovery methods described in in these
GTAC Knowledge articles.
• How to Recover an EXOS Switch and its Configuration Without the Password
If the switch is running 21.1 or later, you can use a one-time failsafe password to log in.
https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-access-an-EXOS-switch-using-a-one-
time-failsafe-password?q=exos+password+recovery&l=en_US&fs=Search&pn=1
Extreme Networks
4. In the bootrom, type the following commands to select a default configuration to be booted:
config none
boot
The switch should boot with a factory default configuration. Username = admin, Password = none.
Method 1: Creating an Autoexec Script
3. Type the following line, which creates a new user called “temp” with administrative privileges and a password of
“password”
5. Exit insert mode by pressing ESC, and then write the file and exit vi by typing :wq.
6. Reboot the switch by typing reboot, but do NOT save the configuration. Saving the configuration at this point overwrites
the existing configuration with a blank one.
7. When the switch reboots, the autoexec.xsf script is executed, creating the new account.
8. Log in using the new account and make the appropriate changes to the other accounts to allow access. If the password for
an account is unknown, the only way to change the password is to delete the account and re-create it.
9. Log out.
10. Ensure that the other accounts can now be used to log into the switch.
11. While logged in using a different account than one created in the script, delete the temp account and the autoexec.xsf
script.
delete account temp
rm autoexec.xsf
At this point, the switch should be back to its initial configuration, except for the passwords on the modified
accounts.
Method 2: Transferring the XML Configuration and Modifying:
1. Once logged into the switch, configure an IP address on VLAN mgmt and connect a computer with a TFTP server.
configure vlan mgmt ipaddress <SWITCH_IP>
2. Type ls to list files on the switch.
3. Use TFTP to transfer the original configuration file. Typically named “primary.cfg”:
tftp put <TFTP_SERVER_IP> primary.cfg
4. Save a new configuration file with the current factory default credentials
save configuration nopassword
5. Use TFTP to transfer this file:
tftp put <TFTP_SERVER_IP> nopassword.cfg
Primary.cfg:
<account><name><![CDATA[admin]]></name><password><![CDATA[DlWbeK$OF3c54bLuRbBMtpy19rfP/]]></pa
ssword><default_val>0</default_val><readwrite>1</readwrite></account>
Nopassword.cfg:
<account><name><![CDATA[admin]]></name><password><![CDATA[DlWRiK$y/1Cl8umtCcGlxaRAW8.m/]]></pa
ssword><default_val>1</default_val><readwrite>1</readwrite></account>
Primary.cfg:
<account><name><![CDATA[admin]]></name><password><![CDATA[DlWRiK$y/1Cl8umtCcGlxaRAW8.m/]]></pa
ssword><default_val>0</default_val><readwrite>1</readwrite></account>
7. Use TFTP to overwrite the configuration on the switch with the password edited version.
tftp get <TFTP_SERVER_IP> primary.cfg force-overwrite
8. Use the new configuration:
use configuration primary
reboot
9. Log in to switch with admin/no password and verify that the expected configuration is present.
10. If not, transfer any other configuration (.cfg) files on the switch and repeat the process.
Note
To prevent losing access in the future, you can create a failsafe account with the
command: configure failsafe-account.
https://gtacknowledge.extremenetworks.com/
Search: What is the procedure to recover passwords on a SecureStack via the reset button.
Environment:
• Securestack
• C5 Series
• B5 Series
2. While the switch is operational, press and hold the password reset button for 6 seconds; release after 6 seconds. This
changes the login password to the default password and is indicated in the CLI.
3. Log in to the switch using the default password using the console port and assign a new password using the CLI.
Password recovery requires the assistance of Technical Support. Open a case at www.support.avaya.com.
Support will be migrated to the Extreme Networks support website in calendar year 2018.
https://supportforums.cisco.com/discussion/11375006/3560-password-recovery-enabled-procedures
Hold down the green mode button during the boot process.
switch: flash_init
switch: load_helper
switch: boot
After the switch boots and you are at the enable prompt, type the following:
EXAMPLE:
EXAMPLE:
Password Changed.
EXAMPLE:
VSP4850> enable
VSP-4850:(config)#Bob Extreme123 rw
EXAMPLE:
5928GTS-PWR+>enable
5928GTS-PWR+#configure terminal
You are prompted for the password for the user just created
EXAMPLE:
5928GTS-PWR+>enable
5928GTS-PWR+#configure terminal
EXAMPLE:
>enable
#config t
(config)#end
EXAMPLE:
EXAMPLE:
EXAMPLE:
VSP4850> enable
VSP-4850:(config)#prompt switch-01
BOSS EXAMPLE:
5928GTS-PWR+>enable
5928GTS-PWR+#configure terminal
Switch44#(config)#
EXAMPLE:
Switch>enable
Switch#config t
Switch(config)#hostname switch-01
Switch(config)#end
EXAMPLE:
EXAMPLE:
VOSS EXAMPLE:
VSP4850> enable
VSP-4850:(config)#login-message WORD<1-1513>
VSP-4850:(config)#no login-message
EXAMPLE:
VSP4850> enable
VSP-4850:(config)#login-message Logon
VSP-4850:(config)#default max-logins
VSP-4850:(config)#max-logins <0-8>
VSP-4850:(config)#max-logins 4
BOSS EXAMPLE:
5928GTS-PWR+>enable
5928GTS-PWR+#configure terminal
EXAMPLE:
5928GTS-PWR+>enable
5928GTS-PWR+#configure terminal
EXAMPLE:
5928GTS-PWR+>enable
5928GTS-PWR+#configure terminal
5928GTS-PWR+(config)#cli password ?
EXAMPLE:
Switch>enable
Switch#config t
Switch(config)#aaa new-model
Switch(config)#end
Configuring NTP
ExtremeXOS configure ntp [server | peer] add [ip_address | host_name] {key keyid}
{option[burst | initial-burst]}
EXAMPLE: configure ntp server add 134.20.16.35 Missouri key 5 option initial-burst
EXAMPLE:
EXAMPLE:
VSP4850> enable
EXAMPLE:
5928GTS-PWR+>enable
5928GTS-PWR+#configure terminal
5928GTS-PWR+(config)#sntp enable
5928GTS-PWR+(config)#sntp sync-interval 1
s5928GTS-PWR+(config)#ntp sync-now
EXAMPLE:
Switch>enable
#config t
Switch(config)#ntp authenticate
Switch(config)ntp trusted-key 5
Switch(config)#end
Configuring SNMP
SNMPv1
EXAMPLE:
EOS set snmp group groupname user user security-model {v1 | v2c | usm} [volatile |
nonvolatile]
EXAMPLE:
EXAMPLE:
EXAMPLE:
EXAMPLE:
VSP4850> enable
EXAMPLE:
VSP4850> enable
To change:
EXAMPLE:
VSP-4850:>enable
VSP-4850:#configure terminal
BOSS EXAMPLE:
5928GTS-PWR+>enable
5928GTS-PWR+#configure terminal
5928GTS-PWR+(config)#snmp-server enable
EXAMPLE:
5928GTS-PWR+>enable
5928GTS-PWR+#configure terminal
EXAMPLE:
Switch>enable
Switch#config t
Switch(config)end
SNMPv2
EXAMPLE:
EXAMPLE:
EOS set snmp group groupname user user security-model {v1 | v2c | usm} [volatile |
nonvolatile]
EXAMPLE:
EXAMPLE:
EXAMPLE:
EXAMPLE:
VSP-4850:>enable
VSP-4850:#configure terminal
EXAMPLE:
VSP-4850:>enable
VSP-4850:#configure terminal
To change:
EXAMPLE:
VSP-4850:>enable
VSP-4850:#configure terminal
BOSS EXAMPLE:
5928GTS-PWR+>enable
5928GTS-PWR+#configure terminal
5928GTS-PWR+(config)#snmp-server enable
EXAMPLE:
Switch>enable
Switch#config t
Switch(config)end
SNMPv3
EXAMPLE: conf snmpv3 add user EXTRadmin auth md5 extreme!!! privacy des
extreme!!!
EXAMPLE:
EXAMPLE:
conf snmpv3 add access EXTRgroup sec-model usm sec-level priv read-
view defaultAdminView write-view defaultAdminView notify-view
defaultAdminView
EOS set snmp group groupname user user security-model {v1 | v2c | usm} [volatile |
nonvolatile]
EXAMPLE:
EXAMPLE:
set snmp access EXTRgroup security-model usm authentication exact read All write
All notify All nonvolatile
set snmp user user [remote remoteid] [encryption {des | aes}] [privacy
EXAMPLE:
VOSS User admin with full access, SHA pass-phrase levelnot, AES pass-phrase secret100
User operator with read-only access, SHA pass-phrase levelset, AES pass-phrase
secret99
EXAMPLE:
VSP-4850:>enable
VSP-4850:#configure terminal
BOSS This example creates two user names with read-only and read-write privileges,
respectively, and sets a destination for a trap receiver:
EXAMPLE:
5928GTS-PWR+>enable
5928GTS-PWR+#configure terminal
5928GTS-PWR+(config)#snmp-server enable
Cisco snmp-server group [groupname {v1 | v2c | v3{auth | noauth | priv}}] [read
readview] [write writeview] [notify notifyview] [access access-list]
EXAMPLE:
Switch>enable
Switch#config t
(config)end
EXAMPLE:
Switch>enable
Switch#config t
Switch(config) end
Configuring Syslog
0 Emergency
1 Alert
2 Critical
3 Error
4 Warning
5 Notice
6 Informational
7 Debug
EOS set logging server index [ip-addr ip-addr] [facility facility] [severity
severity][descr descr] [port port] [state {enable | disable}]
EXAMPLE:
1 Emergency
2 Alert
3 Critical
4 Error
5 Warning
6 Notice
7 Informational
8 Debug
syslog host <1-10> facility { local0 | local1 | local2 | local3 | local4 | local5 | local6 |
local7 }
syslog host <1-10> maperror { emergency | alert | critical | error | warning | notice |
info | debug }
syslog host <1-10> mapfatal { emergency | alert | critical | error | warning | notice |
info | debug }
syslog host <1-10> mapinfo { emergency | alert | critical | error | warning | notice | info
| debug }
syslog host <1-10> mapwarning { emergency | alert | critical | error | warning | notice |
info | debug }
syslog host <1-10> severity { info | warning | error | fatal } { info | warning | error |
fatal }
syslog host <1-10> severity { info | warning | error | fatal } { info | warning | error |
fatal } { info | warning |
error | fatal }
syslog host <1-10> severity { info | warning | error | fatal } { info | warning | error |
fatal } { info | warning |
EXAMPLE:
VSP-4850:>enable
VSP-4850:#configure terminal
VSP-4850:(config)#syslog enable
VSP-4850:(config)#syslog host 1
BOSS logging [disable] [enable] [level] {[critical] [informational] [none] [serious]} [nv-
level]
{[daemon] [local0] [local1] [local2] [local3] [local4] [local5] [local6] [local7]} [level]
EXAMPLE:
5928GTS-PWR+>enable
5928GTS-PWR+#configure terminal
EXAMPLE:
Switch>enable
Switch#config t
Switch(config)#logging trap 1
Switch(config)#end
EXAMPLE:
EXAMPLE:
EXAMPLE:
EXAMPLE:
C5(su)->router
C5(su)->router>enable
C5(su)->router#configure
C5(su)->router(Config)#exit
EXAMPLE:
#configure terminal
(config-if)#ip dhcp-relay
EXAMPLE:
#configure terminal
(config-if)#ip dhcp-relay
EXAMPLE
>enable
#config t
(config-if)#end
Labeling Ports
EXAMPLE:
EXAMPLE:
#configure terminal
(config-if)#name Uplink-to-Core
EXAMPLE:
#configure terminal
(config-if)#name Uplink-to-Core
EXAMPLE:
Switch>enable
Switch#config t
Switch(config)#interface GigabitEthernet0/1
Switch(config-if)#description Uplink-to-Core
Switch(config-if)#end
EXAMPLE:
EXAMPLE:
EXAMPLE:
EXAMPLE:
#configure terminal
(config)#banner custom
(config)#banner displaymotd
EXAMPLE:
#configure terminal
(config)#banner custom
EXAMPLE:
Switch>enable
Switch#config t
Switch(config)#banner motd ^C
Welcome to Cisco
Switch(config)#end
Enabling WEB/GUI
EXAMPLE:
EXAMPLE:
#configure terminal
(config)#web-server enable
EXAMPLE:
#configure terminal
(config)#web-server enable
(config)#ssl
(config)#https-only
Cisco EXAMPLE:
Switch>enable
Switch#config t
Switch(config)end
EXAMPLE:
enable rmon
EXAMPLE:
EXAMPLE:
#configure terminal
EXAMPLE:
Switch>enable
Switch#config t
Switch(config)rmon native
Switch(config)end
Configuring Software/Image
Downloading New Images
ExtremeXOS download [url url {vr vrname} | image [active | inactive] [[hostname | ipaddress]
filename {{vr} vrname} {block-size block_size} | memorycard filename]
{partition}}
EXAMPLE:
EXAMPLE:
VOSS Use an FTP or SFTP client to copy the software image to the switch using the switch
management IP address. Put the software image in the "/intflash" directory. If using
FTP, make sure the ftp boot config flag is enabled. If using SFTP, make sure the ssh
boot config flag is enabled
EXAMPLE:
#configure terminal
EXAMPLE:
#configure terminal
(config)#ssh
EXAMPLE:
#configure terminal
EXAMPLE:
Switch>enable
…....................................................
EXAMPLE:
EXAMPLE:
EXAMPLE:
#boot -y
BOSS Download the image to the flash and boot the switch to activate the new image
boot
EXAMPLE:
#boot
EXAMPLE:
Switch>enable
save config
EXAMPLE:
C5(su)->save config
EXAMPLE:
EXAMPLE:
#save config
save config
EXAMPLE:
#save config
EXAMPLE:
Switch>enable
EXAMPLE:
Switch>enable
Booting Configurations
EXAMPLE:
C5(su)->configure configs/lab-test
EXAMPLE:
EXAMPLE:
#configure terminal
BOSS
EXAMPLE:
Switch>enable
Backing Up Configurations
Options are a local file path in the configs directory, or the URL of a TFTP, SFTP, or
SCP server.
EXAMPLE:
VOSS The recommended best practice is to backup configurations using sFTP, since it is
secure. Connect to the switch using an sFTP client, log in, and then upload the
desired configuration file. You can also use FTP or TFTP to back up the
configuration.
EXAMPLE:
EXAMPLE:
copy system:running-config
ftp: [[[ // [ username [ : password ]@ ] location ] / directory ] / filename ]
copy nvram:startup-config
ftp: [[[ // [ username [ : password ] @] location ] / directory ] / filename ]
EXAMPLE:
Switch>enable
!!!!!!!!!!!!!!!
EXAMPLE:
EXAMPLE:
EXAMPLE:
>enable
#configure terminal
(config)#save config
(config)#reset -y
EXAMPLE:
#boot default
write erase
Switch>enable
Switch#write erase <or erase startup-config>
Erasing the nvram filesystem will remove all configuration files! Continue? [con
firm]
[OK]
Erase of nvram: complete
Delete the VLAN information from Flash or NVRAM, and reload the switch.
Switch#delete flash:vlan.dat
Delete filename [vlan.dat]?
Delete flash:vlan.dat? [confirm]
Switch#reload
ExtremeXOS configure ports port_list {medium [copper | fiber]} auto off speed speed duplex
[half | full]
EXAMPLE:
EXAMPLE:
EXAMPLE:
>enable
#configure terminal
(config-if)#speed 100
(config-if)#duplex full
EXAMPLE:
>enable
#configure terminal
(config-if)#speed 100
(config-if)#duplex full
EXAMPLE:
Switch>enable
Switch#config t
Switch(config-if)#duplex auto
Switch(config-if)#speed auto
Switch(config-if)#end
EXAMPLE:
EXAMPLE:
[shutdown | no shutdown]
EXAMPLE:
>enable
#configure terminal
(config)#interface
(config-if)#no shutdown
[shutdown | no shutdown]
EXAMPLE:
>enable
#configure terminal
(config)#interface
(config-if)#no shutdown
Cisco no shut
EXAMPLE:
Switch>enable
Switch#configure terminal
Switch(config)#interface GigabitEthernet0/1
Switch(config-if)#no shut
Switch(config-if)#end
Partitioning Ports
EXAMPLE:
EXAMPLE:
EXAMPLE:
System(su)->reset system
This command will reset the system and may disconnect your telnet session.
Resetting...
Resets the CPU on an option module, where mod specifies the module in which the
option module is installed and nemcpu specifies the location of the option module.
Currently, this value can only be 1.
EXAMPLE:
EXAMPLE:
>enable
#configure terminal
(config-if)#channelize enable
BOSS N/A
Switch>enable
Switch#configure terminal
EOS set port inlinepower port-string {[admin {off | auto}] [priority {critical | high |
low}] [type
type]}
EXAMPLE:
[poe-shutdown | no poe-shutdown]
EXAMPLE:
>enable
#configure terminal
(config-if)#poe-shutdown
[poe-shutdown | no poe-shutdown]
EXAMPLE:
>enable
#configure terminal
(config-if)# poe-shutdown
Cisco power inline { auto [ max max-wattage ] | never | static [ max max-wattage ]}
EXAMPLE:
Switch>enable
Switch#configure terminal
ExtremeXOS create mirror mirror_name {to [port port | port_list port_list loopback-port port ]
{ remote-tag rtag }} {description mirror-desc}
configure mirror mirror_name add [vlan name |port port {ingress | egress |
ingress-and-egress | anomaly}]
EXAMPLE:
VOSS mirror-by-port instance number {1-479} in-port port out-port port mode [both |
rx | tx] enable
EXAMPLE:
>enable
#configure terminal
BOSS port-mirroring instance number {1-4} [allow-traffic mode] mode [Adst | Asrc |
AsrcBdst | AsrcBdstOrBsrcAdst | AsrcOrAdst | disable | ManytoOneRx |
ManytoOneRxTx | ManytoOneTx | Xrx | XrxOrXtx | XrxOrYtx | XrxYtx |
XrxYtxOrYrxXtx | Xtx] monitor-port port mirror-port-X port
EXAMPLE:
>enable
#configure terminal
EXAMPLE:
Switch>enable
Switch (config)end
ExtremeXOS create mirror mirror_name {to [port port | port_list port_list loopback-port port ]
{ remote-tag rtag }} {description mirror-desc}
configure mirror mirror_name add [vlan name |port port {ingress | egress |
ingress-and-egress | anomaly}]
EOS Use the set mirror vlan command to assign a VLAN to be reserved for mirroring. If a
mirrored VLAN is created, all mirrored traffic egresses VLAN tagged. All traffic on
the mirror VLAN is flooded.
EXAMPLE:
Alternative: SMON port mirroring support allows you to redirect traffic on ports
remotely using SMON MIBs. To configure an SMON MIB port mirror, see the latest
Configuration Guide.
VOSS N/A
EXAMPLE:
Cisco remote-span
EXAMPLE:
Source Switch:
Switch1(config-vlan)# remote-span
Switch1(config-vlan)# end
reflector-port fastEthernet0/24
Destination Switch:
Switch2(config-vlan)# remote-span
Switch2(config-vlan)# end
Switch2(config)# exit
Layer 2 Commands
Configuring VLANs
Configuring Port-Based (Untagged)
EXAMPLE:
EXAMPLE:
VOSS vlan create {vlan id} name {name} type [port-mstprstp {instance id} | protocol-
mstprstp | {instance id} | pvlan-mstprstp {instance id} | spbm-bvlan
EXAMPLE:
>enable
#configure terminal
BOSS vlan create {vlan id} name {name} type [port | private-vlan | protocol | spbm-
bvlan | spbm-switchedUni | voice-vlan]
EXAMPLE:
>enable
#configure terminal
EXAMPLE:
Switch>enable
Switch (config-vlan)#exit
Switch (config-if)#end
EXAMPLE:
EXAMPLE:
VOSS vlan create {vlan id} name {name} type [port-mstprstp {instance id} |
protocol-mstprstp | {instance id} | pvlan-mstprstp {instance id} | spbm-
bvlan
encapsulation dot1q
EXAMPLE:
>enable
#configure terminal
BOSS vlan create {vlan id} name {name} type [port | private-vlan | protocol |
spbm-bvlan | spbm-switchedUni | voice-vlan]
EXAMPLE:
>enable
#configure terminal
EXAMPLE:
Switch>enable
Switch (config-vlan)#exit
Switch (config-if)#end
EXAMPLE:
create private-vlan companyx
EXAMPLE:
S Chassis(rw)->configure
S Chassis(rw-config-intf-vlan.0.100)->secondary-vlan 200
VOSS vlan create {vlan id} type pvlan-mstprstp {instance} secondary {secondary-
vlan-id}
EXAMPLE:
>enable
#configure terminal
EXAMPLE:
>enable
#configure terminal
EXAMPLE:
Switch>enable
Switch(config)#feature private-vlan
Switch (config-vlan)#exit
Switch (config)#vlan 200
Switch (config-vlan)#end
Configuring EAPS
EXAMPLE:
Note: transit switch is configured the same except for mode = transit
EOS N/A
VOSS N/A
BOSS N/A
Cisco N/A
Configuring ERPS
#ERPS
enable erps
EOS N/A
VOSS N/A
BOSS N/A
Cisco N/A
Configuring LAGs
EXAMPLE:
EXAMPLE:
Optional:
EXAMPLE:
Switch:1>enable
Switch:1#config t
Switch:1(config)# mlt 10
EXAMPLE:
Switch >enable
Switch #config t
EXAMPLE:
>enable
# config t
(config-if-range# end
Configuring MLAGs
EXAMPLE:
(X440-SW1)
MLAG Configuration
(X440-SW2)
MLAG Configuration
EOS N/A
VOSS Non-SPB Option for Split Multi-link Trunking utilizing Simplified vIST:
When you enable Simplified vIST with the virtual-ist enable command, two
VLANs are automatically created to support vIST. The VLAN IDs are: 4086 and
4087. SPBM must not be enabled on the vIST peers or any router that
participates in the network.
ip address <A.B.C.D/X>
[,...]}
virtual-ist enable
[,...]}
smlt
EXAMPLE:
Switch:1>enable
Switch:1#configure terminal
Switch:1>enable
Switch:1#configure terminal
Switch:1(config)#mlt 3 enable
Switch:1(config)#interface mlt 3
Switch:1(config-if)#smlt
Switch:1(config-if)#exit
Switch:1(config)#mlt 5 enable
Switch:1(config)#interface mlt 5
Switch:1(config-if)#virtual-ist enable
Switch:1(config-if)#exit
Switch:1(config)#interface vlan 50
Switch:1(config-if)#exit
Switch:1(config-if)#exit
BOSS N/A
Cisco Cisco’s implementation of MLAG uses vPC with limited model support to Nexus
switching.
Configuring LLDP
configure lldp port all advertise vendor-specific med policy application voice vlan
<Vlan name> dscp 46
EOS set lldp port status {tx-enable | rx-enable | both | disable} {port-string}
EXAMPLE:
Port Parameters:
EXAMPLE:
Switch:1>enable
Switch:1#configure terminal
Switch:1(config-if)#exit
Switch:1(config)#lldp tx-interval 31
Port Parameters:
MED Policies:
EXAMPLE:
Switch>enable
Switch#configure terminal
Switch(config)#default lldp
Switch(config-if)#exit
EXAMPLE:
Switch>enable
Switch#configure terminal
Switch(config)#lldp run
Configuring CDP
EXAMPLE:
EXAMPLE:
EXAMPLE:
Switch:1>enable
Switch:1#configure terminal
BOSS N/A
EXAMPLE:
Switch>enable
Switch#configure terminal
Switch(config)#cdp run
ExtremeXOS configure stpd stpd_name add vlan vlan_name ports [all | port_list] {[dot1d
|emistp | pvst-plus]}
EXAMPLE:
enable stpd s0
EXAMPLE:
EXAMPLE:
Switch:1>enable
Switch:1#configure terminal
Switch:1(config-if)#exit
EXAMPLE:
Switch>enable
Switch#configure terminal
Switch(config-if)#exit
EXAMPLE:
Switch>enable
Switch#configure terminal
ExtremeXOS configure stpd stpd_name add vlan vlan_name ports [all | port_list] {[dot1d
|emistp | pvst-plus]}
EXAMPLE:
Switch>enable
Switch#configure terminal
ExtremeXOS configure stpd stpd_name add vlan vlan_name ports [all | port_list] {[dot1d
|emistp | pvst-plus]}
EXAMPLE:
enable stpd s0
EXAMPLE:
EXAMPLE:
Switch:1>enable
Switch:1#configure terminal
EXAMPLE:
Switch>enable
Switch#configure terminal
Switch(config-if)#exit
EXAMPLE:
Switch>enable
Switch#configure terminal
configure stpd stpd_name mode [dot1d | dot1w | mstp [cist | msti instance]]
EXAMPLE:
enable stpd s0
EXAMPLE:
EXAMPLE:
Switch:1>enable
Switch:1#configure terminal
EXAMPLE:
Switch>enable
Switch#configure terminal
Switch(config-if)#exit
EXAMPLE:
Switch>enable
Switch#configure terminal
ExtremeXOS ELRP
enable elrp-client
EXAMPLE:
enable elrp-client
EOS N/A
slpp enable
EXAMPLE:
Switch:1>enable
Switch:1#configure terminal
Switch:1(config-if)# exit
Switch:1(config-if)# exit
EXAMPLE:
Switch>enable
Switch#configure terminal
Note: SLPP packets are generated only on switches that are configured with
SLPP, for example, ERS 5000 Series or ERS 8800. The switch does not support
SLPP. When you enable SLPP Guard on the switch, it must be connected to
another Avaya switch that supports SLPP, and SLPP must be enabled on that
switch.
Cisco N/A
VLAN EXAMPLE:
802.1p EXAMPLE:
EXAMPLE:
set policy profile 1 name "purple" pvid-status enable pvid 7 cos-status enable cos
4 tagged-vlans 7
The CoS setting for CoS-4 applying DSCP value of EF to purple traffic.
VOSS QoS by default is enabled on all NNI interfaces. Depending on the switch, QoS
may still have to be enabled on the UNI interface, or filters must be used to
provide end-to-end QoS. On the VSP 4000, VSP 8000, VSP 7200, and VSP
9000, the interface level parameters “802.1p-override disable”, “enable-diffserv
enable”, and “no access-diffserv enable” are the default settings. On an UNI
interface, this has the overall result of honoring p-bits for bridge traffic and
DSCP values for routed traffic.
BOSS By default, the QoS queues configured on the ERS platform is Queue Set 2 (2
queues). To map the queues one for one, set the Queue Set to 8 (8 queues):
EXAMPLE:
Switch>enable
Switch#configure terminal
Switch(config-if)# exit
EXAMPLE:
>enable
Switch#configure terminal
Switch(config)#mls-qos
Switch(config)#interface fastethernet0/1
Switch(config-if)#exit
EXAMPLE:
EXAMPLE:
There is no option to set the frame size - Max Frame Size: 9216
EXAMPLE:
Switch:1> enable
EXAMPLE:
Switch>enable
Switch#configure terminal
Switch(config)# jumbo-frames
EXAMPLE:
Switch#config t
Switch(config)# end
ExtremeXOS configure ports port_list {tagged tag} vlan vlan_name [limit-learning number
{action [blackhole | stop-learning]} | lock-learning | unlimited-learning |
unlock-learning]
EXAMPLES:
set maclock static {port-string} {value. Value specifies the maximum number of
static MAC addresses allowed per port. Valid values are 0 to 20.
set maclock firstarrival {port-string} {value}. Value specifies the number of first
arrival end station MAC addresses to be allowed connections to the port. Valid
values are 0 to 600.
EXAMPLE:
EXAMPLE:
Switch:1>enable
Switch:1#configure terminal
Switch:1(config-if)# exit
EXAMPLE:
Switch(config)#mac-security enable
Switch(config-if)#mac-security enable
Switch(config-if)#exit
switchport port-security
EXAMPLE:
Switch>enable
Switch(config)#interface gigabitethernet0/1
Switch(config-if)#switchport port-security
Layer 3 Commands
Configuring VLAN IP Addresses
EXAMPLE:
EXAMPLE:
C5(su)->router
C5(su)->router>enable
C5(su)->router#configure
C5(su)->router(Config)#interface vlan 1
VOSS After creating the VLAN and entering config-if mode within that vlan.
EXAMPLE:
Switch#configure terminal
Switch(config)#interface vlan 1
Switch(config-if)#exit
BOSS After creating the VLAN and entering config-if mode within that vlan.
EXAMPLE:
Switch#configure terminal
Switch(config)#interface vlan 1
Switch(config-if)#exit
EXAMPLE:
Switch#configure terminal
Switch(config-if)#end
EXAMPLE:
EOS Use this command to disable IP routing on the device. By default, IP routing is
enabled when interfaces are configured; they include no shutdown.
ip routing
no ip routing
no shutdown
shutdown
EXAMPLE:
C5(su)->router
C5(su)->router>enable
C5(su)->router#configure
C5(su)->router(Config)#ip routing
C5(su)->router(Config)#interface vlan 1
VOSS ip routing
EXAMPLE:
Switch(config)# ip routing
BOSS ip routing
EXAMPLE:
Switch(config)# ip routing
EXAMPLE:
Switch#config t
Switch(config)# ip routing
Switch(config-if)#end
EXAMPLE:
Enable rip
no router rip
Use this command to configure the administrative distance for RIP routes. The
no form of this command resets RIP administrative distance to the default value
of 120.
distance {weight}
no distance {weight}
Use this command to allow RIP to receive update packets on an interface. The
no form of this command denies the reception of RIP updates. By default,
receiving is enabled on all routing interfaces.
EXAMPLE:
C5(su)->router
C5(su)->router>enable
C5(su)->router#configure
C5(su)->router(Config)#router rip
C5(su)->router(Config-router)#distance 100
C5(su)->router(Config-router)#passive-interface vlan 2
network {ip_address}
EXAMPLE:
network {ip_address}
EXAMPLE:
network ip-address
EXAMPLE:
Switch>enable
Switch#configure terminal
Switch(config)#router rip
Switch(config-router)#network 10.0.0.0
Switch(config-router)#end
ExtremeXOS configure ospf add vlan [vlan-name | all] area area-identifier {passive}
EXAMPLE:
Enable ospf
EOS Use this command to set the OSPF router ID for the device. This IP address must
be set manually to run OSPF. The no form of this command removes the router
ID for the device.
router id {ip-address}
no router id
no ip ospf areaid
ip ospf enable
no ip ospf enable
EXAMPLE:
C5(su)->router(Config)#router id 182.127.62.1
C5(su)->router#conf terminal
C5(su)->router(Config)#interface vlan 1
enable
switch(config-ospf)# enable
enable
switch(config-router)# enable
EXAMPLE:
#config t
(config-route)#end
ExtremeXOS configure iproute add [ipNetmask | ip_addr mask] gateway {bfd} {metric}
{multicast | multicast-only | unicast | unicast-only} {vlan egress_vlan} {vr
vrname}
EXAMPLE:
EXAMPLE:
EXAMPLE:
EXAMPLE:
Switch#configure terminal
EXAMPLE Default:
Switch#configure terminal
EXAMPLE:
Switch#configure terminal
EXAMPLE Default:
Switch#configure terminal
EXAMPLE:
Switch>enable
Switch#configure terminal
EXAMPLE default:
Switch>enable
Switch#configure terminal
EXAMPLE:
interface-name}
EXAMPLE:
System(su)->configure
System(rw-config)->interface loop.0.2
System(rw-config-intf-loop.0.2)->no shutdown
EXAMPLE:
BOSS N/A
EXAMPLE:
Switch>enable
Switch#configure terminal
Switch(config)#interface loopback2
Switch(config-if)#end
Switch(config-router)#end
EXAMPLE:
MASTER
enable vrrp
BACKUP
enable vrrp
EXAMPLE:
Master
router
enable
configure
interface vlan 2
no shutdown
exit
interface loopback 1
no shutdown
exit
router vrrp
create vlan 2 1
enable vlan 2 1
exit
The "1" at the end of the 'address vlan' command indicates this router owns IP
address 10.16.128.1.
BACKUP
router
enable
configure
interface vlan 2
no shutdown
exit
interface loopback 1
no shutdown
exit
router vrrp
create vlan 2 1
enable vlan 2 1
exit
The "0" at the end of the 'address vlan' command indicates this router does not
own IP address 10.16.128.1
EXAMPLE:
MASTER
BACKUP
EXAMPLE:
MASTER
BACKUP
Cisco EXAMPLE:
MASTER
Switch>enable
Switch#configure terminal
Switch(config)#interface gigabitethernet0/1
Switch(config-if)#vrrp 1 ip 10.16.128.1
Switch(config-if)#end
BACKUP
Switch>enable
Switch#configure terminal
Switch(config)#interface gigabitethernet0/1
Switch(config-if)#vrrp 1 ip 10.16.128.1
Switch(config-if)#end
Configuring Multicast
Configuring PIM-SM
configure pim {ipv4 | ipv6} add vlan [vlan-name | all] {dense | sparse}
{passive}
configure pim {ipv4 | ipv6} crp vlan vlan_name [none | policy] {priority}
configure pim cbsr {ipv4 | ipv6} [{vlan} vlan_name {priority [0-254]} | none]
EXAMPLE:
Enable pim
entry anyname {
if match any { }
EOS C5-series
ip pimsm
no ip pimsm
EXAMPLE:
C5(su)->router
C5(su)->router>enable
C5(su)->router#config
C5(su)->router(Config)# ip pimsm
C5(su)->router(Config)#interface vlan 10
S-series
ip pim sparse-mode
no ip pim sparse-mode
no ip bsr-candidate interface-address
EXAMPLE:
S Chassis(su-config)->interface vlan 1
EXAMPLE:
EXAMPLE:
ip pim version [ 1 | 2 ]
EXAMPLE:
Switch>enable
Switch#configure terminal
Configuring PIM-DM
configure pim {ipv4 | ipv6} add vlan [vlan-name | all] {dense | sparse}
{passive}
EXAMPLE:
enable pim
no ip pim dense-mode
EXAMPLE:
S Chassis(su-config)->interface vlan 1
VOSS N/A
BOSS N/A
ip pim version [ 1 | 2 ]
EXAMPLE:
Switch>enable
Switch#configure terminal
EXAMPLE:
EXAMPLE:
set policy profile 1 name "purple" pvid-status enable pvid 7 cos-status enable cos
4 tagged-vlans 7
The CoS setting for CoS-4 applying DSCP value of EF to purple traffic
access-diffserv enable
EXAMPLE:
Switch(config-if)# exit
EXAMPLE:
Switch(config)# qos policy 100 name TEST port 1/12 clfr-type classifier clfr-id
200 meter 10000 precedence 7
match input-interfaceinterface-id-list
policy-map policy-map-name
class-map class-map-name
policy-map policy-map-name
service-policy policy-map-name
EXAMPLE:
Switch>enable
Switch#configure terminal
Switch(config)#mls qos
Switch(config)#class-map map-105
Switch(config-cmap)#exit
Switch(config)#policy-map port-map-105
Switch(config-pmap)#class map-105
Switch(config-pmap-c)#set dscp 7
Switch(config-pmap-c)#exit
Switch(config-pmap)#exit
Switch(config-if)#end
EXAMPLE:
EXAMPLE:
EXAMPLE:
Switch(config)#ip dhcp-snooping
EXAMPLE:
Switch(config)#ip dhcp-snooping
EXAMPLE:
Switch>enable
EXAMPLE:
no ip gratuitous-arp
EXAMPLE:
(rw-config)->interface vlan 1
VOSS no ip gratuitous-arp
EXAMPLE:
Switch#configure terminal
Switch(config)#no ip gratuitous-arp
BOSS N/A
Cisco no ip gratuitous-arp
EXAMPLE:
enable dos-protect
EOS S-SERIES
EXAMPLE:
S Chassis(rw-config)->hostdos enable
C5-SERIES
set dos-control [all | sipdip | firstfrag firstfrag | tcpfrag | l4port | icmp icmp
EXAMPLE:
VOSS N/A
BOSS N/A
Cisco N/A
Cisco Documentation
Cisco Configuring Passwords and Privileges
http://www.cisco.com/c/en/us/td/docs/ios/12_2/security/configuration/guide/fsecur_c/scfpass.pdf
http://www.cisco.com/c/en/us/td/docs/security/fwsm/fwsm31/configuration/guide/fwsm_cfg/basic_f.pdf
http://www.cisco.com/c/en/us/support/docs/switches/catalyst-2900-xl-series-switches/24328-
156.html#reset_ios
http://www.cisco.com/c/en/us/td/docs/ios/cether/configuration/guide/ce_lnkbndl.html#wp1053903