0% found this document useful (0 votes)
195 views

Lab - Implement Eigrp For Ipv4: Topology

Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
0% found this document useful (0 votes)
195 views

Lab - Implement Eigrp For Ipv4: Topology

Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
You are on page 1/ 15

Lab - Implement EIGRP for IPv4

Topology

Addressing Table
Device Interface IP Address Subnet Mask

R1 G0/0/0 10.0.12.1 255.255.255.0

R1
G0/0/1.1 172.16.1.1 255.255.255.0

R1
G0/0/1.2 192.168.1.1 255.255.255.0
R2 G0/0/0 10.0.12.2 255.255.255.0

R2
G0/0/1 10.0.23.2 255.255.255.0

R3 G0/0/0 10.0.23.3 255.255.255.0

R3
G0/0/1 172.16.13.1 255.255.255.0

R3
Loopback 0 192.168.3.1 255.255.255.0

D2 G1/0/1 172.16.1.2 255.255.255.0

D2
G1/0/11 172.16.13.2 255.255.255.0
PC1 NIC DHCP

Objectives
Part 1: Build the Network and Configure Basic Device Settings

© 2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 1 of 15 www.netacad.com
Lab - Implement EIGRP for IPv4

Part 2: Configure and Verify EIGRP for IPv4


Part 3: Tune EIGRP for IPv4

Background / Scenario
EIGRP is an interior gateway routing protocol created by Cisco and published as open source in 2016 in RFC
7868. It is a very ef f icient distance-vector based protocol. In this lab, you will conf igure and examine EIGRP in
two f orms, Classic EIGRP and Named EIGRP. Named EIGRP is an update to Classic EIGRP that added
multiprotocol support and def ault support for wide metrics.
Note: This lab is an exercise in conf iguring options available f or EIGRP supporting IPv4 and does not
necessarily ref lect implementation best practices.
Note: The routers used with CCNP hands-on labs are Cisco 4221 with Cisco IOS XE Release 16.9.4
(universalk9 image). The switches used in the labs are Cisco Catalyst 3650 with Cisco IOS XE Release
16.9.4 (universalk9 image). Other routers, switches, and Cisco IOS versions can be used. Depending on the
model and Cisco IOS version, the commands available and the output produced might vary f rom what is
shown in the labs. Ref er to the Router Interf ace Summary Table at the end of the lab f or the correct interf ace
identif iers.
Note: Make sure that the routers and switches have been erased and have no startup conf igurations. If you
are unsure, contact your instructor.

Required Resources
• 3 Routers (Cisco 4221 with Cisco IOS XE Release 16.9.4 universal image or comparable)
• 2 Switches (Cisco 3650 with Cisco IOS XE Release 16.9.4 universal image or comparable)
• 1 PC (Choice of operating system with a terminal emulation program installed)
• Console cables to conf igure the Cisco IOS devices via the console ports
• Ethernet cables as shown in the topology

Part 1: Build the Network and Configure Basic Device Settings


In Part 1, you will set up the network topology and conf igure basic settings on routers.

Step 1: Cable the network as shown in the topology.


Attach the devices as shown in the topolo gy diagram, and cable as necessary.

Step 2: Configure basic settings for each device.


a. Console into each device, enter global conf iguration mode, and apply the basic settings. The startup
conf igurations f or each device are provided below.
Open configuration window

Router R1
hostname R1
no ip domain lookup
banner motd # R1, Implement EIGRP for IPv4 #
line con 0
exec-timeout 0 0
logging synchronous
exit
line vty 0 4

© 2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 2 of 15 www.netacad.com
Lab - Implement EIGRP for IPv4

privilege level 15
exec-timeout 0 0
password cisco123
login
exit
interface g0/0/1
no ip address
no shutdown
exit
interface g0/0/1.1
encapsulation dot1q 1
ip address 172.16.1.1 255.255.255.0
no shutdown
exit
interface g0/0/1.2
encapsulation dot1q 2
ip address 192.168.1.1 255.255.255.0
no shutdown
exit
interface g0/0/0
ip address 10.0.12.1 255.255.255.0
no shutdown
exit
ip dhcp pool HOSTS
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
exit
end
Router R2
hostname R2
no ip domain lookup
banner motd # R2, Implement EIGRP for IPv4 #
line con 0
exec-timeout 0 0
logging synchronous
exit
line vty 0 4
privilege level 15
exec-timeout 0 0
password cisco123
login
exit
interface g0/0/0
ip address 10.0.12.2 255.255.255.0
no shutdown

© 2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 3 of 15 www.netacad.com
Lab - Implement EIGRP for IPv4

exit
interface g0/0/1
ip address 10.0.23.2 255.255.255.0
no shutdown
exit
end
Router R3
hostname R3
no ip domain lookup
banner motd # R3, Implement EIGRP for IPv4 #
line con 0
exec-timeout 0 0
logging synchronous
exit
line vty 0 4
privilege level 15
exec-timeout 0 0
password cisco123
login
exit
interface g0/0/0
ip address 10.0.23.3 255.255.255.0
no shutdown
exit
interface g0/0/1
ip address 172.16.13.1 255.255.255.0
no shutdown
exit
interface loopback 0
ip address 192.168.3.1 255.255.255.0
no shutdown
exit
end
Switch D1
hostname D1
no ip domain lookup
banner motd # D1, Implement EIGRP for IPv4 #
line con 0
exec-timeout 0 0
logging synchronous
exit
line vty 0 4
privilege level 15
exec-timeout 0 0

© 2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 4 of 15 www.netacad.com
Lab - Implement EIGRP for IPv4

password cisco123
login
exit
vlan 2
name HOST-VLAN
exit
interface range g1/0/1 - 24, g1/1/1 - 4
shutdown
exit
interface g1/0/1
switchport mode access
spanning-tree portfast
no shutdown
exit
interface g1/0/11
switchport mode trunk
no shutdown
exit
interface g1/0/23
switchport mode access
switchport access vlan 2
spanning-tree portfast
no shutdown
exit
end
Switch D2
hostname D2
no ip domain lookup
ip routing
banner motd # D2, Implement EIGRP for IPv4 #
line con 0
exec-timeout 0 0
logging synchronous
exit
line vty 0 4
privilege level 15
exec-timeout 0 0
password cisco123
login
exit
interface range g1/0/1 - 24, g1/1/1 - 4
shutdown
exit
interface g1/0/1
no switchport

© 2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 5 of 15 www.netacad.com
Lab - Implement EIGRP for IPv4

ip address 172.16.1.2 255.255.255.0


no shutdown
exit
interface g1/0/11
no switchport
ip address 172.16.13.2 255.255.255.0
no shutdown
exit
end
b. Set the clock on each device to UTC time.
c. Save the running conf iguration to startup -conf ig.
Close configuration window

d. Verif y that PC1 receives an address via DHCP.


e. Verif y that PC1 can ping its def ault gateway.

Part 2: Configure and Verify EIGRP for IPv4


In this part of the lab, you will conf igure and verif y EIGRP in the network. R1 and R3 will used Named EIGRP,
while R2 will use Classic EIGRP. Af ter you have established the network, you will examine the dif f erences in
how each version of EIGRP deals with metrics.
For the lab, you will use the Autonomous System number 27 on all routers.

Step 1: Configure Classic EIGRP for IPv4 on R2.


a. Start the conf iguration of Classic EIGRP by issuing the router eigrp 27 command.
Open configuration window

R2(config)# router eigrp 27


b. Conf igure the EIGRP router ID using the eigrp router-id command. Use the number 2.2.2.2 f or R2.
R2(config-router)# eigrp router-id 2.2.2.2
c. Identif y the interf aces that should be speaking EIGRP and the networks that should be included in the
EIGRP topology table. This is done with the network command.
It is best to be as specif ic as possible when creating network statements, while balancing ef f iciency and
the number of commands necessary. For our lab example, we will use network 10.0.0.0 255.255.224.0
to specif y the interf aces. This covers less network space than 10.0.0.0/8, while including both interf aces
with a single network command.
R2(config-router)# network 10.0.0.0 255.255.224.0
R2(config-router)# end
d. Verif y the interf aces now involved in EIGRP with the show ip eigrp interfaces command.
R2# show ip eigrp interfaces
EIGRP-IPv4 Interfaces for AS(27)
Xmit Queue PeerQ Mean Pacing Time Multicast
Pending
Interface Peers Un/Reliable Un/Reliable SRTT Un/Reliable Flow
Timer Routes
Gi0/0/0 0 0/0 0/0 0 0/0 0 0
Gi0/0/1 0 0/0 0/0 0 0/0 0 0
Close configuration window

© 2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 6 of 15 www.netacad.com
Lab - Implement EIGRP for IPv4

Step 2: Configure Named EIGRP for IPv4 on R1 and R3.


a. Start the conf iguration of Named EIGRP by issuing the router eigrp [ name ] command. The name
parameter can be a number, but the number does not identif y an Autonomous System as it does with
Classic EIGRP, it simply identif ies the process. For our purposes, name the process BASIC-EIGRP-LAB.
Open configuration window

R1(config)# router eigrp BASIC-EIGRP-LAB


b. Enter into address-f amily conf iguration mode with the address-family ipv4 unicast autonomous-
system 27 command.
R1(config-router)# address-family ipv4 unicast autonomous-system 27
c. Conf igure the EIGRP router ID using the eigrp router-id command. Use the number 1.1.1.1 f or R1.
R1(config-router-af)# eigrp router-id 1.1.1.1
d. Identif y the interf aces that should be speaking EIGRP and the networks that should be included i n the
EIGRP topology table. This is done with the network command. In this case, the conf iguration requires
three network commands. An example f or R1 f ollows:
R1(config-router-af)# network 10.0.12.0 255.255.255.0
R1(config-router-af)# network 172.16.1.0 255.255.255.0
R1(config-router-af)# network 192.168.1.0 255.255.255.0
R1(config-router-af)# end
Close configuration window

e. Repeat Steps 2a through 2d f or R3 and D2. Use 3.3.3.3 f or the router ID on R3, and 132.132.132.132 f or
the router ID on D2. Conf igure the appropriate network statements on both devices according to the
Addressing Table.
Open configuration window
Close configuration window

Step 3: Verify EIGRP for IPv4.


a. A f ew seconds af ter conf iguring the network statements , you should have seen syslog messages noting
that EIGRP adjacencies have been f ormed.
*Feb 18 15:49:34.243: %DUAL-5-NBRCHANGE: EIGRP-IPv4 27: Neighbor 10.0.12.2
(GigabitEthernet0/0/0) is up: new adjacency
b. To verif y that routing is working, ping f rom PC1 to interf ace Loopback 0 on R3 (192.168.3.1). The ping
should be successf ul. You can also randomly ping other addresses in the topology.
c. On R1, examine the EIGRP entries in the IP routing table using the show ip route eigrp | begin
Gateway command. As you can see, there is one path installed in the routing table f or the network, and
two paths f or the 192.168.3.0/24 network. Take note of the metric values listed.
Open configuration window

R1# show ip route eigrp | begin Gateway


Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks


D 10.0.23.0/24 [90/15360] via 10.0.12.2, 00:00:12, GigabitEthernet0/0/0
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
D 172.16.13.0/24
[90/15360] via 172.16.1.2, 00:00:12, GigabitEthernet0/0/1.1
D 192.168.3.0/24
[90/16000] via 172.16.1.2, 00:00:12, GigabitEthernet0/0/1.1
[90/16000] via 10.0.12.2, 00:00:12, GigabitEthernet0/0/0

d. Now examine the EIGRP topology table using the show ip eigrp topology all-links command. The all-
links parameter instructs the router to display all available routes, including the ones that are not
successors or f easible successors.

© 2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 7 of 15 www.netacad.com
Lab - Implement EIGRP for IPv4

Remember that the topology table is EIGRP’s database of route inf ormation. EIGRP selects the best
paths f rom this database, based on the DUAL algorithm, and of f ers them to the IP routing table. However,
the IP routing table does not have to use those of fered paths, because the router may have learned about
the same network f rom a more reliable routing source, which would be a routing source with a lower
administrative distance.
R1# show ip eigrp topology all-links
EIGRP-IPv4 VR(BASIC-EIGRP-LAB) Topology Table for AS(27)/ID(1.1.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 192.168.3.0/24, 2 successors, FD is 2048000, serno 26


via 10.0.12.2 (2048000/1392640), GigabitEthernet0/0/0
via 172.16.1.2 (2048000/1392640), GigabitEthernet0/0/1.1
P 172.16.13.0/24, 1 successors, FD is 1966080, serno 16
via 172.16.1.2 (1966080/1310720), GigabitEthernet0/0/1.1
via 10.0.12.2 (2621440/1966080), GigabitEthernet0/0/0
P 192.168.1.0/24, 1 successors, FD is 1310720, serno 3
via Connected, GigabitEthernet0/0/1.2
P 172.16.1.0/24, 1 successors, FD is 1310720, serno 2
via Connected, GigabitEthernet0/0/1.1
P 10.0.23.0/24, 1 successors, FD is 1966080, serno 27
via 10.0.12.2 (1966080/1310720), GigabitEthernet0/0/0
via 172.16.1.2 (2621440/1966080), GigabitEthernet0/0/1.1
P 10.0.12.0/24, 1 successors, FD is 1310720, serno 1
via Connected, GigabitEthernet0/0/0

We will f ocus on the routes, highlighted in the above output, to 192.168.3.0/24 and 10.0.23.0/24. There
are several things to notice:
o The entry f or the 192.168.3.0/24.0 network shows two successors, while the entry f or 10.0.23.0/24
shows only one successor. Both entries show two paths. The path with the lowest Feasible Distance
(FD) is selected as the successor and is of f ered to the routing table. For 192.168.3.0/24, there are
two paths with equal FD (2048000). Theref ore, both are successors and both are of f ered to the
routing table. In the case of 10.0.23.0/24, the FD is listed as 19660800. The path via 10.0.12.2 shows
that number as the FD (f irst number in parentheses). The path via 172.16.1.2 shows an FD of
2621440, which is higher than the current f easible distance. So that path, although valid, is a higher
cost path and is not of f ered to the routing table.
o The FD listed in the topology table does not match the metric listed in the routing table. For
192.168.3.0/24, the routing table shows the metric value 16000, while the topology table shows the
FD as 2048000. This is due to the routing table having a limit of 4 bytes (32 bits) f or metric
inf ormation while EIGRP on R1 is using EIGRP wide metrics, which are 64 bits. Wide metrics are
used by Named EIGRP by def ault. To work around the 32-bit metric size limitation in the routing
table, EIGRP divides the wide-metric value by the EIGRP_RIB_SCALE value, which def aults to 128,
as you will see next in the output f or the show ip protocols command. The value 2048000 divided by
128 is 16000.
Note: A network with mixed EIGRP implementations (Named and Classic in the same routing
domain), will have some loss of route clarity which could lead to sub-optimal path selection. The
recommended implementation is to use Named EIGRP in all cases.
o There are no f easible successors listed in the topology table f or 192.168. 3.0/24 or 10.0.23.0/24. The
f easibility condition requires that the reported distance (RD) to a destination network be less than the
current f easible distance f or a next-hop to be considered a f easible successor to the route. In the
case of 10.0.23.0/24, the RD of the path via 172.16.1.2 is the second number listed:

© 2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 8 of 15 www.netacad.com
Lab - Implement EIGRP for IPv4

(2621440/1966080). Because the RD is equal to the current FD, this route is disqualif ied as a f easible
successor. If the path via 172.16.1.2 were to be lost, R1 would have to send queries to f ind a new
way to get to 10.0.23.0/24. Feasible successors only exist in the topology table. Only successors
appear in the routing table.
e. To see the Routing Inf ormation Base (RIB) Scale and Metric Scale values, as well as other protocol
inf ormation, issue the show ip protocols | section eigrp command.
R1# show ip protocols | section eigrp
Routing Protocol is "eigrp 27"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP-IPv4 VR(BASIC-EIGRP-LAB) Address-Family Protocol for AS(27)
Metric weight K1=1, K2=0, K3=1, K4=0, K5=0 K6=0
Metric rib-scale 128
Metric version 64bit
Soft SIA disabled
NSF-aware route hold timer is 240
EIGRP NSF disabled
NSF signal timer is 20s
NSF converge timer is 120s
Router-ID: 1.1.1.1
Topology : 0 (base)
Active Timer: 3 min
Distance: internal 90 external 170
Maximum path: 4
Maximum hopcount 100
Maximum metric variance 1
Total Prefix Count: 5
Total Redist Count: 0

f. To examine details about a particular path, issue the show ip eigrp topology [address] command.
R1# show ip eigrp topology 192.168.3.0/24
EIGRP-IPv4 VR(BASIC-EIGRP-LAB) Topology Entry for AS(27)/ID(1.1.1.1) for
192.168.3.0/24
State is Passive, Query origin flag is 1, 2 Successor(s), FD is 2048000, RIB is
16000
Descriptor Blocks:
10.0.12.2 (GigabitEthernet0/0/0), from 10.0.12.2, Send flag is 0x0
Composite metric is (2048000/1392640), route is Internal
Vector metric:
Minimum bandwidth is 1000000 Kbit
Total delay is 21250000 picoseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 2
Originating router is 3.3.3.3
172.16.1.2 (GigabitEthernet0/0/1.1), from 172.16.1.2, Send flag is 0x0
Composite metric is (2048000/1392640), route is Internal

© 2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 9 of 15 www.netacad.com
Lab - Implement EIGRP for IPv4

Vector metric:
Minimum bandwidth is 1000000 Kbit
Total delay is 21250000 picosecon ds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 2
Originating router is 3.3.3.3
Close configuration window

Part 3: Tune EIGRP for IPv4


In this part of the lab, you will tune and optimize EIGRP f or IPv4 through the use of passive interf aces,
authentication, and variance.

Step 1: Configure specific interfaces as passive.


Passive interf aces are interf aces that only partially participate in a routing protocols operation. The network
address f or the passive interf ace is advertised through other interf aces. However, the routing protocol does
not actually speak on the passive interf ace. Use passive interf aces when you have a connected network that
you want to advertise, but you do not want protocol neighbors to appear on that interf ace. For example,
interf aces supporting users should always be conf igured as passive. There are two ways to conf igure
interf aces as passive, either specif ically by interf ace name or by def ault. Normally a device with many LAN
interf aces will use the def ault option, and then use the no f orm of the command on those specif ic interf aces
that should be sending and receiving EIGRP messages.
a. On PC1, run Wireshark and set the capture f ilter to eigrp. You should see a hello message roughly every
f ive seconds. If your device were capable of running EIGRP, you might be able to f orm an adjacency and
interact in the routing domain. This is unnecessary traf f ic on the LAN and a potential security risk. Stop
the capture.
b. On R1, conf igure af -interf ace G0/0/1 to be passive.
Open configuration window

R1(config)# router eigrp BASIC-EIGRP-LAB


R1(config-router)# address-family ipv4 unicast autonomous-system 27
R1(config-router-af)# af-interface g0/0/1.2
R1(config-router-af-interface)# passive-interface
R1(config-router-af-interface)# end
Close configuration window

c. On PC1, restart the Wireshark capture with the capture f ilter still conf igured f or eigrp. You should no
longer see EIGRP Hello messages.

Step 2: Configure interfaces to default to passive.


The second option f or configuring passive interf aces is to conf igure them all as passive and then issue the no
passive-interf ace command f or certain interf aces. This approach is suitable in a security -f ocused scenario, or
when the device has many LAN interf aces. The commands vary depending on whether you are using Classic
or Named EIGRP.
a. In Classic EIGRP conf iguration, enter the passive-interface default command f ollowed by no passive-
interface interface-number commands f or all the interf aces that should be participating in EIGRP. The
f ollowing provides an example of this on R2. You will temporarily lose EIGRP adjacencies until passive-
interface is removed f rom required interf aces.
Open configuration window

R2(config)# router eigrp 27


R2(config-router)# passive-interface default
R2(config-router)# no passive-interface g0/0/0

© 2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 10 of 15 www.netacad.com
Lab - Implement EIGRP for IPv4

R2(config-router)# no passive-interface g0/0/1


R2(config-router)# exit
R2(config)# end
Close configuration window

b. In Named EIGRP conf iguration, you apply the passive-interface command to the af-interface default
conf iguration, and the no passive-interface command to the specif ic af-interface interface-number. The
f ollowing provides an example of this on R3. You will temporarily lose EIGRP adjacencies until passive-
interface is removed f rom required interf aces.
Open configuration window

R3(config)# router eigrp BASIC-EIGRP-LAB


R3(config-router)# address-family ipv4 unicast autonomous-system 27
R3(config-router-af)# af-interface default
R3(config-router-af-interface)# passive-interface
R3(config-router-af-interface)# exit
R3(config-router-af)# af-interface g0/0/0
R3(config-router-af-interface)# no passive-interface
R3(config-router-af-interface)# exit
R3(config-router-af)# af-interface g0/0/1
R3(config-router-af-interface)# no passive-interface
R3(config-router-af-interface)# end
c. The output of the show ip protocols | section Passive command will give you a list of passive interf aces
conf igured f or EIGRP, which f or R3 will only be the Loopback 0 interf ace that is simulating a LAN.
R3# show ip protocols | section Passive
Passive Interface(s):
Loopback0
Close configuration window

Step 3: Configure EIGRP authentication.


EIGRP supports authentication on an interf ace basis. In other words, each interf ace can be conf igured to
require authentication of the connected peer. This ensures that connected devices that try to f orm an
adjacency are authorized to do so. Classic EIGRP supports key-chain based MD5-hashed keys, while Named
EIGRP adds support f or SHA256-hashed keys. The two are not compatible.
In this step, you will conf igure both types of authentication to exercise the range of options available.
a. On R1, R2, R3, and D2, create a key-chain named EIGRP-AUTHEN-KEY with a single key. The key
should have the key-string $3cre7!!
Open configuration window

R1(config)# key chain EIGRP-AUTHEN-KEY


R1(config-keychain)# key 1
R1(config-keychain-key)# key-string $3cre7!!
R1(config-keychain-key)# end
Close configuration window

b. On R2, conf igure interf aces G0/0/0 and G0/0/1 to encrypt the key chain you just created with MD5. Note
that you will lose EIGRP adjacencies until the neighbor interf aces are conf igured.
Open configuration window

R2(config)# interface g0/0/0


R2(config-if)# ip authentication key-chain eigrp 27 EIGRP-AUTHEN-KEY
R2(config-if)# ip authentication mode eigrp 27 md5
R2(config-if)# exit
R2(config)# interface g0/0/1
R2(config-if)# ip authentication key-chain eigrp 27 EIGRP-AUTHEN-KEY
R2(config-if)# ip authentication mode eigrp 27 md5

© 2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 11 of 15 www.netacad.com
Lab - Implement EIGRP for IPv4

R2(config-if)# end
Close configuration window

c. Conf igure interf ace G0/0/0 on both R1 and R3 to use the key chain with MD5. EIGRP adjacencies with
R2 should be restored.
Open configuration window

R1(config)# router eigrp BASIC-EIGRP-LAB


R1(config-router)# address-family ipv4 unicast autonomous-system 27
R1(config-router-af)# af-interface g0/0/0
R1(config-router-af-interface)# authentication key-chain EIGRP-AUTHEN-KEY
R1(config-router-af-interface)# authentication mode md5
R1(config-router-af-interface)# end
d. Use the show ip eigrp interface detail | section Gi0/0/0 command to verif y that authentication is in
place and what type of authentication it is.
R1# show ip eigrp interface detail | section Gi0/0/0
Gi0/0/0 1 0/0 0/0 1 0/050 0
Hello-interval is 5, Hold-time is 15
Split-horizon is enabled
Next xmit serial <none>
Packetized sent/expedited: 14/2
Hello's sent/expedited: 186/4
Un/reliable mcasts: 0/11 Un/reliable ucasts: 15/7
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 0
Retransmissions sent: 3 Out-of-sequence rcvd: 0
Topology-ids on interface - 0
Authentication mode is md5, key-chain is "EIGRP-AUTHEN-KEY"
Topologies advertised on this interface: base
Topologies not advertised on this interface:

e. On R1 and D2, conf igure SHA 256 based authentication using the same $3cre7!! shared secret.. R1 and
D2 are running Named EIGRP, so the conf iguration is applied in af-interface mode. On R1, conf igure the
G0/0/1.1 subinterf ace. On D2, conf igure the G1/0/1 interf ace. The conf iguration f or R1 is shown. Note
that the R1-D2 adjacency will be lost until both ends are conf igured.
R1(config)# router eigrp BASIC-EIGRP-LAB
R1(config-router)# address-family ipv4 unicast autonomous-system 27
R1(config-router-af)# af-interface g0/0/1.1
R1(config-router-af-interface)# authentication mode hmac-sha-256 $3cre7!!
R1(config-router-af-interface)# end
Close configuration window
Open configuration window
Close configuration window

f. Use the show ip eigrp interface detail command to verif y that authentication is in place and what type of
authentication it is.
Open configuration window

R1# show ip eigrp interface detail | section Gi0/0/1.1


Gi0/0/1.1 1 0/0 0/0 3 0/050 0
Hello-interval is 5, Hold-time is 15
Split-horizon is enabled
Next xmit serial <none>
Packetized sent/expedited: 11/0
Hello's sent/expedited: 225/4
Un/reliable mcasts: 0/11 Un/reliable ucasts: 12/7
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 0
Retransmissions sent: 4 Out-of-sequence rcvd: 0

© 2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 12 of 15 www.netacad.com
Lab - Implement EIGRP for IPv4

Topology-ids on interface - 0
Authentication mode is HMAC-SHA-256, key-chain is not set
Topologies advertised on this interface: base
Topologies not advertised on this interface:
Close configuration window

Step 4: Manipulate load balancing with variance


By def ault, load balancing occurs only over eq ual-cost paths. EIGRP supports up to f our equal cost paths by
def ault but can be conf igured to support as many as 32 with the maximum-paths command.
EIGRP has the added capability to load balance over unequal-cost paths. Load balancing is controlled by the
variance parameter. Its value is a multiplier that is used to determine how to deal with multiple paths to the
same destination.
Variance is set to 1 by def ault, so any paths up to the conf igured maximum number of paths that have a
f easible distance equal to the best current f easible distance are also of f ered to the routing table. This provides
equal cost load balancing.
The variance parameter can also be set to zero, which dictates that no load balancing takes place.
The variance parameter can be adjusted so that paths that have an FD that is less than or equal to variance
times current best FD are also considered as successors and installed into the routing table. There is an
extremely important dif f erentiation here -- to be a f easible successor, the RD of a path must be less than the
current best FD. To be considered f or unequal load balancing, the FD of the f easible successor is multiplied
by the variance value, and if the product of this calculation is less than the current best FD, the f easible
successor is promoted to successor.
There are two caveats; f irst, only f easible successors are considered and second, unequal cost load
balancing is unequal; traf f ic share is proportional to the best metric in the routing table f or the given path.
Note: Keep in mind that your routing table may be dif f erent than the one created by the examples in this lab.
If your results are dif f erent, examine them caref ully to determine why so that you can thoroughly understand
how EIGRP is operating.
a. On R3, there are two equal-cost paths to 192.168.1.0/24.
Open configuration window

R3# show ip route eigrp | section 192.168.1.0


D 192.168.1.0/24
[90/20480] via 172.16.13.2, 00:08:18, GigabitEthernet0/0/1
[90/20480] via 10.0.23.2, 00:08:18, GigabitEthernet0/0/0
Close configuration window

b. To change this and allow f or the demonstration of variance, change the interf ace bandwidth f or the R2
interf aces G0/0/0 and G0/0/1 to 800000.
Open configuration window

R2(config)# interface g0/0/0


R2(config-if)# bandwidth 800000
R2(config-if)# exit
R2(config)# interface g0/0/1
R2(config-if)# bandwidth 800000
R2(config-if)# end
Close configuration window

c. When you examine the routing table on R3, you see that there is no load balancing occurring . All
destinations have a single path.
Open configuration window

R3# show ip route eigrp | begin Gateway


Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks


D 10.0.12.0/24 [90/16640] via 10.0.23.2, 00:01:17, GigabitEthernet0/0/0

© 2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 13 of 15 www.netacad.com
Lab - Implement EIGRP for IPv4

172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks


D 172.16.1.0/24
[90/15360] via 172.16.13.2, 00:01:04, GigabitEthernet0/0/1
D 192.168.1.0/24
[90/20480] via 172.16.13.2, 00:01:04, GigabitEthernet0/0/1

d. However, we know there are multiple paths in the network. The f irst consideration f or manipulating
variance is that it only works with f easible successors. Examining the topology table on R3 shows that
there is a f easible successor f or the 192.168.1.0/24 network. The route via 10.0.23.2 out the G0/0/0
interf ace has a RD less than the FD f or the current successor.
R3# show ip eigrp topology | section 192.168.1.0
P 192.168.1.0/24, 1 successors, FD is 2621440
via 172.16.13.2 (2621440/1966080), GigabitEthernet0/0/1
via 10.0.23.2 (2785280/2129920), GigabitEthernet0/0/0

e. To use the other route f or unequal cost load balancing, we can set the variance parameter to 2. This will
mean that any path with an RD less than or equal to 5242880 will qualif y as a successor (2 x 2621440 =
5242880).
R3(config)# router eigrp BASIC-EIGRP-LAB
R3(config-router)# address-family ipv4 unicast autonomous-system 27
R3(config-router-af)# topology base
R3(config-router-af-topology)# variance 2
R3(config-router-af-topology)# end
f. The output of the show ip route eigrp | begin Gateway command now displays two paths available to
the 192.168.1.0/24 network. Notice that the routes have dif f erent metrics, but are listed and used just the
same. Also, notice adding variance 2 adds a second path to the 10.0.12.0/24 network.
R3# show ip route eigrp | begin Gateway
Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks


D 10.0.12.0/24
[90/20480] via 172.16.13.2, 00:00:11, GigabitEthernet0/0/1
[90/16640] via 10.0.23.2, 00:00:11, GigabitEthernet0/0/0
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
D 172.16.1.0/24
[90/15360] via 172.16.13.2, 00:00:11, GigabitEthernet0/0/1
D 192.168.1.0/24
[90/20480] via 172.16.13.2, 00:00:11, GigabitEthernet0/0/1
[90/21760] via 10.0.23.2, 00:00:11, GigabitEthernet0/0/0

g. Issue the show ip route 192.168.1.0 command to see more details about the paths the router has to the
192.168.1.0 network. As a part of this output, you see the traf f ic share count, which tells you the ratio of
traf f ic that will be sent between these links. In this example, the co unt is 120 via 172.16.13.2 and 113 via
10.0.23.2. What that means is that 120 packets will be sent via 172.16.13.2 and then 113 packets will be
sent via 10.0.23.2.
R3# show ip route 192.168.1.0
Routing entry for 192.168.1.0/24
Known via "eigrp 27", distance 90, metric 20480, type internal
Redistributing via eigrp 27
Last update from 10.0.23.2 on GigabitEthernet0/0/0, 00:01:42 ago

© 2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 14 of 15 www.netacad.com
Lab - Implement EIGRP for IPv4

Routing Descriptor Blocks:


* 172.16.13.2, from 172.16.13.2, 00:01:42 ago, via GigabitEthernet0/0/1
Route metric is 20480, traffic share count is 120
Total delay is 30 microseconds, minimum bandwidth is 1000000 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 2
10.0.23.2, from 10.0.23.2, 00:01:42 ago, via GigabitEthernet0/0/0
Route metric is 21760, traffic share count is 113
Total delay is 30 microseconds, minimum bandwidth is 800000 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 2
Close configuration window
End of document

Router Interface Summary Table


Router Model Ethernet Interface #1 Ethernet Interface #2 Serial Interface #1 Serial Interface #2

Fast Ethernet 0/0 Fast Ethernet 0/1


1800 (F0/0) (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
Gigabit Ethernet 0/0 Gigabit Ethernet 0/1
1900 (G0/0) (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
Fast Ethernet 0/0 Fast Ethernet 0/1
2801 (F0/0) (F0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
Fast Ethernet 0/0 Fast Ethernet 0/1
2811 (F0/0) (F0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
Gigabit Ethernet 0/0 Gigabit Ethernet 0/1
2900 (G0/0) (G0/1) Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
Gigabit Ethernet 0/0/0 Gigabit Ethernet 0/0/1
4221 (G0/0/0) (G0/0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
Gigabit Ethernet 0/0/0 Gigabit Ethernet 0/0/1
4300 (G0/0/0) (G0/0/1) Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)

Note: To f ind out how the router is conf igured, look at the interf aces to identif y the type of router and how many
interf aces the router has. There is no way to ef f ectively list all the combinations of conf igurations f or each router
class. This table includes identif iers f or the possible combinations of Ethernet and Serial interf aces in the device.
The table does not include any other type of interf ace, even though a specif ic router may contain one. An
example of this might be an ISDN BRI interf ace. The string in parenthesis is the legal abbreviation that can b e
used in Cisco IOS commands to represent the interf ace.
End of document

© 2020 - 2020 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 15 of 15 www.netacad.com

You might also like