0% found this document useful (0 votes)
50 views

007 - Rishab Goel - Acn Lab File

This document provides instructions for experiments to be conducted in the Advance Computer Network Practical File course at Guru Gobind Singh Indraprastha University. It includes an index listing 10 experiments covering topics such as studying Cisco packet tracer components, implementing different network types and topologies, configuring routing protocols, implementing VLANs, and using commands like RARP and for basic debugging. The submitted file provides details on setting up and carrying out each listed experiment.

Uploaded by

Rishab Goel
Copyright
© © All Rights Reserved
Available Formats
Download as DOCX, PDF, TXT or read online on Scribd
0% found this document useful (0 votes)
50 views

007 - Rishab Goel - Acn Lab File

This document provides instructions for experiments to be conducted in the Advance Computer Network Practical File course at Guru Gobind Singh Indraprastha University. It includes an index listing 10 experiments covering topics such as studying Cisco packet tracer components, implementing different network types and topologies, configuring routing protocols, implementing VLANs, and using commands like RARP and for basic debugging. The submitted file provides details on setting up and carrying out each listed experiment.

Uploaded by

Rishab Goel
Copyright
© © All Rights Reserved
Available Formats
Download as DOCX, PDF, TXT or read online on Scribd
You are on page 1/ 32

ADVANCE COMPUTER NETWORK

Practical File
(IT-451)

GURU GOBIND SINGH INDRAPRASTHA UNIVERSITY


(University School of Information, Communication &
Technology)

Submitted To: Submitted By:


Abhay Yadav
Arshi Hussain Name: Rishab Goel
USICT, GGSIPU Roll No: 00716403219
BTech CSE 7th Sem
2019-2023
INDEX
S.N Experiment Name Signature
O
1 To study the different components of Cisco packet trace.
2 To implement basic networking DOS commands.
3 To implement different type of networks (LAN, WAN, MAN)
4 To implement different networking topologies (bus, star, ring,
mesh)
5 To implement commands for RARP and basic debugging
6 To implement static NAT in CISCO Packet Tracer.
7 To configure and implement RIP routing protocol for a given
scenario In CISCO Packet Tracer.

8 To configure and implement OSPF routing protocol for a given


scenario in cisco packet tracer
9 To understand the operation of TELNET by accessing the router
in server room from a PC in IT office.

10 To implement VLAN on packet tracer


1. To study the different components of Cisco packet tracer.
Cisco Packet Tracer is a network simulation software that allows users to design and
simulate computer networks.
Some of the main components of Cisco Packet Tracer are:

 Network devices: These include routers, switches, hubs, and other


networking hardware that are used to create and connect different
network segments.
 Cabling: Packet Tracer allows users to connect network devices using
various types of cables, including copper and fiber optic cables.
 Protocols: Packet Tracer supports various networking protocols, such as
TCP/IP, HTTP, and FTP, which are used to transmit data between devices
on a network.
 Network topologies: Packet Tracer allows users to create and simulate
different types of network topologies, such as star, bus, and ring.
 Network utilities: Packet Tracer includes a number of utilities that allow
users to troubleshoot and test their network configurations, such as ping
and traceroute.
 Simulation: Packet Tracer allows users to simulate network behaviour and
see how different configurations and scenarios affect network
performance.
2. To implement basic networking DOS commands
Here are some basic DOS commands that can be used to manage and troubleshoot a network:

1. "ping" - This command is used to test the connectivity between two devices on a network. It
sends a small packet of data to a specified device and waits for a response.

2. "tracert" - This command is used to trace the route that a packet takes from the source device
to the destination device. It can be useful for identifying network issues or bottlenecks.

3. "ipconfig" - This command displays the IP configuration of the local device, including the IP
address, subnet mask, and default gateway.

4. "netstat" - This command displays active network connections and the status of TCP and UDP
ports on the local device.

5. "nslookup" - This command is used to query DNS servers for information about a domain or
hostname.

6. "arp" - This command is used to display and modify the Address Resolution Protocol (ARP)
cache, which is used to map IP addresses to physical addresses on a network.

7. "nbtstat" - This command is used to display statistics and information about NetBIOS over
TCP/IP connections on a device.

8. "route" - This command is used to display and modify the routing table on a device, which is
used to determine the best path for network traffic.
3. To implement different type of networks (LAN, WAN,
MAN).
LAN (Local Area Network).
 Network devices: You will need routers, switches, and possibly hubs to create and connect
different segments of the network.
 Cabling: You will need to connect the devices using Ethernet cables or other types of cabling,
depending on your network's requirements.
 Network topology: You will need to determine the layout of the network, such as a star, bus, or
ring topology.
 Protocols: You will need to configure the devices to use networking protocols such as TCP/IP,
HTTP, and FTP to transmit data between devices on the network.

WAN (Wide Area Network).


 Network devices: You will need routers, switches, and possibly hubs to create and
connect different segments of the network.
 Communication channels: You will need to establish a communication channel
between the devices on the network, such as leased lines, satellite links, or VPN
connections.
 Protocols: You will need to configure the devices to use networking protocols such as
TCP/IP, HTTP, and FTP to transmit data between devices on the network.

MAN (Metropolitan Area Network).


 Network devices: You will need routers, switches, and possibly hubs to create and
connect different segments of the network.
 Communication channels: You will need to establish a communication channel
between the devices on the network, such as leased lines, satellite links, or VPN
connections.
 Protocols: You will need to configure the devices to use networking protocols such
as TCP/IP, HTTP, and FTP to transmit data between devices on the network.
 Network topology: You will need to determine the layout of the network, such as a
star, bus, or ring topology.
 Network utilities: You may need to use network utilities such as ping and traceroute
to troubleshoot and test your network configuration.
4. To implement different networking topologies
(Bus, star, ring, mesh)
1. Bus topology

 Network devices: You will need at least two devices, such as computers or routers, to create
a basic bus topology.
 Cabling: You will need to connect the devices using a single length of cable, which serves as
the backbone of the network. Each device is connected to the cable using a T-connector.
 Protocols: You will need to configure the devices to use networking protocols such as TCP/IP
to transmit data between devices on the network
2. Star topology
 Network devices: You will need at least three devices, such as computers or routers, to
create a basic star topology.
 Cabling: You will need to connect all of the devices to a central hub or switch using individual
cables.
 Protocols: You will need to configure the devices to use networking protocols such as TCP/IP
to transmit data between devices on the network.

3. Ring topology

 Network
devices: You will
need at least
three devices,
such as
computers or
routers, to
create a basic
ring topology.
 Cabling: You will
need to connect
the devices in a circular fashion, with each device connected to two others.
 Protocols: You will need to configure the devices to use networking protocols such as TCP/IP
to transmit data between devices on the network.

4. Mesh topology
 Network devices: You will need at least three devices, such as computers or routers, to
create a basic mesh topology.
 Cabling: You will need to connect all of the devices to each other using individual cables.
 Protocols: You will need to configure the devices to use networking protocols such as TCP/IP
to transmit data between devices on the network.
5. To implement commands for RARP and basic debugging
The Reverse Address Resolution Protocol (RARP) is a network protocol that allows a device to
request its IP address from a server. It is often used in diskless workstations or other devices that do
not have a local storage mechanism to store their IP address.

To implement RARP on a device, you will need to follow these steps:

1. Configure the RARP server: On the server, you will need to create a RARP table that maps
the physical addresses of devices to their IP addresses. This can be done using a
configuration file or through a database.

2. Configure the client device: On the client device, you will need to configure it to use RARP to
request its IP address from the server. This can usually be done through the device's
network configuration settings.

3. Request the IP address: The client device can request its IP address from the server by
sending a RARP request packet. The server will then respond with the appropriate IP
address.

To perform basic debugging on a network, you can use the following commands:

1. "ping" - This command is used to test the connectivity between two devices on a network. It
sends a small packet of data to a specified device and waits for a response.

2. "tracert" - This command is used to trace the route that a packet takes from the source
device to the destination device. It can be useful for identifying network issues or
bottlenecks.

3. "ipconfig" - This command displays the IP configuration of the local device, including the IP
address, subnet mask, and default gateway.

4. "netstat" - This command displays active network connections and the status of TCP and
UDP ports on the local device.

5. "nslookup" - This command is used to query DNS servers for information about a domain or
hostname.
6. "arp" - This command is used to display and modify the Address Resolution Protocol (ARP)
cache, which is used to map IP addresses to physical addresses on a network.

7. "nbtstat" - This command is used to display statistics and information about NetBIOS over
TCP/IP connections on a device.

8. "route" - This command is used to display and modify the routing table on a device, which is
used to determine the best path for network traffic.

6. To implement static NAT in CISCO Packet Tracer.


Network Address Translation (NAT) is a technique used to allow devices on a private network to
communicate with the Internet. Static NAT is a type of NAT in which a one-to-one mapping is
established between a private IP address and a public IP address. This means that a specific private
IP address will always be translated to the same public IP address when communicating with the
Internet.

To implement static NAT, you will need the following:

1. A router or other device that supports NAT.

2. A public IP address that will be used to represent the private IP address to the Internet.

3. A private IP address that you want to map to the public IP address.

To configure static NAT, you will need to follow these steps:

1. Log in to the router or NAT device and access the NAT configuration settings.

2. Create a NAT rule that defines the mapping between the private IP address and the public IP
address. This will typically involve specifying the private and public IP addresses, as well as
the protocol (such as TCP or UDP) and the port number.

3. Save the NAT rule and apply it to the router or NAT device.

4. Test the NAT configuration by attempting to access the Internet from the device with the
private IP address. The device should now be able to communicate with the Internet using
the mapped public IP address.

Static NAT in Cisco Packet Tracer, you will need to follow these steps:

 Open Packet Tracer and create a network with at least one private network and one public
network.
 Add a router to the network and configure it with at least two interfaces: one connected to
the private network and one connected to the public network.
 Access the router's configuration and navigate to the NAT settings.
 Enable NAT on the router by typing the command "Ip Nat inside source static <private Ip>
<public Ip>" where <private Ip> is the private IP address of the device and <public Ip> is the
public IP address that you want to use to represent the device to the Internet.
 Save the NAT configuration and test it by attempting to access the Internet from a device on
the private network. The device should now be able to communicate with the Internet using
the mapped public IP address.

Terminology of NAT:

 Inside Local: It is a region inside the Enterprise’s network where the hosts have Private IP
addresses.

 Inside Global: It is also a region inside the Enterprise network, but Public IP addresses are
used in this region (this region is usually connected to the outside network or Internet).

 Outside Local: It is a region that is generally part of the Enterprise network but in a public
Internet (or outside the Enterprise Network). The hosts of the Outside Local region have
private IP addresses.

 Outside Global: It is a part of the Enterprise network in a public Internet where Public IP
addresses is used.

These Private IP addresses cannot be advertised on the Internet using any routing protocol.
Static NAT:
In Static NAT, IP addresses are statically mapped to each other through manual
configuration. Global IP addresses are translated to Local IP addresses based on the
statically mapping of these IP addresses.
There are 2 types of Static NAT:

 Inside Static NAT


 Outside Static NAT
Inside Static NAT:
This involves the static mapping of the Inside Local IP address (private address) to the Inside
Global address (public address). When Inside Static NAT is used, private IP addresses remain
hidden from the outside network.

Configuration:
Configure the interface in the Inside Global as

 ip nat outside
Configure the interface in the Inside Local as

 ip nat inside
Lastly, enable Static Nat by using the command:
Router(config)#ip nat inside source
static <inside-local-ip> <inside-global-ip>
R1(config)#int f0/0
R1(config-if)#ip nat outside
R1(config-if)#exit
R1(config)#int f1/0
R1(config-if)#ip nat inside
R1(config-if)#exit
R1(config)#ip nat inside source static 10.1.1.2 20.1.1.1

Outside Static NA:


This involves the static mapping of the Outside Global IP address (public address) to an
Outside Local address (private address). When Outside Static NAT is used, the real external
IP addresses remain hidden from the hosts.
Configuration:
Configure the interface in the Inside Global as

 ip nat outside
Configure the interface in the Inside Local as

 ip nat inside
Lastly, enable Static Nat by using the command:
Router(config)#ip nat inside source
static <outside-global-ip> <outside-local-ip>

R1(config)#int f0/0

R1(config-if)#ip nat outside

R1(config-if)#exit

R1(config)#int f1/0

R1(config-if)#ip nat inside

R1(config-if)#exit

R1(config)#ip nat outside source static 30.1.1.1 192.168.1.2

To verify these NAT translations:


R1#show ip nat translations
Note: In Packet Tracer, you may also need to configure the router's firewall settings to allow
traffic from the private network to flow to the public network. It is important to ensure that
the NAT rule does not conflict with any other NAT rules or firewall rules on the router or
NAT device. If a conflict exists, the NAT rule may not work as expected.
7. To configure and implement RIP routing protocol for a given
scenario In CISCO Packet Tracer.
Steps to Configure and Verify Three Router Connections in Cisco Packet Tracer using RIP
Routing:Step 1: First, open the Cisco packet tracer desktop and select the devices given below:

IP Addressing Table:

 Then, create a network topology as shown below the image.


 Use an Automatic connecting cable to connect the devices with others.
Step 2: Configure the PCs (hosts) with IPv4 address and Subnet Mask according to the IP
addressing table given above.

 To assign an IP address in PC0, click on PC0.


 Then, go to desktop and then IP configuration and there you will IPv4 configuration.
 Fill IPv4 address and subnet mask.

 Assigning an IP address using the ipconfig command, or we can also assign an IP


address with the help of a command.
 Go to the command terminal of the PC.
 Then, type ipconfig <IPv4 address><subnet mask><default gateway> (if needed)
Example: ipconfig 192.168.10.2 255.255.255.0 192.168.10.1
 Repeat the same procedure with other PCs to configure them thoroughly.

Step 3: Configure router with IP address and Subnet mask.


IP Addressing Table Router:

 To assign an IP address in router0, click on router0.


 Then, go to config and then Interfaces.
 Make sure to turn on the ports.
 Then, configure the IP address in Fast Ethernet and serial ports according to IP
addressing Table.
 Fill IPv4 address and subnet mask.

 Repeat the same procedure with other routers to configure them thoroughly.
Step 4: After configuring all of the devices we need to assign the routes
to the routers.

1. To assign RIP routes to the particular router:


o First, click on router0 then Go to CLI.
o Then type the commands and IP information given below.
o CLI command: network <network id>
 RIP Routes for Router0 are given below:

Router(config)#network 192.168.10.0
Router(config)#network 10.0.0.0
RIP Routes for Router1 are given below:

Router(config)#network 192.168.20.0
Router(config)#network 10.0.0.0
Router(config)#network 11.0.0.0
RIP Routes for Router2 are given below:

Router(config)#network 192.168.30.0
Router(config)#network 11.0.0.0
Step 5: Verifying the network by pinging the IP address of any PC.

o We will use the ping command to do so.


o First, click on PC0 then Go to the command prompt.
o Then type ping <IP address of targeted node>.
o As we can see in the below image, we are getting replies which means the
connection is working properly.
o Example: ping 192.168.20.2

 A simulation of the experiment is given below we are sending PDU from PC0 to PC2
and PC3 to PC5:
8. To configure and implement OSPF routing protocol for a
given scenario in cisco packet tracer

 Placing Devices
If you are already known how to place the devices accordingly, you may go directly
to the next section (Configuring Devices).
 Placing Routers
Pick a router from left bottom pane and place it on the work area by following this
hint:

For the other 2 routers, you can repeat this step or simply copy and paste the
existing one.
Placing PCs
PC can be found under End Devices > End Devices.

Placing Switches
Switches are stored under Network Devices > Switches.

Physically Interconnecting Devices


For connecting the device, choose your prefered connection type from Connections
> Connections.
Then click on each device and choose an available network interface.

In the ideal world of Packet Tracer, connection between PC and router are
connected using cross-over cable (stripped black icon), router and switch are using
straight-through (solid black icon). Although in real life it usually doesn’t really
matter because the network interfaces are smart enough.

Configuring Devices
Configuring Routers
Click the router to bring up its window, and open the CLI tab. Simply paste the
following scripts accordingly.

R1: Router 1

enable
config terminal
hostname R1
interface GigabitEthernet0/0/0
ip address 192.168.5.1 255.255.255.0
no shutdown
exit

interface GigabitEthernet0/0/1
ip address 10.10.10.1 255.255.255.248
no shutdown
exit

router ospf 1
network 192.168.5.0 0.0.0.255 area 0
network 10.10.10.0 0.0.0.7 area 0

R2:

enable
config terminal
hostname R2
interface GigabitEthernet0/0/0
ip address 192.168.6.1 255.255.255.0
no shutdown
exit

interface GigabitEthernet0/0/1
ip address 10.10.10.2 255.255.255.248
no shutdown
exit

router ospf 1
network 192.168.6.0 0.0.0.255 area 0
network 10.10.10.0 0.0.0.7 area 0

R3:

enable
config terminal
hostname R3
interface GigabitEthernet0/0/0
ip address 192.168.7.1 255.255.255.0
no shutdown
exit

interface GigabitEthernet0/0/1
ip address 10.10.10.3 255.255.255.248
no shutdown
exit

router ospf 1
network 192.168.7.0 0.0.0.255 area 0
network 10.10.10.0 0.0.0.7 area 0

As you can see 0.0.0.255 and 0.0.0.7 in the scripts above, they are the wildcard. We will talk
about it later.

Configuring PCs
Click on the PC. Open Desktop tab, then choose IP Configuration. You can put the network
and gateway address there.

Configuring Switches
There’s not much in this part, just make sure each interface is turned on, and leave it with its
default configuration.

Testing Configuration
Confirming From Router We can confirm our configuration from CLI by using show ip route
or show ip route ospf. If the other 2 network segments are listed there in the table, then
cheers! You’ve done it right.
Here’s the example from my R1.
Ping From PC

The Wildcard
Wildcard mask are used to specify a range of a network segment.
Let’s say, we have a network address of 10.10.1.0/29. The netmask of /29 means we have 29
bits of 1 divided into 4 bytes.

/29 = 11111111.11111111.11111111.11111000
To determine the wildcard, we can invert the mask. So, we get the following value.
wildcard = 00000000.00000000.00000000.00000111
Now we have 3 bits of 1. That means 2³-1=7. So, the wildcard in decimal is:
0.0.0.7
Another example 192.168.5.0/24.
/24=11111111.11111111.11111111.00000000
wildcard = 00000000.00000000.00000000.11111111
2⁸-1 = 255
0.0.0.255
A simpler way is to subtract the maximum bits of netmask (32) with our network mask. For
example, 10.10.1.0/29, we have /29 as the netmask.
32–29=3
2³-1=7
wildcard = 0.0.0.7
Ultimately the simplest way is, using ipcalc.
9. To understand the operation of TELNET by accessing the router
in server room from a PC in IT office.
TELNET stands for Teletype Network. It is a type of protocol that enables one computer to
connect to local computer. It is a used as a standard TCP/IP protocol for virtual terminal service
which is given by ISO. Computer which starts connection known as the local computer.
Computer which is being connected to i.e. which accepts the connection known as remote
computer. When the connection is established between local and remote computer. During
telnet operation whatever that is being performed on the remote computer will be displayed by
local computer. Telnet operates on client/server principle. Local computer uses telnet client
program and the remote computers uses telnet server program.

TELNET Commands:

Commands of the telnet are identified by a prefix character, Interpret as Command (IAC) which
is having code 255. IAC is followed by command and option codes. Basic format of the command
is as shown in the following figure:
Modes of Operation :
Most telnet implementation operates in one of the following three modes:

 Default mode
 Character mode
 Line mode

Default Mode :

If there is no other modes are invoked then this mode is used. Echoing is performed in this mode by
client. In this mode, user types a character and client echoes the character on the screen but it does
not send it until whole line is completed.

Character Mode:

Each character typed in this mode is sent by client to server. Server in this type of mode is normally
echoes character back to be displayed on the client’s screen.

Line Mode:

Line editing like echoing, character erasing etc. is done from the client side. Client will send the
whole line to the server.
10. To implement VLAN on packet tracer
VLAN is the abbreviation for Virtual LAN, i.e. Virtual Local Area Network. This is a custom network we
create from one or more existing LANs. It enables a group of devices from multiple networks (both
wired and wireless) to be combined into a single Logical network. The result is a VLAN that can be
administered like a physical area network. The network equipment like routers or switches must
support the VLAN configurations to create a VLAN.

Advantages of VLANs:

Security: VLANs come up with extra security because users of the same group can send broadcast
messages with an assurance that users from another group will not receive that broadcast message.

Time and Cost Reduction: It can reduce the migration cost of stations because it is a lot easier and
quicker to migrate using the software.

Create a network in Cisco Packet Tracer and configure VLAN in it. Here we create 2 LANs with 6 hosts
each of them and in each LAN we create 2 VLANs and try to communicate between them.

Step 1:

At first, we create a LAN, LAN-A with 6 hosts. To create a LAN we need one Layer 2 switch Switch0
and 6 end devices. Now we provide IP addresses to the hosts starting from 192.168.10.1 (you can
provide any valid IP addresses). To provide an IP address to a host just select that host → Desktop →
IP Configuration → IPv4 Addresses and provide an IP address and then ENTER, the Subnet Mask will
be provided by default.

Step 2: Let us create 2 VLANs where the name of the first VLAN is VLAN-STUDENT and the
second VLAN is VLAN-FACULTY. To configure VLANs we have to go to the switch Switch0 and
move to Config → SWITCHING → VLAN Database. Now let us take the VLAN Number for
STUDENT is 150 and for FACULTY is 250 and add these numbers to VLAN Database.
Step 3: Next we have to select the hosts under VLAN-STUDENT. Here I have put hosts with
IP addresses from 192.168.10.1 to 192.168.10.3 under VLAN-STUDENT. To do so we have to
select the switch Switch0 → Config → INTERFACE, here we choose FastEthernet0/1
corresponding to the host 192.168.10.1 which we consider to be in VLAN-STUDENT. Now we
select the down arrow beside VLAN and select 150: STUDENT, which is for student VLAN.
Similarly, we do this same process for FastEthernet0/2 and FastEthernet0/3.

Step 4: Now we have to configure the hosts under VLAN-FACULTY. Here I have put hosts
with IP addresses 192.168.10.4 to 192.168.10.6 under VLAN-FACULTY. To do so, just follow
the process mentioned in Step 3, but instead of selecting the VLAN Number 150: STUDENT,
select 250: FACULTY for FastEthernet0/4, FastEthernet0/5, and FastEthernet0/6.
Step 5: Lastly, just change the switch port mode from Access to Trunk for FastEthernet0/7.

You can create LAN-B similarly by following these steps and connect LAN-A and LAN-B by
using a Cross-Over cable. And your end network will look like this:
Now our VLAN configuration is ready, and we can check this by sending data packets from
one host to another under LAN-A. Let us ping from 192.168.10.1 to 192.168.10.3. To do so,
we have to select the host with IP 192.168.10.1 and then select Desktop → Command
Prompt. Now run the following command to ping 192.168.10.3.
ping 192.168.10.3

You can also ping the hosts under VLAN-FACULTY by following the previous steps, but you cannot
ping from a host under VLAN-STUDENT to a host under VLAN-FACULTY or vice versa. It’ll generate a
request time out because your created Virtual LAN STUDENT doesn’t contain any host with IP
addresses from 192.168.10.3 to 192.168.10.6. Similarly, VLAN-FACULTY also doesn’t contain IP
addresses from 192.168.10.1 to 192.168.10.3.

Now, let us try to ping from LAN-A VLAN-FACULTY to LAN-B VLAN-FACULTY.

Let us ping 192.168.10.5 of LAN-A VLAN-FACULTY to 192.168.10.12 of LAN-B VLAN-FACULTY. To ping


again, run the command in the command prompt of the host with IP 192.168.10.5

ping 192.168.10.12

You might also like