Lab 01 - Implement Inter-VLAN Routing - ILM
Lab 01 - Implement Inter-VLAN Routing - ILM
Addressing Table
Device Interface IPv4 Address IPv6 Address IPv6 Link-Local
R1
S0/1/1 10.1.3.1/24 2001:db8:acad:1013::1/64 fe80::1:2
D1 G1/0/11 10.1.13.13/24 2001:db8:acad:10d1::d1/64 fe80::d1:1
D1
VLAN50 10.2.50.1/24 2001:db8:acad:1050::d1/64 fe80::d1:2
D1
VLAN60 10.2.60.1/24 2001:db8:acad:1060::d1/64 fe80::d1:3
R3 S0/1/1 10.1.3.3/24 2001:db8:acad:1013::3/64 fe80::3:1
R3
G0/0/1.75 10.3.75.1/24 2001:db8:acad:3075::1/64 fe80::3:2
R3
G0/0/1.85 10.3.85.1/24 2001:db8:acad:3085::1/64 fe80::3:3
D2 VLAN75 10.3.75.14/24 2001:db8:acad:3075::d2/64 fe80::d2:1
PC1 NIC 10.2.50.50/24 2001:db8:acad:1050::50/64 EUI-64
PC2 NIC 10.2.60.50/24 2001:db8:acad:1060::50/64 EUI-64
PC3 NIC 10.3.75.50/24 2001:db8:acad:3075::50/64 EUI-64
PC4 NIC 10.3.85.50/24 2001:db8:acad:3085::50/64 EUI-64
© 20211 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 1 of 10 www.netacad.com
Topology: Implement Inter-VLAN Routing
Objectives
Part 1: Build the Network and Configure Basic Device Settings
Part 2: Configure and Verify Inter-VLAN Routing on a Layer 3 Switch
Part 3: Configure and Verify Router-based Inter-VLAN Routing
Part 4: Examine CAM and CEF Details
Background / Scenario
The methods used to move packets and frames from one interface to the next has changed over the years. In
this lab you will configure Inter-VLAN Routing in its various forms and then examine the different tables used
in making forwarding decisions.
Required Resources
• 2 Routers (Cisco 4221 with Cisco IOS XE Release 16.9.4 universal image or comparable)
• 2 Switches (Cisco 3650 with Cisco IOS XE Release 16.9.4 universal image or comparable)
• 4 PCs (PC with terminal emulation program, such as Tera Term)
• Console cables to configure the Cisco IOS devices via the console ports
• Ethernet and serial cables as shown in the topology
Instructions
Router R1
no ip domain lookup
hostname R1
line con 0
exec-timeout 0 0
logging synchronous
exit
banner motd # This is R1, Inter-VLAN Routing Lab #
Router R3
no ip domain lookup
hostname R3
line con 0
exec-timeout 0 0
© 20211 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 2 of 10 www.netacad.com
Topology: Implement Inter-VLAN Routing
logging synchronous
exit
banner motd # This is R3, Inter-VLAN Routing Lab #
Switch D1
no ip domain lookup
hostname D1
line con 0
exec-timeout 0 0
logging synchronous
exit
banner motd # This is D1, Inter-VLAN Routing Lab #
interface range g1/0/1-24
shutdown
Switch D2
no ip domain lookup
hostname D2
line con 0
exec-timeout 0 0
logging synchronous
exit
banner motd # This is D2, Inter-VLAN Routing Lab #
interface range g1/0/1-24
shutdown
b. Set the clock on each device to UTC time.
c. Save the running configuration to startup-config.
Close configuration window
© 20211 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 3 of 10 www.netacad.com
Topology: Implement Inter-VLAN Routing
© 20211 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 4 of 10 www.netacad.com
Topology: Implement Inter-VLAN Routing
© 20211 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 5 of 10 www.netacad.com
Topology: Implement Inter-VLAN Routing
D2(config)# vlan 75
D2(config-vlan)# name Group75
D2(config-vlan)# exit
D2(config)# vlan 85
D2(config-vlan)# name Group85
D2(config-vlan)# exit
D2(config)# vlan 999
D2(config-vlan)# name NativeVLAN
D2(config-vlan)# exit
b. Assign the G1/0/23 to VLAN 75 and G1/0/24 to VLAN 85.
c. Create a Switched Virtual Interface that will operate within VLAN 75.
D2(config)# interface vlan75
D2(config-if)# ip address 10.3.75.14 255.255.255.0
D2(config-if)# ipv6 address fe80::d2:1 link-local
D2(config-if)# ipv6 address 2001:db8:acad:3075::d2/64
D2(config-if)# no shutdown
D2(config-if)# exit
d. Create an IEEE 802.1Q-based trunk to R3. As a part of the configuration of the trunk, set the native VLAN
to VLAN 999 and filter the VLANs allowed on the trunk down to only those that are configured.
D2(config)# interface g1/0/11
D2(config-if)# switchport mode trunk
D2(config-if)# switchport trunk native vlan 999
D2(config-if)# switchport trunk allowed vlan 75,85,999
D2(config-if)# no shutdown
D2(config-if)# exit
Close configuration window
© 20211 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 6 of 10 www.netacad.com
Topology: Implement Inter-VLAN Routing
R3(config-if)# exit
R3(config)# interface g0/0/1.75
R3(config-subif)# encapsulation dot1q 75
R3(config-subif)# ip address 10.3.75.1 255.255.255.0
R3(config-subif)# ipv6 address fe80::3:2 link-local
R3(config-subif)# ipv6 address 2001:db8:acad:3075::1/64
R3(config-subif)# no shutdown
R3(config-subif)# exit
R3(config)# interface g0/0/1.85
R3(config-subif)# encapsulation dot1q 85
R3(config-subif)# ip address 10.3.85.1 255.255.255.0
R3(config-subif)# ipv6 address fe80::3:3 link-local
R3(config-subif)# ipv6 address 2001:db8:acad:3085::1/64
R3(config-subif)# no shutdown
R3(config-subif)# exit
R3(config)# interface g0/0/1.999
R3(config-subif)# encapsulation dot1q 999 native
R3(config-subif)# no shutdown
R3(config-subif)# exit
c. Configure PC3 with the addresses specified in the Addressing Table. Further assign default gateways of
10.3.75.1 and 2001:db8:acad:3075::1.
d. Configure PC4 with the addresses specified in the Addressing Table. Further assign default gateways of
10.3.85.1 and 2001:db8:acad:3085::1.
e. From PC3, ping PC4’s IPv4 and IPv6 address. Success indicates that R3 is performing Inter-VLAN
Routing.
c. On PC3, issue a ping to PC2. The ping should be successful. This indicates the routing solution is
working in both directions.
© 20211 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 7 of 10 www.netacad.com
Topology: Implement Inter-VLAN Routing
These are basically shortcuts that identify what interface a packet should be sent out of and how it should be
framed.
a. Issue the command show ip cef to see the compiled CEF table, which tells the device what to do with a
frame or packet based on its destination address. This table gives the device a quick answer and keeps
the CPU from getting directly involved. For example, packets destined to the 10.2.0.0/16 network are
quickly resolved to the next-hop address of 10.1.13.13 exiting interface g0/0/1.
Open configuration window
b. Issue the command show adjacency, which shows you the address neighbors on each interface.
R1# show adjacency
Protocol Interface Address
IP GigabitEthernet0/0/1 10.1.13.13(11)
IP GigabitEthernet0/0/1 227.0.0.0(3)
IPV6 GigabitEthernet0/0/1 2001:DB8:ACAD:10D1::D1(12)
IPV6 GigabitEthernet0/0/1 FE80::D1:1(3)
IPV6 GigabitEthernet0/0/1 FFFF::(3)
IP Serial0/1/1 point2point(13)
IPV6 Serial0/1/1 point2point(13)
c. Expand this a bit and issue the command show adjacency detail, and you will see that the router has
precompiled the Layer 2 headers and other details to allow it to package information quickly.
R1# show adjacency detail
Protocol Interface Address
IP GigabitEthernet0/0/1 10.1.13.13(11)
20 packets, 1680 bytes
epoch 0
sourced in sev-epoch 0
Encap length 14
001AE3CFB8C37079B39236410800
L2 destination address byte offset 0
© 20211 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 8 of 10 www.netacad.com
Topology: Implement Inter-VLAN Routing
© 20211 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 9 of 10 www.netacad.com
Topology: Implement Inter-VLAN Routing
Encap length 4
0F000800
P2P-ADJ
IPV6 Serial0/1/1 point2point(13)
18599 packets, 1756190 bytes
epoch 0
sourced in sev-epoch 0
Encap length 4
0F0086DD
P2P-ADJ
Close configuration window
© 20211 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 10 of 10 www.netacad.com