0% found this document useful (0 votes)
57 views

A Computer Network Project Report - Sem - 1

This document discusses a computer network project report for an educational institution. The network design includes two switches, two routers, and WAN emulation to connect multiple VLANs. VLAN 10 is for students, VLAN 20 for teachers, VLAN 30 for guests, and VLAN 99 for management. The network allows for secure inter-VLAN communication and resource sharing to support collaboration between students and teachers.

Uploaded by

Dipesh Thakur
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
0% found this document useful (0 votes)
57 views

A Computer Network Project Report - Sem - 1

This document discusses a computer network project report for an educational institution. The network design includes two switches, two routers, and WAN emulation to connect multiple VLANs. VLAN 10 is for students, VLAN 20 for teachers, VLAN 30 for guests, and VLAN 99 for management. The network allows for secure inter-VLAN communication and resource sharing to support collaboration between students and teachers.

Uploaded by

Dipesh Thakur
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
You are on page 1/ 28

1

A Computer Network Project Report

Dipesh Thakur
Computer Network(BIT-124)
LCID-LC00017002329
2

Table of Contents

1. Introduction_____________________________________________3 to 8
1.1 Objectives
1.2 Scope
1.3 Scenario

2. Network Design_________________________________________8 to 15
2.1 Physical Connectivity
2.2 Device Selection and Architecture
2.3 WAN Emulation
2.4 Benefits of Design Choices
2.5 About Protocols
2.6 Explanation of the network through code analysis

3. Network Implementation___________________________________15
3.1 Switch Configuration
3.2 Router Configuration
3.3 DHCP Configuration
3.4 Challenges Faced and Lessons Learned

4. Troubleshooting and Optimization________________________15 to 16


4.1 Inter-VLAN Routing Issue
4.2 Next-Hop IP Address Issue
4.3 Performance Optimization

5. Conclusion________________________________________________16
5.1 Project Outcomes
5.2 Importance of a Well-Designed Network
5.3 The Value of Cisco Packet Tracer

6. References________________________________________________16

7. Appendix_____________________________________________16 to 28
7.1 A comprehensive guide on IP addressing and subnetting
7.2 History
7.3 Code of the Network
7.4 Some Glimpses
3

1. Introduction

Computer Network: An Extensive Overview

Computer networks have become an integral part of our modern world. They underpin the
global internet, connect millions of devices, and enable data transfer on an unprecedented
scale. This comprehensive overview delves into the fundamental concepts, components,
types, and the significance of computer networks in contemporary society.

I. Introduction to Computer Networks

A computer network is a collection of interconnected computers and devices that can share
data, resources, and services. These networks can range from small local area networks
(LANs) in homes or offices to vast global networks like the internet. Computer networks are
essential for enabling communication and data exchange between devices, facilitating
collaborative work, and providing access to information and services.

II. Key Components of Computer Networks

1. Nodes: Nodes are the devices connected to the network. They can be computers,
servers, smartphones, printers, or any device capable of network communication.

2. Links: Links refer to the physical or logical connections that allow data to flow between
nodes. Physical links can be wired (e.g., Ethernet cables) or wireless (e.g., Wi-Fi).

3. Data: Data is the information transmitted over the network. It can be in the form of text,
images, videos, or any digital content.

4. Protocols: Network protocols are rules and conventions that govern how data is formatted,
transmitted, received, and processed. Common protocols include TCP/IP, HTTP, and SMTP.

III. Types of Computer Networks

1. Local Area Network (LAN): LANs are small-scale networks typically confined to a single
location, like a home, office, or campus. They are characterised by high data transfer rates
and low latency.

2. Wide Area Network (WAN): WANs cover larger geographical areas, often connecting
LANs across cities or countries. The internet is the most extensive WAN.

3. Metropolitan Area Network (MAN): MANs bridge the gap between LANs and WANs,
covering a metropolitan area like a city. They are used for city-wide connectivity.

4. Wireless Networks: Wireless networks use radio waves or other wireless technologies to
connect devices without physical cables. Examples include Wi-Fi and cellular networks.
4

5. Peer-to-Peer Networks: In peer-to-peer networks, devices communicate directly with each


other without the need for a central server. This is common in file-sharing applications.

6. Client-Server Networks: In client-server networks, devices (clients) request services or


resources from a central server. This architecture is prevalent on the internet.

IV. Network Topologies

Network topologies define the physical or logical layout of devices and connections within a
network. Some common topologies include:

1. Bus Topology: Devices are connected to a central cable, resembling a bus. Data is
transmitted along the cable, and all devices can see the data, but only the intended recipient
processes it.

2. Star Topology: All devices connect to a central hub or switch. Data flows through the hub,
allowing for easy expansion and better fault tolerance.

3. Ring Topology: Devices are connected in a closed loop. Data circulates around the ring
until it reaches its destination.

4. Mesh Topology: In a full mesh, every device is connected to every other device. This
provides redundancy and fault tolerance but can be complex and costly.

5. Hybrid Topology: Many networks use a combination of these topologies to meet their
specific requirements.

V. Network Services and Applications

Computer networks enable a wide range of services and applications, including:

1. Internet Browsing: Access to websites and web services using browsers.

2. Email: Sending and receiving electronic messages.

3. File Sharing: Sharing files and documents over the network.

4. Streaming: Watching videos, listening to music, or video conferencing.

5. Remote Access: Accessing devices or data remotely, such as remote desktop or cloud
storage.

6. VoIP (Voice over IP): Making voice calls over the internet.

7. Online Gaming: Multiplayer gaming over the internet.


5

VI. Network Security

Network security is crucial to protect data and privacy. It includes measures such as
firewalls, encryption, authentication, and intrusion detection systems to safeguard against
cyber threats like hacking, malware, and data breaches.

VII. Future Trends in Computer Networking

The field of computer networking is constantly evolving. Emerging trends include:

1. 5G and Beyond: Faster and more reliable wireless networks.

2. IoT (Internet of Things): Networks connecting billions of smart devices.

3. Edge Computing: Processing data closer to the source for lower latency.

4. Software-Defined Networking (SDN): Dynamic and programmable network management.

5. Quantum Networking: Leveraging quantum phenomena for ultra-secure communication.

VIII. Conclusion

Computer networks are the backbone of the digital age, enabling global communication,
data exchange, and access to information. Understanding the concepts, components, and
types of computer networks is essential in today's interconnected world. As technology
continues to advance, the role and importance of computer networks will only grow, shaping
the way we live, work, and interact.

1.1 Objectives

The objectives of this project are as follows:

- To design and implement a computer network with multiple VLANs.


- To configure inter-VLAN routing using routers.
- To simulate WAN connectivity using WAN emulation.
- To gain practical experience in network configuration and troubleshooting.

1.2 Scope

The scope of the project includes the setup of two switches, two routers, and WAN emulation
to create a functional network. Configuration details, challenges faced, and optimization
steps will be documented.

1.3 Scenario

Scenario: Educational Institution Network


6

In an educational institution, the network you've designed would play a pivotal role in
ensuring efficient communication, secure data transfer, and streamlined management of
various educational activities. Let's delve extensively into this scenario:

1. Segmented Network for Different Users

- VLAN 10 (Students): The Students' VLAN is dedicated to all student devices, including
laptops, tablets, and smartphones. In this VLAN, students can access the internet,
educational resources, and communicate with their peers and instructors.

- VLAN 20 (Teachers): Teachers have their VLAN, which is a secure network segment for
academic-related activities. They can access administrative tools, shared educational
resources, and communicate with both students and other faculty members.

- VLAN 30 (Guests): This VLAN is for visitors to the institution, such as guest lecturers,
parents, or prospective students. It offers limited access to the internet and select resources,
ensuring the security of the main network.

- VLAN 99 (Management): This VLAN is exclusively for network administrators and staff
responsible for maintaining and troubleshooting the network. It provides secure access to
network devices and configuration interfaces.

2. Inter-VLAN Communication

- Students can collaborate on projects, share files, and access online learning platforms
within their VLAN (VLAN 10).

- Teachers can use their dedicated VLAN (VLAN 20) for lesson planning, grading, and
accessing educational materials, all while maintaining a secure connection.

- Guests can connect to the network but have restricted access, ensuring that the main
network's security remains intact.

- Network administrators can remotely manage and troubleshoot network devices through
VLAN 99 without interfering with regular network traffic.

3. Resource Sharing and Collaboration

- Teachers can use their VLAN (VLAN 20) to upload educational content to shared drives,
making it accessible to students.

- Students within VLAN 10 can collaborate on projects and share research materials using
the institution's internal resources.

- Guests can access limited resources for presentations or meetings during their visits.
7

4. Security and Control

- The segmentation of the network ensures that even if one VLAN experiences issues, it
doesn't affect the functionality of other segments. For example, a network issue in the
Students' VLAN won't disrupt the Teachers' VLAN.

- Access control lists (ACLs) can be implemented to further restrict access between VLANs.
For instance, students may be allowed to access certain resources in the Teachers' VLAN,
but with limitations.

5. Dynamic IP Addressing and Scalability

- The DHCP configuration in your network allows for dynamic IP address assignment,
reducing administrative overhead. New devices that connect to the network receive IP
addresses automatically.

- As the institution grows and more devices are added to the network, the scalability of the
design ensures that new VLANs can be easily created and integrated into the existing
structure.

6. WAN Emulation for Real-World Experience

- The WAN emulation feature adds a layer of realism to the network. It allows students and
network administrators to simulate different network conditions, preparing them for real-world
scenarios where network conditions may vary.

7. Router Functionality

- Routers play a pivotal role in routing traffic between VLANs. They ensure that data flows
seamlessly between students, teachers, and guests while maintaining network security.

- The default route configured on the routers directs traffic to external networks, ensuring
that users can access online educational resources and connect to the wider internet.

8. Troubleshooting and Optimization

- In the event of network issues, network administrators can use the Troubleshooting and
Optimization section of your network configuration to diagnose and resolve problems
promptly. This minimises downtime and ensures the network runs smoothly.

9. Security and Privacy

- The network design focuses on maintaining the security and privacy of educational data.
Students' information is protected from unauthorised access, and teachers have a secure
platform for grading and academic planning.
8

10. Resource Availability

- The network's architecture ensures that resources such as educational materials,


databases, and online courses are available to all users without interruption.

In summary, the network you've designed is ideally suited for an educational institution. It
offers secure, segmented communication channels for students, teachers, and guests, while
network administrators can efficiently manage and troubleshoot the entire system. The
network's scalability and WAN emulation provide a dynamic and realistic environment for
learning and educational activities.

2. Network Design

2.1 Physical Connectivity

For physical connectivity, copper straight-through and copper crossover cables were used.
Copper straight-through cables were employed for switch-to-switch and switch-to-router
connections. Copper crossover cables were used for router-to-router connections, ensuring
the correct pinouts for transmission and reception.

2.2 Device Selection and Architecture

- Switches: Cisco 2960 Series switches were chosen for their robust Layer 2 capabilities.
- Routers: Cisco 2901 routers were selected for their routing capabilities and ability to handle
multiple subinterfaces for VLAN routing.

2.3 WAN Emulation

The project utilises WAN emulation with the "Cloud-PT" feature in Packet Tracer. This allows
for the simulation of wide area network conditions, providing a more realistic network
environment.

2.4 Benefits of Design Choices

- Copper Straight-Through and Crossover Cables:

- Benefits:
- Easy to set up and readily available.
- Cost-effective for short-distance connections.

- Shortcomings:
- Limited to specific use cases based on cable type (straight-through or crossover).
9

- Device Selection:

- Benefits:
- Cisco 2960 switches offer reliable Layer 2 functionality.
- Cisco 2901 routers support VLAN routing effectively.

- Shortcomings:
- May require a higher budget compared to consumer-grade devices.

- WAN Emulation:

- Benefits:
- Realistic network testing with WAN-like conditions.
- Enables testing network performance under various scenarios.

- Shortcomings:
- Requires more computational resources.

2.5 About Protocols

Understanding Internet, Network, and Routing Protocols

In the world of computer networking, protocols are essential for enabling communication
between devices and systems. These protocols govern how data is formatted, transmitted,
received, and processed across networks. Let's delve into the categories of protocols, their
significance, and explore the specific protocols used in the network you've created.

I. Internet Protocols

1. Internet Protocol (IP)

IP is the cornerstone of internet communication. It's responsible for addressing and routing
data packets so they can travel across networks. Two versions exist:

- IPv4: The older version with 32-bit addresses, e.g., 192.168.1.1.


- IPv6: The newer version with 128-bit addresses, e.g.,
2001:0db8:85a3:0000:0000:8a2e:0370:7334. IPv6 was introduced to address the exhaustion
of IPv4 addresses.

2. Internet Control Message Protocol (ICMP)

ICMP is used for network management and error reporting. It's essential for tools like ping
and traceroute and plays a role in error handling and diagnostics.

3. Internet Group Management Protocol (IGMP)


10

IGMP is used in IP networks to manage multicasting. It enables hosts to join or leave


multicast groups on a network.

II. Network Protocols

1. Transmission Control Protocol (TCP)

TCP provides reliable, connection-oriented communication. It ensures that data packets


reach their destination without errors or loss. Key features include error checking, flow
control, and congestion control.

2. User Datagram Protocol (UDP)

UDP offers lightweight, connectionless communication. While it lacks some of TCP's


reliability features, it's faster and more suitable for real-time applications like VoIP and online
gaming.

3. Internet Control Message Protocol (ICMP)

ICMP, mentioned earlier, is an essential network protocol for error reporting and diagnostics.
It includes messages like "Destination Unreachable" and "Time Exceeded."

4. Address Resolution Protocol (ARP)

ARP maps IP addresses to MAC (Media Access Control) addresses in a local network. It's
crucial for routing data within a LAN.

5. Dynamic Host Configuration Protocol (DHCP)

DHCP automates the process of IP address allocation to devices on a network. It assigns IP


addresses, subnet masks, and other configuration parameters dynamically.

III. Routing Protocols

Routing protocols are essential for directing data packets through a network. They ensure
efficient and reliable data transmission.

1. Routing Information Protocol (RIP)

RIP is a distance-vector routing protocol used in smaller networks. It determines the best
path to a destination based on the number of hops.

2. Open Shortest Path First (OSPF)

OSPF is a link-state routing protocol used in larger networks. It calculates the shortest path
to a destination based on a complex algorithm.
11

3. Border Gateway Protocol (BGP)

BGP is used on the internet to exchange routing and reachability information among
autonomous systems (ASes). It's crucial for global routing.

4. Static Routing

Static routing involves manually configuring the routing table. It's suitable for smaller
networks where routes don't change frequently.

IV. Protocols in my Network

In my network, I've utilised various protocols to facilitate communication and routing:

1. Internet Protocols (IP and ICMP)

- IP (IPv4 and possibly IPv6) is fundamental for addressing devices within your network.

- ICMP assists in network management and error reporting, which is crucial for
troubleshooting and diagnostics.

2. Network Protocols (TCP, UDP, ARP, DHCP)

- TCP and UDP enable reliable and connectionless communication within your network.

- ARP ensures that devices can map IP addresses to MAC addresses for local network
communication.

- DHCP dynamically assigns IP addresses to devices, simplifying network configuration.

3. Routing Protocols (RIP, OSPF, BGP, Static Routing)

- You've mentioned using RIP, OSPF, and static routing in your network configuration. These
protocols enable routers to determine the best paths for data transmission between VLANs
and networks.
- BGP, while not explicitly mentioned, may play a role in connecting to external networks or
the internet, depending on your network's design.

In conclusion, protocols are the unsung heroes of the networking world, responsible for
enabling seamless communication and efficient data routing. Understanding these protocols
is crucial for network administrators and engineers, as it forms the foundation of building and
maintaining robust and reliable computer networks.
12

2.6 Explanation of the network through code analysis

For Switch0:

1. VLAN Configuration:

- VLANs play a crucial role in network segmentation. In this configuration, four VLANs are
defined: VLAN 10 for Students, VLAN 20 for Teachers, VLAN 30 for Guests, and VLAN 99
for Management. Each VLAN is given a name to provide context for network administrators.

2. Port Configuration:

- The FastEthernet0/1 interface is configured as an access port in VLAN 10, connecting


devices for students. Similarly, the range of interfaces FastEthernet0/6 to FastEthernet0/10
is assigned to VLAN 10, ensuring that these ports are part of the Students' network.

- Interfaces FastEthernet0/2 and FastEthernet0/11 to FastEthernet0/14 are configured as


access ports in VLAN 20 (Teachers).

- Interfaces FastEthernet0/3 and FastEthernet0/15 to FastEthernet0/20 are assigned to


VLAN 30 (Guests).
- The range of interfaces FastEthernet0/21 to FastEthernet0/24 is configured as access
ports in VLAN 99 (Management). These ports might be reserved for network administrators
or critical devices.

3. Trunk Configuration:

- GigabitEthernet0/1 is configured as a trunk port, allowing it to carry traffic for VLANs 10,
20, 30, and 99. This is essential for inter-switch communication, as it enables data to flow
between VLANs.

- GigabitEthernet0/2 is also set as a trunk port, but it is currently shut down. This may
indicate a reserved or backup trunk link.
13

4. Management Consideration:

- VLAN 99 (Management) is likely used for managing the switch remotely. It provides a
secure network for network administrators to access and configure the switch.

For Switch1:

1. VLAN Configuration:

- Similar to Switch0, Switch1 configures four VLANs (10, 20, 30, and 99) with
corresponding names for Students, Teachers, Guests, and Management.

2. Port Configuration:

- Interfaces on Switch1 are configured similarly to Switch0, with ports assigned to the
respective VLANs. This ensures that devices in different segments are isolated from each
other.

3. Trunk Configuration:

- GigabitEthernet0/1 and GigabitEthernet0/2 on Switch1 are also configured as trunk ports,


mirroring the configuration of Switch0. This provides redundancy and load-balancing for
inter-switch connections.

For Router0:

1. Interface Configuration:

- Gig0/0 is configured with the IP address 192.168.10.1/24, serving as the gateway for
VLAN 10 (Students).

- Gig0/1 is configured with the IP address 192.168.99.1/24, serving as the gateway for
VLAN 99 (Management).

2. Subinterface Configuration:

- Subinterfaces are created for VLAN routing. These subinterfaces are defined for VLANs
10, 20, 30, and 99, allowing the router to route traffic between these VLANs.
- Each subinterface is assigned an IP address within the corresponding VLAN's subnet.

3. Serial Interface Configuration:

- The Serial0/3/0 interface is configured with the IP address 10.0.0.5/22. This interface
likely connects to another network, such as a wide area network (WAN) or the internet.
14

4. DHCP Configuration:

- DHCP pools are set up for each VLAN, ensuring that devices within these VLANs can
obtain IP addresses dynamically. Each DHCP pool specifies the network range, default
router (gateway), and DNS server.

5. Default Route:

- A default route is configured to direct all traffic with an unknown destination to the
Serial0/3/0 interface. This is typically used for internet-bound traffic.

For Router1:

1. Interface Configuration:

- Gig0/0 and Gig0/1 on Router1 are configured with IP addresses similarly to Router0.
They serve as the gateways for their respective VLANs.

2. Subinterface Configuration:

- Subinterfaces are created for VLAN routing, similar to Router0. Each subinterface
corresponds to a VLAN and has an IP address within that VLAN's subnet.

3. DHCP Configuration:

- DHCP pools are configured for each VLAN, allowing devices to obtain IP addresses
dynamically.

4. Default Route:

- A default route is set up to direct traffic with an unknown destination to the Serial0/3/0
interface. This is a common practice for routing traffic to external networks.

Common Considerations:

- VLANs are used for network segmentation, enhancing security and traffic isolation.

- Trunk ports are essential for inter-switch communication, ensuring that devices in different
VLANs can communicate when necessary.

- Routers play a critical role in routing traffic between VLANs, allowing for inter-VLAN
communication.

- DHCP pools simplify IP address assignment within each VLAN.


15

- Serial interfaces likely connect to external networks, such as WAN or the internet, and
require appropriate IP addressing.

This comprehensive configuration enables the creation of a segmented network with VLANs,
inter-VLAN routing, and dynamic IP address assignment, facilitating efficient communication
and management of devices within the network.

3. Network Implementation

3.1 Switch Configuration

- VLAN creation for segmentation.


- Port configuration with appropriate VLAN assignments.
- Trunk port configuration for inter-switch connectivity.

3.2 Router Configuration

- Subinterfaces creation for VLAN routing.


- IP address assignment to subinterfaces.
- Configuration of routing protocols (if necessary).

3.3 DHCP Configuration

- Creation of DHCP pools for each VLAN.


- Assignment of default routers and DNS servers.

3.4 Challenges Faced and Lessons Learned

- Challenges:
- Proper connectivity between routers and switches.
- Correct VLAN and subinterface configuration.
- Troubleshooting DHCP issues.
- Lessons:
- Importance of thorough testing.
- The significance of understanding VLANs and subinterfaces.
- Troubleshooting skills are crucial in network setup.

4. Troubleshooting and Optimization

4.1 Inter-VLAN Routing Issue

- Issue: Inter-VLAN routing was not functioning correctly.


- Solution: Proper subinterface configuration and routing protocol setup were implemented to
enable inter-VLAN communication.
16

4.2 Next-Hop IP Address Issue

- Issue: Incorrect next-hop IP addresses caused routing problems.


- Solution: Corrected next-hop IP addresses in router configurations, ensuring proper
routing.

4.3 Performance Optimization

- Performance was optimised by ensuring all interfaces were in the correct state (up/up) and
verifying VLAN configurations.

5. Conclusion

5.1 Project Outcomes

The project has resulted in a successfully designed and implemented computer network. All
objectives, including VLAN segmentation, inter-VLAN routing, and WAN emulation, were
achieved. The network can be implemented in multiple scenarios where mentioned
specifications are required.

5.2 Importance of a Well-Designed Network

A well-designed network is essential for efficient data communication, ensuring that data
flows smoothly and securely between devices. This project highlights the importance of
proper planning, configuration, and troubleshooting in network setup.

5.3 The Value of Cisco Packet Tracer

Cisco Packet Tracer played a vital role in this project, allowing us to simulate complex
network scenarios and gain real-world experience in network design and implementation.

6. References

- Cisco documentation and configuration guides.


- Online forums and communities for troubleshooting assistance.
- Classroom lectures and materials.

7. Appendix

7.1 A comprehensive guide on IP addressing and subnetting


IP Addressing and Subnetting: A Comprehensive Guide
17

IP addressing and subnetting are fundamental concepts in computer networking. They play
a critical role in routing data across networks, ensuring devices can communicate with each
other. In this comprehensive guide, we'll delve into the world of IP addressing, subnetting,
and their importance in modern network design and administration.

Part I: IP Addressing

What is an IP Address?

An IP (Internet Protocol) address is a numerical label assigned to each device on a


computer network that uses the Internet Protocol for communication. These addresses serve
two primary purposes:
1. Host Identification: They uniquely identify devices on a network, similar to how postal
addresses identify physical locations.
2. Routing: They assist routers in forwarding data packets to their intended destinations.

IPv4 vs. IPv6

- IPv4 (Internet Protocol version 4): This version uses a 32-bit address format, allowing for
approximately 4.3 billion unique addresses. IPv4 addresses are written as four decimal
numbers separated by periods (e.g., 192.168.1.1).
- IPv6 (Internet Protocol version 6): IPv6 was introduced to address the exhaustion of IPv4
addresses. It uses a 128-bit address format, providing an almost inexhaustible pool of
addresses. IPv6 addresses are written as eight groups of four hexadecimal digits, separated
by colons (e.g., 2001:0db8:85a3:0000:0000:8a2e:0370:7334).

IP Address Classes

IPv4 addresses are categorised into five classes, each with a different format and range of
available addresses:
1. Class A: Supports 16 million hosts on each of 128 networks.
2. Class B: Supports 65,000 hosts on each of 16,000 networks.
3. Class C: Supports 254 hosts on each of 2 million networks.
4. Class D: Reserved for multicast groups.
5. Class E: Reserved for experimental use.

Private and Public IP Addresses

To manage address scarcity, certain IP address ranges are reserved for private networks.
Devices on these networks can use private IP addresses, and a network address translator
(NAT) can map multiple private IP addresses to a single public IP address when
communicating with the internet.

Common private IP address ranges:


- Class A: 10.0.0.0 to 10.255.255.255
- Class B: 172.16.0.0 to 172.31.255.255
- Class C: 192.168.0.0 to 192.168.255.255
18

Part II: Subnetting

What is Subnetting?

Subnetting is the practice of dividing a large IP network into smaller, more manageable
sub-networks or subnets. This process offers several benefits:

- Efficient IP Address Utilisation: Subnetting prevents wastage of IP addresses by allocating


only the required number of addresses to each subnet.

- Isolation and Security: Subnets can be used to isolate parts of a network for security or
administrative purposes.

- Optimised Routing: Smaller subnets can lead to more efficient routing and reduced network
congestion.

Subnet Mask

A subnet mask is a 32-bit number that defines the network and host portions of an IP
address. It is represented in four decimal octets, just like IP addresses (e.g., 255.255.255.0).
The subnet mask contains consecutive 1s followed by consecutive 0s. The 1s indicate the
network bits, and the 0s indicate the host bits.

Subnetting Notation

When subnetting, you'll often encounter notations like `/24` or `/28` to represent the subnet
mask. For instance, `/24` means the first 24 bits of the IP address are network bits, and the
remaining bits are for hosts. This notation is a shorthand way of specifying subnet masks.

CIDR (Classless Inter-Domain Routing)

CIDR notation combines the IP address and subnet mask into a single string, using a format
like `192.168.1.0/24`. This notation simplifies routing table entries and allows for more
flexible network design.

Practical Steps for Subnetting

1. Determine Your Requirements: Decide how many subnets and hosts you need for your
network.

2. Choose a Subnet Mask: Select a subnet mask that satisfies your requirements.
3. Divide IP Range: Divide your IP address range into subnets based on the chosen subnet
mask.

4. Assign Addresses: Assign the first and last addresses in each subnet for network and
broadcast addresses, respectively. The remaining addresses are available for hosts.
19

7.2 History

Cisco: A Pioneering Force in Networking and Innovation

Cisco Systems, Inc., commonly referred to as Cisco, is a globally renowned technology


company with a rich history of innovation in the field of networking and communication.
Since its inception in 1984, Cisco has consistently played a pivotal role in shaping the way
the world connects, communicates, and collaborates through its cutting-edge devices and
solutions.

I. Cisco's Founding and Early Years

Cisco was founded by Leonard Bosack and Sandy Lerner, two computer scientists working
at Stanford University. Their initial innovation was the development of a multi-protocol router,
which allowed for the interconnection of different types of networks. This breakthrough laid
the foundation for the modern internet by enabling the seamless communication between
disparate networks.

II. Key Innovations and Milestones

1. The Birth of the Router

Cisco's first router, the Cisco 2500, was a game-changer in the networking industry. It
provided a flexible and scalable solution for routing data between networks, making it
possible to connect computers and devices across different locations and protocols.

2. The Catalyst Switch

Cisco introduced the Catalyst series of switches, which revolutionised local area network
(LAN) technology. These switches offered advanced features like virtual LANs (VLANs) and
improved network management capabilities. The Catalyst switch line continues to be an
industry leader in LAN switching technology.

3. Voice over IP (VoIP) Revolution

Cisco's innovation in VoIP technology transformed traditional telephone systems into more
efficient and cost-effective voice communication networks. Products like Cisco Unified
Communications Manager (formerly CallManager) paved the way for modern voice and
video communication solutions.

4. Internet Protocol Version 6 (IPv6) Adoption

As the world faced the impending exhaustion of IPv4 addresses, Cisco actively promoted the
adoption of IPv6. Cisco routers and devices have been instrumental in the transition to IPv6,
ensuring the continued growth of the internet.

5. Security Solutions
20

Cisco has been a leader in network security innovations, offering a comprehensive suite of
products and solutions. Cisco's Adaptive Security Appliance (ASA) and intrusion prevention
systems (IPS) are renowned for protecting networks against cyber threats.

6. Software-Defined Networking (SDN)

In the era of software-defined networking, Cisco introduced its Application Centric


Infrastructure (ACI) platform. ACI simplifies network management and automation, allowing
organisations to adapt to changing business needs more effectively.

7. Cloud and Data Center Technologies

Cisco has been at the forefront of data centre innovations with products like Cisco Unified
Computing System (UCS) and HyperFlex. These technologies have streamlined data centre
operations and enabled efficient cloud adoption.

8. Collaboration and Video Conferencing

Cisco Webex, one of the world's leading video conferencing and collaboration platforms, has
gained immense popularity. It enables remote work and virtual meetings on a global scale.

III. Cisco's Devices and Product Lines

Cisco offers a wide range of networking devices and solutions across various product lines:

1. Routers

Cisco's routers are the backbone of the internet, facilitating data transmission between
networks. They come in various series and sizes, from small office/home office (SOHO)
routers to high-capacity enterprise routers.

2. Switches

Cisco's switches are known for their scalability, performance, and advanced features. They
cater to diverse needs, from basic LAN switching to data centre fabrics.

3. Firewalls and Security Appliances

Cisco's security appliances and firewalls, including the Cisco ASA series, provide robust
protection against threats, ensuring the integrity and confidentiality of data.

4. Collaboration Tools

Cisco Webex, Unified Communications, and TelePresence solutions offer a comprehensive


suite for real-time communication, collaboration, and video conferencing.

5. Wireless Networking
21

Cisco's wireless solutions provide reliable and secure connectivity, supporting everything
from Wi-Fi in homes to large-scale enterprise wireless networks.

6. Data Center and Cloud Solutions

Cisco's data centre products, such as UCS servers and HyperFlex hyper-converged
infrastructure, enhance data centre efficiency and agility. Cisco also offers cloud-based
solutions for hybrid and multi-cloud environments.

7. Networking Software

Cisco's networking software includes operating systems, management tools, and SDN
solutions that streamline network operations, enhance security, and enable automation.

IV. Cisco's Impact on Networking and Beyond

Cisco's influence extends far beyond the world of networking. Its innovations have not only
transformed how we connect but have also contributed to the global economy, job creation,
and technological advancements. Cisco's commitment to corporate social responsibility is
evident through initiatives that promote education, healthcare, and environmental
sustainability.

In conclusion, Cisco is more than a technology company; it is an enduring force of innovation


that has reshaped the way the world communicates and collaborates. Its devices and
solutions continue to be at the forefront of technological advancements, and Cisco's vision
for a connected future remains a driving force in the ever-evolving landscape of networking
and technology.

7.3 Code of the Network:

For Switch0:

enable
configure terminal

vlan 10
name Students
exit

vlan 20
name Teachers
exit

vlan 30
name Guests
22

exit

vlan 99
name Management
exit

interface FastEthernet0/1
switchport mode access
switchport access vlan 10
no shutdown
exit

interface range FastEthernet0/6 - 10


switchport mode access
switchport access vlan 10
no shutdown
exit

interface range FastEthernet0/2, FastEthernet0/11-14


switchport mode access
switchport access vlan 20
no shutdown
exit

interface range FastEthernet0/3, FastEthernet0/15-20


switchport mode access
switchport access vlan 30
no shutdown
exit

interface range FastEthernet0/21-24


switchport mode access
switchport access vlan 99
no shutdown
exit

interface GigabitEthernet0/1
switchport mode trunk
switchport trunk allowed vlan 10,20,30,99
no shutdown
exit

interface GigabitEthernet0/2
switchport mode trunk
switchport trunk allowed vlan 10,20,30,99
shutdown
exit
23

interface FastEthernet0/4
switchport mode trunk
no shutdown
exit

For Switch1:
enable
configure terminal

vlan 10
name Students
exit

vlan 20
name Teachers
exit

vlan 30
name Guests
exit

vlan 99
name Management
exit

interface FastEthernet0/1
switchport mode access
switchport access vlan 10
no shutdown
exit

interface range FastEthernet0/6 - 10


switchport mode access
switchport access vlan 10
no shutdown
exit

interface range FastEthernet0/2, FastEthernet0/11-14


switchport mode access
switchport access vlan 20
no shutdown
exit

interface range FastEthernet0/3, FastEthernet0/15-20


switchport mode access
24

switchport access vlan 30


no shutdown
exit

interface range FastEthernet0/21-24


switchport mode access
switchport access vlan 99
no shutdown
exit

interface GigabitEthernet0/1
switchport mode trunk
switchport trunk allowed vlan 10,20,30,99
no shutdown
exit

interface GigabitEthernet0/2
switchport mode trunk
switchport trunk allowed vlan 10,20,30,99
shutdown
exit

interface FastEthernet0/4
switchport mode trunk
no shutdown
exit

For Router0:

enable
configure terminal

interface Gig0/0
ip address 192.168.10.1 255.255.255.0
no shutdown
exit

interface Gig0/1
ip address 192.168.99.1 255.255.255.0
no shutdown
exit

interface Gig0/0.10
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
no shutdown
25

exit

interface Gig0/0.20
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
no shutdown
exit

interface Gig0/0.30
encapsulation dot1Q 30
ip address 192.168.30.1 255.255.255.0
no shutdown
exit

interface Serial0/3/0
ip address 10.0.0.5 255.255.252.0
no shutdown
exit

ip dhcp pool Students


network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
dns-server 8.8.8.8
exit

ip dhcp pool Teachers


network 192.168.20.0 255.255.255.0
default-router 192.168.20.1
dns-server 8.8.8.8
exit

ip dhcp pool Guests


network 192.168.30.0 255.255.255.0
default-router 192.168.30.1
dns-server 8.8.8.8
exit

ip dhcp pool Management


network 192.168.99.0 255.255.255.0
default-router 192.168.99.1
dns-server 8.8.8.8
exit

ip route 0.0.0.0 0.0.0.0 Serial0/3/0

end
write memory
26

For Router1:

enable
configure terminal

interface Gig0/0
ip address 192.168.40.1 255.255.255.0
no shutdown
exit

interface Gig0/1
ip address 192.168.50.1 255.255.255.0
no shutdown
exit

interface Serial0/3/0
ip address 10.0.0.3 255.255.252.0
no shutdown
exit

interface Gig0/0.10
encapsulation dot1Q 10
ip address 192.168.10.2 255.255.255.0
no shutdown
exit

interface Gig0/0.20
encapsulation dot1Q 20
ip address 192.168.20.2 255.255.255.0
no shutdown
exit

interface Gig0/0.30
encapsulation dot1Q 30
ip address 192.168.30.2 255.255.255.0
no shutdown
exit

interface Gig0/0.99
encapsulation dot1Q 99
ip address 192.168.99.2 255.255.255.0
no shutdown
exit

ip dhcp pool Students


network 192.168.10.0 255.255.255.0
27

default-router 192.168.10.2
dns-server 8.8.8.8
exit

ip dhcp pool Teachers


network 192.168.20.0 255.255.255.0
default-router 192.168.20.2
dns-server 8.8.8.8
exit

ip dhcp pool Guests


network 192.168.30.0 255.255.255.0
default-router 192.168.30.2
dns-server 8.8.8.8
exit

ip dhcp pool Management


network 192.168.99.0 255.255.255.0
default-router 192.168.99.3
dns-server 8.8.8.8
exit

ip route 0.0.0.0 0.0.0.0 Serial0/3/0

end
write memory

This is the code of the network. We have two Switch(namely Switch0 and Switch1). We have
two routers(namely Router0 and Router1). Switches are connected to routers individually but
one of the connections is shut down and can be brought online in scenarios of breakage.

7.4 Some Glimpses:

Picture1:
28

This picture shows the inter-vlan capability of the network. Inter-vlan configuration in the
routers of this network allows computers on different vlan to communicate with each other.

Picture2:

This picture shows the communication between a PC and a Router. Even though the route to
WAN emulation (Cloud PT0) is blocked due to lack of ip assigning mechanism, the PC can
communicate with the Router.

You might also like