10.2.1.9 Lab - Configure A Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM - Instructor
10.2.1.9 Lab - Configure A Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM - Instructor
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA
5505 ASDM (Instructor Version)
Instructor Note: Red font color or gray highlights indicate text that appears in the instructor copy only.
Topology
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 1 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
IP Addressing Table
Objectives
Part 1: Basic Router/Switch/PC Configuration
Cable the network and clear previous device settings, as shown in the topology.
Configure basic settings for routers.
Configure PC host IP settings.
Verify connectivity.
Save the basic running configuration for each router and switch.
Part 2: Accessing the ASA Console and ASDM
Access the ASA console.
Clear the previous ASA configuration settings.
Bypass Setup mode.
Use the CLI command script to configure the ASA.
Verify HTTP ASDM access.
Part 3: Configuring the ISR as a Site-to-Site IPsec VPN Endpoint Using the CLI
Configure basic VPN connection information settings.
Specify IKE policy parameters.
Configure a transform set.
Specify traffic to protect.
Review the summary of the configuration.
Review the site-to-site VPN tunnel configuration.
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 2 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
Part 4: Configuring the ASA as a Site-to-Site IPsec VPN Endpoint Using ASDM
Access ASDM.
Review the ASDM Home screen.
Start the VPN wizard.
Configure peer device identification.
Specify the traffic to protect.
Configure authentication.
Configure miscellaneous settings.
Review the configuration summary and deliver the commands to the ASA.
Verify the ASDM VPN connection profile.
Test the VPN configuration from R3.
Use ASDM monitoring to verify the tunnel.
Background/Scenario
In addition to acting as a remote access VPN concentrator, the ASA can provide site-to-site IPsec VPN
tunneling. The tunnel can be configured between two ASAs or between an ASA and another IPsec VPN-
capable device, such as an ISR, as is the case with this lab.
Your company has two locations connected to an ISP. R1 represents a customer-premise equipment (CPE)
device managed by the ISP. R2 represents an intermediate Internet router. R3 connects users at the remote
branch office to the ISP. The ASA is an edge security device that connects the internal corporate network and
DMZ to the ISP while providing NAT services to inside hosts.
Management has asked you to provide a dedicated site-to-site IPsec VPN tunnel between the ISR router at
the remote branch office and the ASA device at the corporate site. This tunnel will protect traffic between the
branch office LAN and the corporate LAN, as it passes through the Internet. The site-to-site VPN does not
require a VPN client on the remote or corporate site host computers. Traffic from either LAN to other Internet
destinations is routed by the ISP and is not protected by the VPN tunnel. The VPN tunnel will pass through
R1 and R2; both routers are not aware of the tunnel’s existence.
In Part 1 of this lab, you will configure the topology and non-ASA devices. In Part 2, you will prepare the ASA
for ASDM access. In Part 3, you will use the CLI to configure the R3 ISR as a site-to-site IPsec VPN endpoint.
In Part 4, you will configure the ASA as a site-to-site IPsec VPN endpoint using the ASDM VPN wizard.
Note: The router commands and output in this lab are from a Cisco 1941 router with Cisco IOS Release
15.4(3)M2 (with a Security Technology Package license). Other routers and Cisco IOS versions can be used.
See the Router Interface Summary Table at the end of this lab to determine which interface identifiers to use
based on the equipment in the lab. Depending on the router model and Cisco IOS version, the commands
available and the output produced might vary from what is shown in this lab.
The ASA used with this lab is a Cisco model 5505 with an 8-port integrated switch, running OS version 9.2(3)
and ASDM version 7.4(1) and comes with a Base license that allows a maximum of three VLANs.
Note: Before beginning, ensure that the routers and switches have been erased and have no startup
configurations.
Instructor Note: Instructions for erasing switches and routers are provided in Chapter 0.0.0.0. Instructions for
erasing the ASA, accessing the console, and accessing ASDM are provided in this lab.
Required Resources
1 ASA 5505 (OS version 9.2(3) and ASDM version 7.4(1) and Base license or comparable)
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 3 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
3 routers (Cisco 1941 with Cisco IOS Release 15.4(3)M2 image with a Security Technology package
license)
3 switches (Cisco 2960 or comparable) (not required)
3 PCs (Windows 7 or Windows 8.1, with SSH Client software installed)
Serial and Ethernet cables, as shown in the topology
Console cables to configure Cisco networking devices
Instructor Notes:
This lab has four main parts. Part 1 and 2 can be performed separately but must be performed before
parts 3 and 4. Part 2 prepares the ASA for ASDM access. Part 3 configures the R3 ISR as a site-to-site
IPsec VPN endpoint using the CLI. Part 4 configures the opposite end of the tunnel on the ASA using
ASDM. Parts 3 and 4 should be performed sequentially. Each part will use CLI and ASDM as required to
verify the configuration.
The main goal is to configure a site-to-site IPsec VPN between two sites using an ISR at one end of the
tunnel and an ASA at the other end.
The final running configs for all devices are found at the end of the lab.
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 4 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
login local
transport input ssh
exec-timeout 5 0
logging synchronous
exit
interface gigabitethernet 0/0
ip address 209.165.200.225 255.255.255.248
no shut
exit
int serial 0/0/0
ip address 10.1.1.1 255.255.255.252
clock rate 2000000
no shut
exit
ip route 0.0.0.0 0.0.0.0 Serial0/0/0
crypto key generate rsa general-keys modulus 1024
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 5 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
exit
ip route 209.165.200.224 255.255.255.248 Serial0/0/0
ip route 172.16.3.0 255.255.255.0 Serial0/0/1
crypto key generate rsa general-keys modulus 1024
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 6 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
Note: If you can ping from PC-C to R1 G0/0 and S0/0/0, you have demonstrated that static routing is
configured and functioning correctly.
Save the running configuration for each router.
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 7 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 209.165.200.226 255.255.255.248
!
interface Vlan3
no forward interface Vlan1
nameif dmz
security-level 70
ip address 192.168.2.1 255.255.255.0
!
object network inside-net
subnet 192.168.1.0 255.255.255.0
!
object network dmz-server
host 192.168.2.3
!
access-list OUTSIDE-DMZ extended permit ip any host 192.168.2.3
!
object network inside-net
nat (inside,outside) dynamic interface
!
object network dmz-server
nat (dmz,outside) static 209.165.200.227
!
access-group OUTSIDE-DMZ in interface outside
!
route outside 0.0.0.0 0.0.0.0 209.165.200.225 1
!
username admin01 password admin01pass
!
aaa authentication ssh console LOCAL
aaa authentication http console LOCAL
!
http server enable
http 192.168.1.0 255.255.255.0 inside
ssh 192.168.1.0 255.255.255.0 inside
ssh timeout 10
!
class-map inspection_default
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 8 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
match default-inspection-traffic
policy-map global_policy
class inspection_default
inspect icmp
!
crypto key generate rsa modulus 1024
e. At the privileged EXEC mode prompt, issue the write mem (or copy run start) command to save the
running configuration to the startup configuration and the RSA keys to non-volatile memory.
Part 3: Configuring the ISR as a Site-to-Site IPsec VPN Endpoint Using the
CLI
In Part 3 of this lab, you will configure R3 as an IPsec VPN endpoint for the tunnel between R3 and the ASA.
R1 and R2 are unaware of the tunnel.
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 9 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
Issue the crypto isakmp policy number global configuration mode command on R1 for policy 10.
R1(config)# crypto isakmp policy 10
c. View the various IKE parameters available using Cisco IOS help by typing a question mark (?).
R1(config-isakmp)# ?
ISAKMP commands:
authentication Set authentication method for protection suite
default Set a command to its defaults
encryption Set encryption algorithm for protection suite
exit Exit from ISAKMP protection suite configuration mode
group Set the Diffie-Hellman group
hash Set hash algorithm for protection suite
lifetime Set lifetime for ISAKMP security association
no Negate a command or set its defaults
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 10 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
used to enter a pre-shared key. Use the IP address of the remote peer. The IP address is the remote
interface that the peer would use to route traffic to the local router.
Which IP address should you use to configure the IKE peer, given the topology diagram and IP addressing
table?
____________________________________________________________________________________
____________________________________________________________________________________
____________________________________________________________________________________
The IP address should be the ASA outside IP address of 209.165.200.226.
Each IP address that is used to configure the IKE peers is also referred to as the IP address of the remote
VPN endpoint. Configure the pre-shared key of SECRET-KEY on R3. Production networks should use a
complex key. This command points to the remote ASA outside IP address.
R3(config)# crypto isakmp key SECRET-KEY address 209.165.200.226
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 11 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 12 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
b. Use the match address access-list command to specify which access list defines which traffic to encrypt.
R3(config-crypto-map)# match address VPN-ACL
c. Setting a peer IP or hostname is required. Set it to the ASA remote VPN endpoint interface using the
following command.
R3(config-crypto-map)# set peer 209.165.200.226
d. Use the set transform-set tag command to hard code the transform set to be used with this peer.
R3(config-crypto-map)# set transform-set ESP-TUNNEL
R3(config-crypto-map)# exit
e. Apply the crypto map to interfaces.
Note: The SAs are not established until the crypto map has been activated by interesting traffic. The
router generates a notification that crypto is now on.
Apply the crypto maps to the R3 Serial 0/0/1 interface.
R3(config)# interface Serial0/0/1
R3(config-if)# crypto map S2S-MAP
R3(config-if)# end
R3#
*Mar 9 06:23:03.863: %CRYPTO-6-ISAKMP_ON_OFF: ISAKMP is ON
R3#
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 13 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
b. At the ASDM welcome page, click Run ASDM. The ASDM-IDM Launcher will display.
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 14 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
b. Review the on-screen text and topology diagram and click Next to continue.
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 15 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
Note: If the ASA does not respond, you may need to close the window and continue to the next step. If
prompted to authenticate, log in again as admin01 with the password admin01pass.
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 16 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 17 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
Step 8: Review the configuration summary and deliver the commands to the ASA.
The Summary page is displayed next. Verify that the information configured is correct. You can click Back to
make changes, or click Cancel and restart the VPN wizard (recommended). Click Finish to complete the
process and deliver the commands to the ASA.
Note: If prompted to authenticate, log in again as admin01 with the password admin01pass.
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 18 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 19 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
b. This generates interesting traffic. Notice how two pings failed before being successful. This is because
the tunnel first had to be negotiated and established before the ICMP packets could be successful.
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 20 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
c. The VPN information is now being displayed on the ASDM Monitoring > VPN > VPN Statistics >
Sessions page.
Note: You may need to click Refresh before the statistics will display.
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 21 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
d. Click Encryption Statistics. You should see one or more sessions using the 3DES encryption algorithm.
e. Click Crypto Statistics. You should see values for the number of packets encrypted and decrypted,
security association (SA) requests, etc.
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 22 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
Reflection
Describe a situation where a site-to-site IPsec VPN would be preferable over other VPN options.
_______________________________________________________________________________________
_______________________________________________________________________________________
_______________________________________________________________________________________
_______________________________________________________________________________________
_______________________________________________________________________________________
_______________________________________________________________________________________
_______________________________________________________________________________________
When a large number of hosts exist at a remote office and traffic between the office and a central site needs
to be protected. One disadvantage of the site-to-site VPN is that traffic on the remote network (connecting
host) is not protected. Only the traffic between the site-to-site tunnel endpoints is protected.
Router Model Ethernet Interface #1 Ethernet Interface #2 Serial Interface #1 Serial Interface #2
1800 Fast Ethernet 0/0 Fast Ethernet 0/1 Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
(F0/0) (F0/1)
1900 Gigabit Ethernet 0/0 Gigabit Ethernet 0/1 Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
(G0/0) (G0/1)
2801 Fast Ethernet 0/0 Fast Ethernet 0/1 Serial 0/1/0 (S0/1/0) Serial 0/1/1 (S0/1/1)
(F0/0) (F0/1)
2811 Fast Ethernet 0/0 Fast Ethernet 0/1 Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
(F0/0) (F0/1)
2900 Gigabit Ethernet 0/0 Gigabit Ethernet 0/1 Serial 0/0/0 (S0/0/0) Serial 0/0/1 (S0/0/1)
(G0/0) (G0/1)
Note: To find out how the router is configured, look at the interfaces to identify the type of router and how many
interfaces the router has. There is no way to effectively list all the combinations of configurations for each router
class. This table includes identifiers for the possible combinations of Ethernet and Serial interfaces in the device.
The table does not include any other type of interface, even though a specific router may contain one. An
example of this might be an ISDN BRI interface. The string in parenthesis is the legal abbreviation that can be
used in Cisco IOS commands to represent the interface.
Device Configs
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 23 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
!
hostname CCNAS-ASA
domain-name ccnasecurity.com
enable password 9D8jmmmgkfNZLETh encrypted
xlate per-session deny tcp any4 any4
xlate per-session deny tcp any4 any6
xlate per-session deny tcp any6 any4
xlate per-session deny tcp any6 any6
xlate per-session deny udp any4 any4 eq domain
xlate per-session deny udp any4 any6 eq domain
xlate per-session deny udp any6 any4 eq domain
xlate per-session deny udp any6 any6 eq domain
names
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
switchport access vlan 3
!
interface Ethernet0/3
shutdown
!
interface Ethernet0/4
shutdown
!
interface Ethernet0/5
shutdown
!
interface Ethernet0/6
shutdown
!
interface Ethernet0/7
shutdown
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 209.165.200.226 255.255.255.248
!
interface Vlan3
no forward interface Vlan1
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 24 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
nameif dmz
security-level 70
ip address 192.168.2.1 255.255.255.0
!
ftp mode passive
dns server-group DefaultDNS
domain-name ccnasecurity.com
object network inside-net
subnet 192.168.1.0 255.255.255.0
object network dmz-server
host 192.168.2.3
object network NETWORK_OBJ_172.16.3.0_24
subnet 172.16.3.0 255.255.255.0
object network NETWORK_OBJ_192.168.1.0_24
subnet 192.168.1.0 255.255.255.0
access-list OUTSIDE-DMZ extended permit ip any host 192.168.2.3
access-list outside_cryptomap extended permit ip 192.168.1.0 255.255.255.0
172.16.3.0 255.255.255.0
pager lines 24
mtu inside 1500
mtu outside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
nat (inside,outside) source static NETWORK_OBJ_192.168.1.0_24
NETWORK_OBJ_192.168.1.0_24 destination static NETWORK_OBJ_172.16.3.0_24
NETWORK_OBJ_172.16.3.0_24 no-proxy-arp route-lookup
!
object network inside-net
nat (inside,outside) dynamic interface
object network dmz-server
nat (dmz,outside) static 209.165.200.227
access-group OUTSIDE-DMZ in interface outside
route outside 0.0.0.0 0.0.0.0 209.165.200.225 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
aaa authentication telnet console LOCAL
aaa authentication ssh console LOCAL
aaa authentication http console LOCAL
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 25 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 26 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 27 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
encryption aes-256
hash sha
group 2
lifetime 86400
crypto ikev1 policy 30
authentication pre-share
encryption aes-256
hash sha
group 2
lifetime 86400
crypto ikev1 policy 40
authentication crack
encryption aes-192
hash sha
group 2
lifetime 86400
crypto ikev1 policy 50
authentication rsa-sig
encryption aes-192
hash sha
group 2
lifetime 86400
crypto ikev1 policy 60
authentication pre-share
encryption aes-192
hash sha
group 2
lifetime 86400
crypto ikev1 policy 70
authentication crack
encryption aes
hash sha
group 2
lifetime 86400
crypto ikev1 policy 80
authentication rsa-sig
encryption aes
hash sha
group 2
lifetime 86400
crypto ikev1 policy 90
authentication pre-share
encryption aes
hash sha
group 2
lifetime 86400
crypto ikev1 policy 100
authentication crack
encryption 3des
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 28 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
hash sha
group 2
lifetime 86400
crypto ikev1 policy 110
authentication rsa-sig
encryption 3des
hash sha
group 2
lifetime 86400
crypto ikev1 policy 120
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto ikev1 policy 130
authentication crack
encryption des
hash sha
group 2
lifetime 86400
crypto ikev1 policy 140
authentication rsa-sig
encryption des
hash sha
group 2
lifetime 86400
crypto ikev1 policy 150
authentication pre-share
encryption des
hash sha
group 2
lifetime 86400
crypto ikev1 policy 65535
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 10
ssh stricthostkeycheck
ssh 192.168.1.0 255.255.255.0 inside
ssh timeout 10
ssh key-exchange group dh-group1-sha1
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 29 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 30 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
subscribe-to-alert-group diagnostic
subscribe-to-alert-group environment
subscribe-to-alert-group inventory periodic monthly
subscribe-to-alert-group configuration periodic monthly
subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:8d83dd856f98a0f1e574fba6c6bfc478
: end
Router R1
Building configuration...
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 31 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
ip address 10.1.1.1 255.255.255.252
clock rate 2000000
!
interface Serial0/0/1
no ip address
shutdown
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 Serial0/0/0
!
control-plane
!
line con 0
exec-timeout 5 0
logging synchronous
login local
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
exec-timeout 5 0
logging synchronous
login local
transport input ssh
!
scheduler allocate 20000 1000
!
end
Router R2
R2# show run
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 32 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
Building configuration...
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 33 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
!
interface Serial0/0/0
ip address 10.1.1.2 255.255.255.252
!
interface Serial0/0/1
ip address 10.2.2.2 255.255.255.252
clock rate 2000000
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 172.16.3.0 255.255.255.0 Serial0/0/1
ip route 209.165.200.224 255.255.255.248 Serial0/0/0
!
control-plane
!
line con 0
exec-timeout 5 0
logging synchronous
login local
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
exec-timeout 5 0
logging synchronous
login local
transport input telnet
!
scheduler allocate 20000 1000
end
Router R3
R3# show run
Building configuration...
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 34 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
hostname R3
!
boot-start-marker
boot-end-marker
!
security passwords min-length 10
enable secret 9 $9$bkZXRtRQF6uqE.$MenFawyYEn642ALi3kGNBttfJxBOYk3fScLmuOFO9Tg
!
no aaa new-model
memory-size iomem 15
!
ip domain name ccnasecurity.com
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
cts logging verbose
!
vtp domain TSHOOT
vtp mode transparent
username admin01 secret 9
$9$3gQ5keGlFNmNx.$YmVC/lGkYSErJRHSxRZ13xek9HBYHOASaKmQjYeHx36
!
redundancy
!
crypto isakmp policy 10
encr 3des
authentication pre-share
group 2
crypto isakmp key SECRET-KEY address 209.165.200.226
!
crypto ipsec transform-set ESP-TUNNEL esp-3des esp-sha-hmac
mode tunnel
!
crypto map S2S-MAP 10 ipsec-isakmp
set peer 209.165.200.226
set transform-set ESP-TUNNEL
match address VPN-ACL
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 35 of 36 www.netacad.com
Lab – Configure a Site-to-Site IPsec VPN Using ISR CLI and ASA 5505 ASDM
!
interface GigabitEthernet0/1
ip address 172.16.3.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
clock rate 125000
!
interface Serial0/0/1
ip address 10.2.2.1 255.255.255.252
crypto map S2S-MAP
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 Serial0/0/1
!
ip access-list extended VPN-ACL
permit ip 172.16.3.0 0.0.0.255 192.168.1.0 0.0.0.255
!
control-plane
!
line con 0
exec-timeout 5 0
logging synchronous
login local
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
exec-timeout 5 0
logging synchronous
login local
transport input ssh
!
scheduler allocate 20000 1000
!
end
Switches S1, S2 and S3 – Use default configs, except for host name
© 2015 - 2019 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 36 of 36 www.netacad.com