0% found this document useful (0 votes)
29 views

Configuration Guide - Interoperating With Cisco Systems v1.00

This document provides guidance on configuring D-Link and Cisco switches to interoperate in a multi-vendor network environment. It covers terminology, topology examples, and step-by-step configuration instructions for VLANs, link aggregation, spanning tree, multiple spanning tree, and OSPF routing. The configurations shown allow ports on D-Link and Cisco switches to be assigned to the appropriate VLANs and trunks to be set up to carry multiple VLANs between switches.

Uploaded by

sanajy15880
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
0% found this document useful (0 votes)
29 views

Configuration Guide - Interoperating With Cisco Systems v1.00

This document provides guidance on configuring D-Link and Cisco switches to interoperate in a multi-vendor network environment. It covers terminology, topology examples, and step-by-step configuration instructions for VLANs, link aggregation, spanning tree, multiple spanning tree, and OSPF routing. The configurations shown allow ports on D-Link and Cisco switches to be assigned to the appropriate VLANs and trunks to be set up to carry multiple VLANs between switches.

Uploaded by

sanajy15880
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
You are on page 1/ 38

Interoperating with Cisco Systems

Interoperating with Cisco Version: 1.00


Published: Mar 19, 2010
Systems D-Link HQ

Scope
This guide is a one-stop resource to help users to setup their network quickly and optimize the
features of D-Link and vendors’ equipments smoothly. This guide focuses on the configuration of
D-Link and Cisco switches and includes topology examples for setting up a multi-vendor
environment.

Use this document to learn, use and configure the different features of D-Link and Cisco
management switches.

Audience
This document is written for system administrators, network managers and IT personnel who are
responsible for the deployment of management switches.

About This Guide


This guide is structured into 4 parts as follows:

Title Description
Terminology Detailed descriptions of functions that are used to explain similar concepts on
both D-Link & Cisco platforms.
Topology Topology examples when working in interoperability mode.
Configuration Step-by-step instructions on how to configure and setup the devices.
Troubleshooting Command examples on how to quickly troubleshoot and configure if
Examples interoperation fails.

1
Interoperating with Cisco Systems

Table Of Contents
VLAN Configuration ...................................................................................................... 3
Terminology ........................................................................................................... 3
Topology ............................................................................................................... 3
Configuration ......................................................................................................... 3
Troubleshooting Examples........................................................................................ 5
Link Aggregation ........................................................................................................ 10
Terminology ......................................................................................................... 10
Compatibility between D-Link Port-trunking and Cisco Port-Channel ............................. 10
Topology ............................................................................................................. 11
Configuration ....................................................................................................... 11
Troubleshooting Examples...................................................................................... 11
Spanning Tree Configuration ........................................................................................ 17
Terminology ......................................................................................................... 17
Topology ............................................................................................................. 17
Configuration ....................................................................................................... 17
Troubleshooting Examples...................................................................................... 18
Multiple Spanning Tree Configuration ............................................................................ 21
Terminology ......................................................................................................... 21
Compatibility between MSTP and PVST .................................................................... 21
Topology ............................................................................................................. 21
Configuration ....................................................................................................... 21
Troubleshooting Examples...................................................................................... 23
Open Shortest Path Fast (OSPF) Configuration................................................................ 27
Terminology ......................................................................................................... 27
Topology – Single OSPF Area .................................................................................. 27
Configuration ....................................................................................................... 27
Troubleshooting Examples...................................................................................... 29
Topology – Multiple OSPF Areas .............................................................................. 33
Configuration ....................................................................................................... 34
Troubleshooting Examples...................................................................................... 36

2
Interoperating with Cisco Systems

VLAN Configuration
This chapter deals with port-based VLANs that Cisco and D-Link switches support.

Terminology

Cisco D-Link Description


Trunking Port Tagged Port This port carries multiple 802.1Q tagged VLANs that are usually
used for uplink and IP phone ports.
Access Port Untagged Port A port which is an untagged member of a VLAN.
Native VLAN Untagged In a Cisco VLAN trunk, traffic belonging to the native vlan is not
Membership of included in the VLAN trunk. That is, the untagged frames
Physical Ports received by VLAN trunking port, will be assigned the access
VLAN ID of this port.
By default, all VLAN membership of D-Link switches and access
VLAN in Cisco switches is VLAN 1.

Topology

Figure-1 Port-based VLAN Configuration

Configuration
VLAN Configuration on a Cisco Switch

The following section lists step-by-step instructions for configuring VLAN & IP on Cisco and
D-Link management switches.

3
Interoperating with Cisco Systems

Command Example Purpose


Catalyst# config terminal To create VLAN
Step 1 Catalyst(config)# vlan 10,20,30 interfaces for ports
Catalyst(config-vlan)# exit 10, 20 and 30.
Catalyst(config)# interface range gigabitEthernet
1/0/1-6
Catalyst(config-if)# switchport mode access
Catalyst(config-if)# switchport access vlan 10
Catalyst(config-if)# exit

Catalyst(config)# interface range gigabitEthernet


To change ports to
1/0/7-12
access mode and
Step 2 Catalyst(config-if)# switchport mode access
assign membership
Catalyst(config-if)# switchport access vlan 20
for each VLAN.
Catalyst(config-if)# exit

Catalyst(config)# interface range gigabitEthernet


1/0/13-18
Catalyst(config-if)# switchport mode access
Catalyst(config-if)# switchport access vlan 30
Catalyst(config-if)# exit
Catalyst(config)# interface gigabitEthernet 1/0/21
Catalyst(config-if)# switchport trunk encapsulation
dot1q
To create a VLAN
Step 3 Catalyst(config-if)# switchport trunk allowed vlan
trunking port.
1,10,20,30
Catalyst(config-if)# switchport mode trunk
Catalyst(config-if)# exit

Note: By default a Cisco VLAN trunk sends to and receives traffic from all VLANs. To restrict
the traffic a VLAN trunk carries, remove vlan-list parameter to remove specific VLANs
from the allowed list.

Note: By default, all ports of a Cisco switch belong to VLAN 1, access mode.

IP Configuration on a Cisco Switch

The following configuration example is for L3 switches. For layer 3 switches, an IP address has
to be defined for each VLAN and for a layer 2 switch, an IP address can only be configured on one
VLAN for management purposes.

Command Example Purpose


Catalyst(config)# interface vlan 1
Catalyst(config-vlan)# ip address 192.168.0.1
255.255.255.0
Catalyst(config-vlan)# no shutdown
Catalyst(config-vlan)# exit
To configure the IP
Step 4 addresses for the
Catalyst(config)# interface vlan 10
VLAN interfaces.
Catalyst(config-vlan)# ip address 192.168.10.1
255.255.255.0
Catalyst(config-vlan)# no shutdown
Catalyst(config-vlan)# exit

4
Interoperating with Cisco Systems

Catalyst(config)# interface vlan 20


Catalyst(config-vlan)# ip address 192.168.20.1
255.255.255.0
Catalyst(config-vlan)# no shutdown
Catalyst(config-vlan)# exit

Catalyst(config)# interface vlan 30


Catalyst(config-vlan)# ip address 192.168.30.1
255.255.255.0
Catalyst(config-vlan)# no shutdown
Catalyst(config-vlan)# exit

VLAN Configuration on a D-Link Switch

In this example, ports 1 to 18 are removed from VLAN 1(default VLAN) and are assigned to each
VLAN. Here are the details:
• Ports 1 to 6 are assigned to VLAN 10.
• Ports 7 to 12 are assigned to VLAN 20.
• Ports 13 to 18 are assigned to VLAN 30.
• Port 21 (uplink) is tagged with VLAN 10, 20, 30 and belongs to an untagged member of
VLAN 1.

Command Example Purpose


switch# create vlan 10 tag 10
switch# create vlan 20 tag 20
switch# create vlan 30 tag 30
To create VLAN
switch# config vlan default delete 1-18
interfaces for ports
Step 1 switch# config vlan 10 add untagged 1-6
10, 20, 30 and assign
switch# config vlan 20 add untagged 7-12
port membership.
switch# config vlan 30 add untagged 13-18
switch# config vlan 10 add tagged 19-21
switch# config vlan 20 add tagged 19-21
switch# config vlan 30 add tagged 19-21

IP Configuration on a D-Link Switch

The following configuration example is for L3 switches.


For layer 3 switches, an IP address has to be defined for each VLAN and for a layer 2 switch, only
system IP address has to be defined.

Command Example Purpose


switch# config ipif System ipaddress 192.168.0.2/24
To configure the IP
switch# create ipif 10 192.168.10.2/24 10
Step 2 addresses for the
switch# create ipif 20 192.168.20.2/24 20
VLAN interfaces.
switch# create ipif 30 192.168.30.2/24 30

Troubleshooting Examples
The following section lists command examples for verifying VLANs and port assignments on
Cisco and D-Link switches.

Verifying VLANs and Ports Assignments on a Cisco Switch

The following example shows you how to verify the member ports and all the VLAN interfaces.

5
Interoperating with Cisco Systems

Command Example
Catalyst# show vlan

VLAN Name Status Ports


---- -------------------------------- --------- ----------------------------
1 default active Gi1/0/19, Gi1/0/20, Gi1/0/21, Gi1/0/22, Gi1/0/23,
Gi1/0/24
10 VLAN0010 active Gi1/0/1, Gi1/0/2, Gi1/0/3, Gi1/0/4, Gi1/0/5, Gi1/0/6
20 VLAN0020 active Gi1/0/7, Gi1/0/8, Gi1/0/9, Gi1/0/10, Gi1/0/11,
Gi1/0/12
30 VLAN0030 active Gi1/0/13, Gi1/0/14, Gi1/0/15, Gi1/0/16, Gi1/0/17,
Gi1/0/18

The following example shows you how to set a trunking port.

Command Example
Catalyst# show interfaces gigabitEthernet 1/0/21 switchport
Name: Gi1/0/19
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: 1,10,20,30
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

The following example shows you how to set the access ports.
Command Example
Catalyst# show interfaces gigabitEthernet 1/0/1 switchport
Name: Gi1/0/1
Switchport: Enabled
Administrative Mode: static access
Operational Mode: down
Administrative Trunking Encapsulation: negotiate

6
Interoperating with Cisco Systems

Negotiation of Trunking: Off


Access Mode VLAN: 10 (VLAN0010)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

The following example shows you how to verify the IP address of each VLAN interface.
Command Example
Catalyst# show ip interface brief
Interface IP-Address OK? Method Status Protocol
Vlan1 192.168.0.1 YES manual up up
Vlan10 192.168.10.1 YES manual up up
Vlan20 192.168.20.1 YES manual up up
Vlan30 192.168.30.1 YES manual up up

Verifying VLANs and Port Assignments on D-Link Switches

The following example shows you how to verify all the VLAN interfaces and member ports.
Command Example
switch# show vlan
Command: show vlan

VID : 1 VLAN Name : default


VLAN Type : Static Advertisement : Enabled
Member Ports : 19-24
Static Ports : 19-24
Current Tagged Ports :
Current Untagged Ports : 19-24
Static Tagged Ports :
Static Untagged Ports : 19-24
Forbidden Ports :
Status : Active

VID : 10 VLAN Name : 10


VLAN Type : Static Advertisement : Disabled
Member Ports : 1-6,21
Static Ports : 1-6,21
Current Tagged Ports : 21

7
Interoperating with Cisco Systems

Current Untagged Ports : 1-6


Static Tagged Ports : 21
Static Untagged Ports : 1-6
Forbidden Ports :
Status : Active

VID : 20 VLAN Name : 20


VLAN Type : Static Advertisement : Disabled
Member Ports : 7-12,21
Static Ports : 7-12, 21
Current Tagged Ports : 21
Current Untagged Ports : 7-12
Static Tagged Ports : 21
Static Untagged Ports : 7-12
Forbidden Ports :
Status : Active

VID : 30 VLAN Name : 30


VLAN Type : Static Advertisement : Disabled
Member Ports : 13-18,21
Static Ports : 13-18,21
Current Tagged Ports : 21
Current Untagged Ports : 13-18
Static Tagged Ports : 21
Static Untagged Ports : 13-18
Forbidden Ports :
Status : Active

Total Entries: 4

The following example shows you how to verify the IP address of each VLAN interface.
Command Example
switch# show ipif
Command: show ipif

IP Interface : 10
VLAN Name : 10
Interface Admin state : Enabled
DHCPv6 Client State : Disabled
IPv4 Address : 192.168.10.2/24 (Manual) Primary
Proxy ARP : Disabled (Local : Disabled)
IP Directed Broadcast : Disabled
IP MTU : 1500

IP Interface : 20
VLAN Name : 20
Interface Admin state : Enabled
DHCPv6 Client State : Disabled
IPv4 Address : 192.168.20.2/24 (Manual) Primary
Proxy ARP : Disabled (Local : Disabled)
IP Directed Broadcast : Disabled
IP MTU : 1500

IP Interface : 30
VLAN Name : 30
Interface Admin state : Enabled
DHCPv6 Client State : Disabled

8
Interoperating with Cisco Systems

IPv4 Address : 192.168.30.2/24 (Manual) Primary


Proxy ARP : Disabled (Local : Disabled)
IP Directed Broadcast : Disabled
IP MTU : 1500

IP Interface : System
VLAN Name : default
Interface Admin state : Enabled
DHCPv6 Client State : Disabled
IPv4 Address : 192.168.0.2/24 (Manual) Primary
Proxy ARP : Disabled (Local : Disabled)
IP Directed Broadcast : Disabled
IP MTU : 1500

Total Entries : 4

9
Interoperating with Cisco Systems

Link Aggregation
This chapter deals with Link Aggregation Control Protocol (LACP) function that both Cisco and
D-Link switches support.

Terminology

Cisco D-Link Description


Channel-group ID Group ID ID of a port aggregation group.
Port-channel Link Aggregation Group A logical port aggregation group.

Link Aggregation Group


Cisco defines the Aggregation group as Port-channel and is configured as the Interface
Port-channel x. The default Port-channel mode is Static trunk, and the LACP mode for a
dynamic trunk. On the other hand, D-Link calls it Link Aggregation Group and is configured
as type static for a Static trunk or type LACP for a dynamic trunk.

Static and Dynamic Trunks/Channels


In between two switches, a static trunk becomes an active trunk unconditionally and
independently of the other switch’s configuration. A static trunk does not require any protocols.

A dynamic trunk is active only when the dynamic trunk is enabled in both D-Link and Cisco
switches. To do so, the switches exchange messages, either through Port aggregation protocol
(PAgP) or Link Aggregation Control Protocol (LACP), to negotiate their status. If either of the
switches are ‘active’ (LACP) or ‘desirable’ (PAgP), then the switch initiates negotiation. If the
switch is ‘passive’ (LACP) or ‘auto’ (PAgP) then it forms a link aggregation automatically.

LACP
LACP is the Link Aggregation Control Protocol defined by the 802.3ad standard. It provides a
way for both parts to negotiate a port aggregation. With LACP, one or more additional links can
operate as standby links that will activate only if another active link goes down.
When connecting two switches with LACP, one of the switches must be active (send LACP frames)
and another should be set to passive.

Compatibility between D-Link Port-trunking and Cisco Port-Channel


The following table summarizes the options that can be combined to create a trunk on both
D-Link and Cisco switches.
Cisco Mode
D-Link Mode On Mode Passive Mode Active
Type-Mode

Static 9

LACP-Passive 9

LACP- Active 9

Note: All ports in a trunk group must be configured at the same speed and VLAN.

10
Interoperating with Cisco Systems

Topology

Figure-2 Link Aggregation and VLAN Configuration

Configuration
Static Trunk Configuration on a Cisco Switch

Command Example Purpose


Catalyst# config terminal
To create a channel
Catalyst(config)# interface range gigabitEthernet
Step 1 group 1 with static
1/0/19-22
mode.
Catalyst(config-if)# channel-group 1 mode on

Static Trunk Configuration on a D-Link Switch

Command Example Purpose


switch# create link_aggregation group_id 1 type static To create a trunk
Step 1 switch# config link_aggregation group_id 1 ports 19-22 group 1 with static
state enable mode.

Troubleshooting Examples
Verifying the Static Channel Status on a Cisco Switch

The following example shows you how to correctly set the port mode and verify the channel
group ports.
Command Example
Catalyst# show etherchannel 1 summary

11
Interoperating with Cisco Systems

Flags: D - down P - bundled in port-channel


I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator

M - not in use, minimum links not met


u - unsuitable for bundling
w - waiting to be aggregated
d - default port

Number of channel-groups in use: 1


Number of aggregators: 1

Group Port-channel Protocol Ports


------+-------------+-----------+-----------------------------------------------
1 Po1(SU) - Gi1/0/19(P) Gi1/0/20(P) Gi1/0/21(P)
Gi1/0/22(P)

Catalyst#show etherchannel 1 detail


Group state = L2
Ports: 4 Maxports = 8
Port-channels: 1 Max Port-channels = 1
Protocol: -
Minimum Links: 0
Ports in the group:
-------------------
Port: Gi1/0/19
------------

Port state = Up Mstr In-Bndl


Channel group = 1 Mode = On Gcchange = -
Port-channel = Po1 GC = - Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = -

Age of the port in the current state: 0d:00h:04m:13s

Port: Gi1/0/20
------------

Port state = Up Mstr In-Bndl


Channel group = 1 Mode = On Gcchange = -
Port-channel = Po1 GC = - Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = -

Age of the port in the current state: 0d:00h:04m:12s

Port: Gi1/0/21
------------

Port state = Up Mstr In-Bndl


Channel group = 1 Mode = On Gcchange = -
Port-channel = Po1 GC = - Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = -

Age of the port in the current state: 0d:00h:04m:14s

12
Interoperating with Cisco Systems

Port: Gi1/0/22
------------

Port state = Up Mstr In-Bndl


Channel group = 1 Mode = On Gcchange = -
Port-channel = Po1 GC = - Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = -

Age of the port in the current state: 0d:00h:04m:13s

Port-channels in the group:


---------------------------

Port-channel: Po1
------------

Age of the Port-channel = 0d:00h:04m:17s


Logical slot/port = 10/1 Number of ports = 4
GC = 0x00000000 HotStandBy port = null
Port state = Port-channel Ag-Inuse
Protocol = -
Port security = Disabled

Ports in the Port-channel:

Index Load Port EC state No of bits


------+------+------+------------------+-----------
0 00 Gi1/0/19 On 0
0 00 Gi1/0/20 On 0
0 00 Gi1/0/21 On 0
0 00 Gi1/0/22 On 0

Time since last port bundled: 0d:00h:04m:14s Gi1/0/22

Verifying the Static Trunk status on a D-Link Switch

The following example shows you how to correctly set the port mode and verify the channel
group ports.
Command Example
switch# show link_aggregation
Command: show link_aggregation

Link Aggregation Algorithm = IP-Source


Group ID : 1
Type : TRUNK
Master Port : 19
Member Port : 19-22
Active Port : 19-22
Status : Enabled
Flooding Port : 19

LACP Configuration on a Cisco Switch

The following example shows you how to create a channel group, when a switch plays an active
role in a LACP trunk.

13
Interoperating with Cisco Systems

Command Example Purpose


Catalyst# config terminal
To create a channel
Catalyst(config)# interface range gigabitEthernet
Step 1 group 1 with
1/0/19-22
LACP-active mode.
Catalyst(config-if)# channel-group 1 mode active

The following example shows you how to create a channel group, when a switch plays a passive
role in a LACP trunk.
Command Example Purpose
Catalyst# config terminal
To create a channel
Catalyst(config)# interface range gigabitEthernet
Step 1 group 1 with
1/0/19-22
LACP-passive mode.
Catalyst(config-if)# channel-group 1 mode passive

LACP Configuration on a D-Link Switch

The following example shows you how to create a trunk group, when a switch plays an active
role in a LACP trunk.
Command Example Purpose
switch# create link_aggregation group_id 1 type lacp
To create a trunk
switch# config link_aggregation group_id 1 master_port
Step 1 group 1 with
19 ports 19-22 state enable
LACP-active mode.
switch# config lacp_port 19-22 mode active

The following example shows you how to create a trunk group, when a switch plays a passive
role in a LACP trunk.
Command Example Purpose
switch# create link_aggregation group_id 1 type lacp
To create a trunk
switch# config link_aggregation group_id 1 master_port
Step 1 group 1 with
19 ports 19-22 state enable
LACP-passive mode.
switch# config lacp_port 19-22 mode passive

Note: By default, the LACP port mode is set passive in D-Link switches.

Verifying the LACP Configuration on a Cisco Switch

The following example shows you how to correctly set the port mode and verify the channel
group ports.
Command Example
Catalyst# show interfaces etherchannel
----
GigabitEthernet1/0/19:
Port state = Up Sngl-port-Bndl Mstr Not-in-Bndl
Channel group = 1 Mode = Active Gcchange = -
Port-channel = null GC = - Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = LACP

Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.


A - Device is in active mode. P - Device is in passive mode.

Local information:
LACP port Admin Oper Port Port

14
Interoperating with Cisco Systems

Port Flags State Priority Key Key Number State


Gi1/0/19 SA indep 32768 0x1 0x1 0x13 0x7D

Age of the port in the current state: 0d:00h:00m:51s

----
GigabitEthernet1/0/20:
Port state = Up Sngl-port-Bndl Mstr Not-in-Bndl
Channel group = 1 Mode = Active Gcchange = -
Port-channel = null GC = - Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = LACP

Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.


A - Device is in active mode. P - Device is in passive mode.

Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi1/0/20 SA indep 32768 0x1 0x1 0x14 0x7D

Age of the port in the current state: 0d:00h:00m:51s

----
GigabitEthernet1/0/21:
Port state = Up Sngl-port-Bndl Mstr Not-in-Bndl
Channel group = 1 Mode = Active Gcchange = -
Port-channel = null GC = - Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = LACP

Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.


A - Device is in active mode. P - Device is in passive mode.

Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi1/0/21 SA indep 32768 0x1 0x1 0x15 0x7D

Age of the port in the current state: 0d:00h:00m:55s

----
GigabitEthernet1/0/22:
Port state = Up Sngl-port-Bndl Mstr Not-in-Bndl
Channel group = 1 Mode = Active Gcchange = -
Port-channel = null GC = - Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = LACP

Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.


A - Device is in active mode. P - Device is in passive mode.

Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi1/0/22 SA indep 32768 0x1 0x1 0x16 0x7D

Age of the port in the current state: 0d:00h:00m:55s

----

15
Interoperating with Cisco Systems

Port-channel1:Port-channel1 (Primary aggregator)

Age of the Port-channel = 0d:01h:42m:42s


Logical slot/port = 10/1 Number of ports = 0
HotStandBy port = null
Port state = Port-channel Ag-Not-Inuse
Protocol = LACP
Port security = Disabled

Time since last port bundled: 0d:01h:42m:38s Gi1/0/22


Time since last port Un-bundled: 0d:00h:01m:19s Gi1/0/22

Verifying the LACP Configuration on a D-Link Switch

The following example shows you how to correctly set the ports of a trunk group.
Command Example
switch# show link_aggregation
Command: show link_aggregation

Link Aggregation Algorithm = IP-Source


Group ID : 1
Type : LACP
Master Port : 19
Member Port : 19-22
Active Port : 19-22
Status : Enabled
Flooding Port : 21

Total Entries : 1

The following example shows you how to correctly set the port mode.
Command Example
switch# show lacp
Command: show lacp_port

Port Activity

----- --------
1 Passive
2 Passive
3 Passive
……

19 Passive
20 Passive
21 Passive
22 Passive

16
Interoperating with Cisco Systems

Spanning Tree Configuration


Terminology

Cisco D-Link Description


Port Fast Edge Port Bypassing the listening and learning states, this port changes
its state from blocking to forwarding directly to speed-up
Spanning tree protocol (STP) convergence.

Note: Since STP/RSTP function can only run in a single VLAN, all connections on Per-VLAN
Spanning Tree (PVST) should be located in the same VLAN.

Topology

Figure-3 Spanning Tree Configuration

Configuration
Rapid-PVST Configuration on a Cisco Switch

Command Example Purpose


To enable STP and
Catalyst# config terminal
Step 1 choose rapid-PVST
Catalyst(config)# spanning-tree mode rapid-pvst
mode.
To change priority to
Step 2 Catalyst(config)# spanning-tree vlan 1 priority 4096
4096.

17
Interoperating with Cisco Systems

RSTP Configuration on a D-Link Switch

Command Example Purpose


switch:admin# enable stp To enable RSTP and
Step 1
switch:admin# config stp version rstp choose RSTP.
Assume ports 1-22
are connected to PCs
or an end terminal
device. These ports
switch:admin# config stp ports 1-22 edge true should be set as edge
Step 2
switch:admin# config stp ports 23-24 p2p true ports. The ports
23-24 which are
connected to the
switch should be set
as P2P ports.

Troubleshooting Examples

Verifying RSTP Mode and Ports Status on a Cisco Switch

The following example shows you how to verify the STP protocol version, STP priority and port.
Command Example
Catalyst# show span vlan 1

VLAN0001
Spanning tree enabled protocol rstp
Root ID Priority 4097
Address 0021.56b0.5c00
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 4097 (priority 4096 sys-id-ext 1)


Address 0021.56b0.5c00
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300

Interface Role Sts Cost Prio.Nbr Type


----------------- ---- --- -------- -------- --------------------------------
Gi1/0/23 Desg FWD 4 128.23 P2p
Gi1/0/24 Desg FWD 4 128.24 P2p

The following example shows you how to check STP detail information.
Command Example
Catalyst# show spanning-tree detail

VLAN0001 is executing the rstp compatible Spanning Tree protocol


Bridge Identifier has priority 4096, sysid 1, address 0021.56b0.5c00
Configured hello time 2, max age 20, forward delay 15, transmit hold-count 6
We are the root of the spanning tree
Topology change flag not set, detected flag not set
Number of topology changes 4 last change occurred 00:25:48 ago
from GigabitEthernet1/0/23

18
Interoperating with Cisco Systems

Times: hold 1, topology change 35, notification 2


hello 2, max age 20, forward delay 15
Timers: hello 0, topology change 0, notification 0, aging 300

Port 23 (GigabitEthernet1/0/23) of VLAN0001 is designated forwarding


Port path cost 4, Port priority 128, Port Identifier 128.23.
Designated root has priority 4097, address 0021.56b0.5c00
Designated bridge has priority 4097, address 0021.56b0.5c00
Designated port id is 128.23, designated path cost 0
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 2
Link type is point-to-point by default
BPDU: sent 839, received 22

Port 24 (GigabitEthernet1/0/24) of VLAN0001 is designated forwarding


Port path cost 4, Port priority 128, Port Identifier 128.24.
Designated root has priority 4097, address 0021.56b0.5c00
Designated bridge has priority 4097, address 0021.56b0.5c00
Designated port id is 128.24, designated path cost 0
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
BPDU: sent 779, received 65

Verifying the RSTP Mode and Ports Status on a D-Link Switch

The following example shows you how to verify if the spanning mode is RSTP and STP are
enabled.
Command Example
switch:admin# show stp
Command: show stp

STP Bridge Global Settings


---------------------------
STP Status : Enabled
STP Version : RSTP
Max Age : 20
Hello Time : 2
Forward Delay : 15
Max Hops : 2
TX Hold Count : 6
Forwarding BPDU : Disabled
Loopback Detection : Enabled
LBD Recover Time : 60
NNI BPDU Address : dot1ad

The following example shows you how to verify the Root Bridge.
Command Example
switch:admin# show stp instance 0
Command: show stp instance 0

STP Instance Settings


---------------------------
Instance Type : CIST
Instance Status : Enabled

19
Interoperating with Cisco Systems

Instance Priority : 32768(Bridge Priority : 32768, SYS ID Ext : 0 )

STP Instance Operational Status


--------------------------------
Designated Root Bridge : 4097 /00-21-56-B0-5C-00
External Root Cost : 20000
Regional Root Bridge : 32768/00-19-5B-12-43-00
Internal Root Cost : 0
Designated Bridge : 4097 /00-21-56-B0-5C-00
Root Port : 23
Max Age : 20
Forward Delay : 15
Last Topology Change : 978
Topology Changes Count : 5

The following example shows you how to verify the role of the interface.
Command Example
switch:admin# show stp ports 23
Command: show stp ports 23

MSTP Port Information


----------------------
Port Index : 23 , Hello Time: 2 /2 , Port STP : Enabled , LBD : No
External PathCost : Auto/20000 , Edge Port : False/No , P2P : True /Yes
Port RestrictedRole : False, Port RestrictedTCN : False
Port Forward BPDU : Disabled
MSTI Designated Bridge Internal PathCost Prio Status Role
----- ------------------ ----------------- ---- ---------- ----------
0 1001/002156B05C00 20000 128 Forwarding Root

20
Interoperating with Cisco Systems

Multiple Spanning Tree Configuration


Terminology
None

Compatibility between MSTP and PVST


The following table summarizes the compatibility of PVST and MSTP functions.
Cisco
D-Link PVST PVST+ Rapid PVST+

MSTP No Yes (See note) Yes (reverts to PVST+)

Note: In a MSTP and PVST+ network, the Common Spanning-tree (CST) root must be
inside the MST backbone, and a PVST+ switch cannot connect to multiple MST
regions.

Topology

Figure-4 Multiple Spanning Tree Configuration

Configuration
Multiple Spanning Configuration on a Cisco Switch

Command Example Purpose


To create VLAN
Catalyst# config terminal
Step 1 interface for ports 10
Catalyst(config)# vlan 10,20,30
and 20.
Catalyst(config)# interface range gigabitEthernet
1/0/1-8 To assign interfaces for
Step 2 Catalyst(config-if-range)# switchport access vlan 10 0/1/0-8 to VLAN 10 and
Catalyst(config-if-range)# interface range 0/1/9-16 to VALN 20.
gigabitEthernet 1/0/9-16

21
Interoperating with Cisco Systems

Catalyst(config-if-range)# switchport access vlan 20


Catalyst(config)# interface range gigabitEthernet
1/0/23-24
Catalyst(config-if-range)# switchport mode trunk To set interfaces for
Step 3 Catalyst(config-if-range)# switchport trunk allowed 0/1/23-24 as the trunk
vlan 1,10,20 interfaces.
Catalyst(config-if-range)# switchport trunk
encapsulation dot1q
Catalyst(config)# interface vlan 10
Catalyst(config-if)# ip address 192.168.10.1
To create two IP
255.255.255.0
Step 4 interfaces on VLAN 10
Catalyst(config)# interface vlan 20
and 20.
Catalyst(config-if)# ip address 192.168.20.1
255.255.255.0
Catalyst(config)# spanning-tree mode mst To setup Multiple
Catalyst(config)# spanning-tree mst configuration Spanning Tree
Catalyst(config-mst)# name test name/revision/instance
Step 5
Catalyst(config-mst)# revision 1 and VLAN mapping as
Catalyst(config-mst)# instance 1 vlan 10 the same value on all
Catalyst(config-mst)# instance 2 vlan 20 switches.
Catalyst(config)# spanning-tree mst 1 priority 4096
To set a Cisco switch as
Step 6 Catalyst(config)# spanning-tree mst 2 priority 4096
the root switch.
Catalyst(config)# spanning-tree mst 3 priority 4096

Multiple Spanning Configuration on a D-Link Switch

Command Example Purpose


switch:admin# create vlan 10 tag 10
switch:admin# create vlan 20 tag 20
To create VLAN
switch:admin# config vlan default delete 1-16
interfaces for ports 10,
Step 1 switch:admin# config vlan 10 add untagged 1-8
20 and port
switch:admin# config vlan 10 add tagged 23-24
assignment.
switch:admin# config vlan 20 add untagged 9-16
switch:admin# config vlan 20 add tagged 23-24
To create two IP
switch:admin# create ipif 10 192.168.10.2/24 10
Step 2 interfaces on VLAN 10
switch:admin# create ipif 20 192.168.20.2/24 20
and 20.
switch:admin# config stp mst_config_id name test
switch:admin# config stp mst_config_id revision_level
To setup Multiple
1
Spanning Tree
switch:admin# config stp version mstp
name/revision/instance
Step 3 switch:admin# create stp instance_id 1
and VLAN mapping as
switch:admin# create stp instance_id 2
the same value on all
switch:admin# config stp instance_id 1 add_vlan 10
switches.
switch:admin# config stp instance_id 2 add_vlan 20
switch:admin# enable stp

22
Interoperating with Cisco Systems

Troubleshooting Examples
Verifying MSTP Mode and Ports Status on a Cisco Switch

The following example shows you how to verify an MSTP instance and VLAN mapping
information.
Command Example
Catalyst(config-mst)# show pending
Pending MST configuration
Name [test]
Revision 1 Instances configured 3

Instance Vlans mapped


-------- ---------------------------------------------------------------------
0 1-9,11-19,21-4094
1 10
2 20
-------------------------------------------------------------------------------

Catalyst# show spanning-tree mst configuration


Name [test]
Revision 1 Instances configured 3

Instance Vlans mapped


-------- ---------------------------------------------------------------------
0 1-9,11-19,21-4094
1 10
2 20
-------------------------------------------------------------------------------

The following example shows you how to check STP information.


Command Example
Catalyst# show spanning-tree detail

VLAN0001 is executing the rstp compatible Spanning Tree protocol


Bridge Identifier has priority 4096, sysid 1, address 0021.56b0.5c00
Configured hello time 2, max age 20, forward delay 15, transmit hold-count 6
We are the root of the spanning tree
Topology change flag not set, detected flag not set
Number of topology changes 4 last change occurred 00:25:48 ago
from GigabitEthernet1/0/23
Times: hold 1, topology change 35, notification 2
hello 2, max age 20, forward delay 15
Timers: hello 0, topology change 0, notification 0, aging 300

Port 23 (GigabitEthernet1/0/23) of VLAN0001 is designated forwarding


Port path cost 4, Port priority 128, Port Identifier 128.23.
Designated root has priority 4097, address 0021.56b0.5c00
Designated bridge has priority 4097, address 0021.56b0.5c00
Designated port id is 128.23, designated path cost 0
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 2
Link type is point-to-point by default

23
Interoperating with Cisco Systems

BPDU: sent 839, received 22

Port 24 (GigabitEthernet1/0/24) of VLAN0001 is designated forwarding


Port path cost 4, Port priority 128, Port Identifier 128.24.
Designated root has priority 4097, address 0021.56b0.5c00
Designated bridge has priority 4097, address 0021.56b0.5c00
Designated port id is 128.24, designated path cost 0
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
BPDU: sent 779, received 65

The following example shows you how to check the STP Status.
Command Example
Catalyst# show spanning-tree

MST0
Spanning tree enabled protocol mstp
Root ID Priority 4096
Address 0021.56b0.5c00
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 4096 (priority 4096 sys-id-ext 0)


Address 0021.56b0.5c00
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Interface Role Sts Cost Prio.Nbr Type


----------------- ---- --- -------- -------- --------------------------------
Gi1/0/1 Desg FWD 200000 128.1 P2p Edge
Gi1/0/9 Desg FWD 200000 128.9 P2p Edge
Gi1/0/23 Desg FWD 20000 128.23 P2p
Gi1/0/24 Desg FWD 20000 128.24 P2p

MST1
Spanning tree enabled protocol mstp
Root ID Priority 4097
Address 0021.56b0.5c00
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 4097 (priority 4096 sys-id-ext 1)


Address 0021.56b0.5c00
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Interface Role Sts Cost Prio.Nbr Type


----------------- ---- --- -------- -------- --------------------------------
Gi1/0/1 Desg FWD 200000 128.1 P2p Edge
Gi1/0/23 Desg FWD 20000 128.23 P2p
Gi1/0/24 Desg FWD 20000 128.24 P2p

MST2
Spanning tree enabled protocol mstp
Root ID Priority 4098

24
Interoperating with Cisco Systems

Address 0021.56b0.5c00
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 4098 (priority 4096 sys-id-ext 2)


Address 0021.56b0.5c00
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Interface Role Sts Cost Prio.Nbr Type


----------------- ---- --- -------- -------- --------------------------------
Gi1/0/9 Desg FWD 200000 128.9 P2p Edge
Gi1/0/23 Desg FWD 20000 128.23 P2p
Gi1/0/24 Desg FWD 20000 128.24 P2p

The following example shows you how to check the MST protocol information.
Command Example
Catalyst# show spanning-tree mst

##### MST0 vlans mapped: 1-9,11-19,21-4094


Bridge address 0021.56b0.5c00 priority 4096 (4096 sysid 0)
Root this switch for the CIST
Operational hello time 2 , forward delay 15, max age 20, txholdcount 6
Configured hello time 2 , forward delay 15, max age 20, max hops 20

Interface Role Sts Cost Prio.Nbr Type


--------------- ---- --- -------- -------- --------------------------------
Gi1/0/1 Desg FWD 200000 128.1 P2p Edge
Gi1/0/9 Desg FWD 200000 128.9 P2p Edge
Gi1/0/23 Desg FWD 20000 128.23 P2p
Gi1/0/24 Desg FWD 20000 128.24 P2p

##### MST1 vlans mapped: 10


Bridge address 0021.56b0.5c00 priority 4097 (4096 sysid 1)
Root this switch for MST1

Interface Role Sts Cost Prio.Nbr Type


--------------- ---- --- -------- -------- --------------------------------
Gi1/0/1 Desg FWD 200000 128.1 P2p Edge
Gi1/0/23 Desg FWD 20000 128.23 P2p
Gi1/0/24 Desg FWD 20000 128.24 P2p

##### MST2 vlans mapped: 20


Bridge address 0021.56b0.5c00 priority 4098 (4096 sysid 2)
Root this switch for MST2

Interface Role Sts Cost Prio.Nbr Type


--------------- ---- --- -------- -------- --------------------------------
Gi1/0/9 Desg FWD 200000 128.9 P2p Edge
Gi1/0/23 Desg FWD 20000 128.23 P2p
Gi1/0/24 Desg FWD 20000 128.24 P2p

Verifying the RSTP Mode and Ports Status on a D-Link Switch

The following example shows you how to verify if the spanning mode is MSTP and STP is
enabled.

25
Interoperating with Cisco Systems

Command Example
switch:admin# show stp
Command: show stp

STP Bridge Global Settings


---------------------------
STP Status : Enabled
STP Version : MSTP
Max Age : 20
Forward Delay : 15
Max Hops : 20
TX Hold Count : 6
Forwarding BPDU : Disabled
Loopback Detection : Enabled
LBD Recover Time : 60
NNI BPDU Address : dot1ad

The following example shows you how to check the spanning instance information.
Command Example
switch:admin# show stp instance 0
Command: show stp instance 0

STP Instance Settings


---------------------------
Instance Type : CIST
Instance Status : Enabled
Instance Priority : 32768(Bridge Priority : 32768, SYS ID Ext : 0 )

STP Instance Operational Status


--------------------------------
Designated Root Bridge : 32768/00-19-5B-12-43-00
External Root Cost : 0
Regional Root Bridge : 32768/00-19-5B-12-43-00
Internal Root Cost : 0
Designated Bridge : 32768/00-19-5B-12-43-00
Root Port : None
Max Age : 20
Forward Delay : 15
Last Topology Change : 74717
Topology Changes Count : 22

The following example shows you how to check the STP instance and VALN mapping.
Command Example
switch:admin# show stp mst_config_id
Command: show stp mst_config_id

Current MST Configuration Identification


----------------------------------------

Configuration Name : test Revision Level :1


MSTI ID Vid list
------- -------------------------------------------------------------
CIST 1-9,11-19,21-4094
1 10

26
Interoperating with Cisco Systems

2 20

Open Shortest Path Fast (OSPF) Configuration


Terminology
None

Topology – Single OSPF Area

Figure-5 Single OSPF Area Configuration

Configuration
OSPF Configuration on a Cisco Switch - 1

Command Example Purpose


Catalyst# config terminal
Catalyst(config)# interface gigabitEthernet 1/0/23
Catalyst(config-if)# no switchport
Catalyst(config-if)# ip address 192.168.20.2
255.255.255.0
To create two IP
Catalyst(config-if)# no shut
interfaces -
Step 1 Catalyst(config-if)# exit
(192.168.20.0/
Catalyst(config)# interface gigabitEthernet 1/0/22
192.168.30.0)
Catalyst(config-if)# no switchport
Catalyst(config-if)# ip address 192.168.30.1
255.255.255.0
Catalyst(config-if)# no shutdown
Catalyst(config-if)# exit

27
Interoperating with Cisco Systems

Catalyst(config)# ip routing
Catalyst(config)# router ospf 100
Catalyst(config-router)# router-id 192.168.20.1 To enable OSPF on
Step 2 Catalyst(config-router)# network 192.168.20.0 specific interfaces and
0.0.0.255 area 0 setup router ID.
Catalyst(config-router)# network 192.168.30.0
0.0.0.255 area 0

OSPF Configuration on a Cisco Switch - 2

Command Example Purpose


Catalyst# config terminal
Catalyst(config)# interface gigabitEthernet 1/0/23
Catalyst(config-if)# no switchport
Catalyst(config-if)# ip address 192.168.40.2
255.255.255.0
Catalyst(config-if)# no shut To create two IP
Catalyst(config-if)# exit interfaces
Step 1
Catalyst(config)# interface gigabitEthernet 1/0/22 (192.168.30.0 /
Catalyst(config-if)# no switchport 192.168.40.0).
Catalyst(config-if)# ip address 192.168.30.1
255.255.255.0
Catalyst(config-if)# no shutdown
Catalyst(config-if)# exit

Catalyst(config)# ip routing
Catalyst(config)# router ospf 100
Catalyst(config-router)# router-id 192.168.30.1 To enable OSPF on
Step 2 Catalyst(config-router)# network 192.168.30.0 specific interfaces and
0.0.0.255 area 0 setup router ID.
Catalyst(config-router)# network 192.168.40.0
0.0.0.255 area 0

OSPF Configuration on a D-Link Switch - 1

Command Example Purpose


switch:admin# create vlan 10 tag 10 To create VLAN
switch:admin# create vlan 20 tag 20 interfaces for ports
Step 1 switch:admin# config vlan default delete 1-16 10 and 20 and assign
switch:admin# config vlan 10 add untagged 1-8 relative ports to each
switch:admin# config vlan 20 add untagged 9-16,23 VLAN.
To create two IP
switch:admin# create ipif 10 192.168.10.1/24 10
Step 2 interfaces on VLAN
switch:admin# create ipif 20 192.168.20.1/24 20
10 and 20.

config ospf router_id 192.168.10.1


switch:admin# config ospf ipif 10 area 0.0.0.0 state
To enable OSPF on
enable
Step 3 specific interfaces
switch:admin# config ospf ipif 20 area 0.0.0.0 state
and setup router ID.
enable
switch:admin# enable ospf

28
Interoperating with Cisco Systems

OSPF Configuration on a D-Link Switch - 2

Command Example Purpose


switch:admin# create vlan 40 tag 40 To create VLAN
switch:admin# create vlan 50 tag 50 interfaces for ports
Step 1 switch:admin# config vlan default delete 1-16 40 and 50 and assign
switch:admin# config vlan 40 add untagged 1-8,24 relative ports to each
switch:admin# config vlan 50 add untagged 9-16 VLAN.
To create two IP
switch:admin# create ipif 40 192.168.10.1/24 40
Step 2 interfaces on VLAN
switch:admin# create ipif 50 192.168.20.1/24 50
40 and 50.

config ospf router_id 192.168.40.1


switch:admin# config ospf ipif 40 area 0.0.0.0 state
To enable OSPF on
enable
Step 3 specific interfaces
switch:admin# config ospf ipif 50 area 0.0.0.0 state
and setup router ID.
enable
switch:admin# enable ospf

Troubleshooting Examples
Verifying OSPF information on a Cisco Switch

The following example shows you how to check OSPF information.


Command Example
Catalyst# show ip ospf
Routing Process "ospf 100" with ID 192.168.20.1
Start time: 00:01:21.528, Time elapsed: 00:00:52.454
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Incremental-SPF disabled
Minimum LSA interval
*Mar 1 00:02:12.623: %OSPF-5-ADJCHG: Process 100, Nbr 192.168.30.1 on
GigabitEthernet1/0/22 from LOADING to FULL, Loading Done5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 0. Checksum Sum 0x000000
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Number of areas transit capable is 0
External flood list length 0

29
Interoperating with Cisco Systems

IETF NSF helper support enabled


Cisco NSF helper support enabled
Reference bandwidth unit is 100 mbps
Area BACKBONE(0)
Number of interfaces in this area is 2
Area has no authentication
SPF algorithm last executed 00:00:37.984 ago
SPF algorithm executed 2 times
Area ranges are
Number of LSA 8. Checksum Sum 0x043353
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 4
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0

The following example shows you how to verify if the OSPF neighbors are established.
Command Example
Catalyst# show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface


192.168.30.1 1 FULL/DR 00:00:38 192.168.30.2 GigabitEthernet1/0/22
192.168.10.1 1 FULL/DR 00:00:36 192.168.20.1 GigabitEthernet1/0/23

The following example shows you how to verify if the route entries that are learnt by the
switches.
Command Example
Catalyst# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.30.0/24 is directly connected, GigabitEthernet1/0/22


O 192.168.10.0/24 [110/2] via 192.168.20.1, 00:02:07, GigabitEthernet1/0/23
O 192.168.40.0/24 [110/2] via 192.168.30.2, 00:02:07, GigabitEthernet1/0/22
C 192.168.20.0/24 is directly connected, GigabitEthernet1/0/23
O 192.168.50.0/24 [110/3] via 192.168.30.2, 00:02:07, GigabitEthernet1/0/22

The following example shows you how to check the OSPF interface status.
Command Example
Catalyst# show ip ospf interface
GigabitEthernet1/0/22 is up, line protocol is up (connected)
Internet Address 192.168.30.1/24, Area 0
Process ID 100, Router ID 192.168.20.1, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State BDR, Priority 1
Designated Router (ID) 192.168.30.1, Interface address 192.168.30.2
Backup Designated router (ID) 192.168.20.1, Interface address 192.168.30.1
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

30
Interoperating with Cisco Systems

oob-resync timeout 40
Hello due in 00:00:01
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 192.168.30.1 (Designated Router)
Suppress hello for 0 neighbor(s)
GigabitEthernet1/0/23 is up, line protocol is up (connected)
Internet Address 192.168.20.2/24, Area 0
Process ID 100, Router ID 192.168.20.1, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State BDR, Priority 1
Designated Router (ID) 192.168.10.1, Interface address 192.168.20.1
Backup Designated router (ID) 192.168.20.1, Interface address 192.168.20.2
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:07
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 5
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 192.168.10.1 (Designated Router)
Suppress hello for 0 neighbor(s)

Verifying the OSPF status on a D-Link Switch

The following example shows you how to verify if the OSPF is enabled on correct interfaces.
Command Example
switch:admin# show ospf
Command: show ospf

OSPF Router ID : 192.168.10.1


State : Enabled

OSPF Interface Settings

Interface IP Address Area ID State Link Metric


Status
------------ ------------------ --------------- -------- --------- ---------
System 10.90.90.90/8 0.0.0.0 Disabled Link Up 1
10 192.168.10.1/24 0.0.0.0 Enabled Link Up 1
20 192.168.20.1/24 0.0.0.0 Enabled Link Up 1

Total Entries : 3

OSPF Area Settings

31
Interoperating with Cisco Systems

Area ID Type Stub Import Summary LSA Stub Default Cost Translate
--------------- ------ ----------------------- ----------------- ---------
0.0.0.0 Normal None None None

Total Entries : 1

Virtual Interface Configuration


Transit Virtual Hello Dead Authentication Link
Area ID Neighbor Router Interval Interval Status
---------- --------------- -------- -------- --------------- ------

Total Entries : 0

OSPF Area Aggregation Settings

Area ID Aggregated LSDB Advertise


Network Address Type
------------ ----------------- -------- ---------

Total Entries : 0

OSPF Host Route Settings

Host Address Metric Area ID


--------------- ------- ---------------

Total Entries : 0

The following example shows you how to verify if the OSPF neighbor is established.
Command Example
switch:admin# show ospf neighbor
Command: show ospf neighbor

IP Address of Router ID of Neighbor Neighbor


Neighbor Neighbor Priority State
--------------- --------------- -------- -------------
192.168.20.2 192.168.20.2 1 Full

Total Entries : 1

The following example shows you how to check the OSPF interface information.
Command Example
switch:admin# show ospf ipif 10
Command: show ospf ipif 10

Interface Name: 10 IP Address: 192.168.10.1/24 (Link Up)


Network Medium Type: BROADCAST Metric: 1
Area ID: 0.0.0.0 Administrative State: Enabled
Priority: 1 DR State: DR
DR Address: 192.168.10.1 Backup DR Address: None
Hello Interval: 10 Dead Interval: 40
Transmit Delay: 1 Retransmit Time: 5
Authentication: None

Passive Mode: Disabled

32
Interoperating with Cisco Systems

Total Entries : 1

The following example shows you how to verify all the route entries that are learnt by the
switches.
Command Example
switch:admin# show iproute
Command: show iproute

Routing Table

IP Address/Netmask Gateway Interface Cost Protocol


------------------ -------------- ------------ -------- --------
10.0.0.0/8 0.0.0.0 System 1 Local
192.168.10.0/24 0.0.0.0 10 1 Local
192.168.20.0/24 0.0.0.0 20 1 Local
192.168.30.0/24 192.168.20.2 20 2 OSPF
192.168.40.0/24 192.168.20.2 20 3 OSPF
192.168.50.0/24 192.168.20.2 20 4 OSPF

Total Entries : 6
Total Entries : 1

Topology – Multiple OSPF Areas

Figure-6 Multiple OSPF Areas Configuration

33
Interoperating with Cisco Systems

Configuration
OSPF Configuration on Cisco Switch - 1

Command Example Purpose


Switch#config terminal
Switch(config)#interface gigabitEthernet 1/0/23
Switch(config-if)#no switchport
Switch(config-if)#ip address 192.168.20.2
255.255.255.0
Switch(config-if)#no shut
Create two IP interfaces
Switch(config-if)#exit
Step 1 (192.168.20.0 /
Switch(config)#interface gigabitEthernet 1/0/22
192.168.30.0)
Switch(config-if)#no switchport
Switch(config-if)#ip address 192.168.30.1
255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit

Create a Loopback
interface for Router ID.
Cisco router prefers the
Switch(config)#interface loopback 0
address of loopback
Step 2 Switch(config-if)#ip address 10.0.0.1 255.255.255.255
interface over the
Switch(config-if)#no shut
address of all physical
interfaces while
choosing Router ID.
Switch(config)#ip routing
Switch(config)#router ospf 100
Switch(config-router)#network 192.168.20.0 0.0.0.255 Enable OSPF on specific
Step 3
area 1 interfaces.
Switch(config-router)#network 192.168.30.0 0.0.0.255
area 0

OSPF Configuration on Cisco Switch - 2

Command Example Purpose


Switch#config terminal
Switch(config)#interface gigabitEthernet 1/0/23
Switch(config-if)#no switchport
Switch(config-if)#ip address 192.168.40.2
255.255.255.0
Switch(config-if)#no shut Create two IP interfaces
Step 1 Switch(config-if)#exit (192.168.30.0 /
Switch(config)#interface gigabitEthernet 1/0/22 192.168.40.0)
Switch(config-if)#no switchport
Switch(config-if)#ip address 192.168.30.1
255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
Create a Loopback
Switch(config)#interface loopback 0
interface for Router ID.
Step 2 Switch(config-if)#ip address 10.0.0.2 255.255.255.255
Cisco router prefers the
Switch(config-if)#no shut
address of loopback

34
Interoperating with Cisco Systems

interface over the


address of all physical
interfaces while
choosing Router ID.
Switch(config)#ip routing
Switch(config)#router ospf 100
Switch(config-router)#router-id 192.168.30.1 Enable OSPF on specific
Step 3 Switch(config-router)#network 192.168.30.0 0.0.0.255 interfaces and setup
area 0 router ID
Switch(config-router)#network 192.168.40.0 0.0.0.255
area 2

OSPF Configuration on D-Link Switch - 1

Command Example Purpose


DGS-3627:admin#create vlan 10 tag 10
DGS-3627:admin#create vlan 20 tag 20 Create VLAN 10 and
Step 1 DGS-3627:admin#config vlan default delete 1-16 20 and assign relative
DGS-3627:admin#config vlan 10 add untagged 1-8 ports to each VLAN
DGS-3627:admin#config vlan 20 add untagged 9-16,23
Create two IP
DGS-3627:admin#create ipif 10 192.168.10.1/24 10
Step 2 interfaces on VLAN
DGS-3627:admin#create ipif 20 192.168.20.1/24 20
10 and 20

DGS-3627:admin#config ospf router_id 192.168.10.1


DGS-3627:admin#create ospf area 0.0.0.1 type normal
Enable OSPF on
DGS-3627:admin#config ospf ipif 10 area 0.0.0.1 state
specific interfaces
Step 3 enable
and assign interfaces
DGS-3627:admin#config ospf ipif 20 area 0.0.0.1 state
on area 1.
enable
DGS-3627:admin#enable ospf

OSPF Configuration on D-Link Switch - 2

Command Example Purpose


DGS-3627:admin#create vlan 40 tag 40
DGS-3627:admin#create vlan 50 tag 50 Create VLAN 40 and
Step 1 DGS-3627:admin#config vlan default delete 1-16 50 and assign relative
DGS-3627:admin#config vlan 40 add untagged 1-8,24 ports to each VLAN
DGS-3627:admin#config vlan 50 add untagged 9-16
Create two IP
DGS-3627:admin#create ipif 40 192.168.10.1/24 40
Step 2 interfaces on VLAN
DGS-3627:admin#create ipif 50 192.168.20.1/24 50
40 and 50

DGS-3627:admin#config ospf router_id 192.168.40.1


DGS-3627:admin#create ospf area 0.0.0.2 type normal
Enable OSPF on
DGS-3627:admin#config ospf ipif 40 area 0.0.0.2 state
specific interfaces
Step 3 enable
and assign interfaces
DGS-3627:admin#config ospf ipif 50 area 0.0.0.2 state
on area 2.
enable
DGS-3627:admin#enable ospf

35
Interoperating with Cisco Systems

Troubleshooting Examples
Verifying OSPF information on a Cisco Switch

The following example shows you how to check OSPF detailed information on Cisco Switch.
Cisco Switch uses loopback interface to be Router ID and Area 1 should be created
Command Example
Catalyst# show ip ospf
Routing Process "ospf 100" with ID 10.0.0.1
Start time: 00:01:21.528, Time elapsed: 4d19h
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
It is an area border router
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Incremental-SPF disabled
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 0. Checksum Sum 0x000000
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 2. 2 normal 0 stub 0 nssa
Number of areas transit capable is 0
External flood list length 0
IETF NSF helper support enabled
Cisco NSF helper support enabled
Reference bandwidth unit is 100 mbps
Area BACKBONE(0)
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm last executed 00:27:19.763 ago
SPF algorithm executed 14 times
Area ranges are
Number of LSA 8. Checksum Sum 0x07E502
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 1
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
Area 1
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm last executed 00:33:43.525 ago
SPF algorithm executed 8 times
Area ranges are
Number of LSA 6. Checksum Sum 0x036A95
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 1

36
Interoperating with Cisco Systems

Number of indication LSA 0


Number of DoNotAge LSA 0
Flood list length 0

Checking OSPF status on D-Link Switch

The following example shows you how to verify if the OSPF is enabled on correct interfaces and
if the area assignment is correct.
Command Example
switch:admin# show ospf
Command: show ospf

OSPF Router ID : 192.168.10.1


State : Enabled

OSPF Interface Settings

Interface IP Address Area ID State Link Metric


Status
------------ ---------------- ----------- -------- -------- --------
System 10.90.90.90/8 0.0.0.0 Disabled Link Up 1
10 192.168.10.1/24 0.0.0.1 Enabled Link Up 1
20 192.168.20.1/24 0.0.0.1 Enabled Link Up 1

Total Entries : 3

OSPF Area Settings

Area ID Type Stub Import Summary LSA Stub Default Cost Translate
-------- ------ ----------------------- ----------------- ---------
0.0.0.0 Normal None None None
0.0.0.1 Normal None None None

Total Entries : 2

Virtual Interface Configuration

Transit Virtual Hello Dead Authentication Link


Area ID Neighbor Router Interval Interval Status
---------- --------------- -------- -------- -------------- ------

Total Entries : 0

OSPF Area Aggregation Settings

Area ID Aggregated LSDB Advertise


Network Address Type
--------------- ------------------ -------- ---------

Total Entries : 0

OSPF Host Route Settings

Host Address Metric Area ID


--------------- ------ ---------------

37
Interoperating with Cisco Systems

Total Entries : 0

The following example shows you how to verify if the OSPF interface information are correct.
Command Example
switch:admin# show ospf ipif 10
Command: show ospf ipif 10

Interface Name: 10 IP Address: 192.168.10.1/24 (Link Up)


Network Medium Type: BROADCAST Metric: 1
Area ID: 0.0.0.1 Administrative State: Enabled
Priority: 1 DR State: DR
DR Address: 192.168.10.1 Backup DR Address: None
Hello Interval: 10 Dead Interval: 40
Transmit Delay: 1 Retransmit Time: 5
Authentication: None

Passive Mode: Disabled

Total Entries : 1

38

You might also like