RIPv2 Part 1
RIPv2 Part 1
Learning Objectives
interface Loopback0
ip address 172.30.110.1 255.255.255.0
interface Loopback1
ip address 172.30.200.17 255.255.255.240
interface Loopback2
ip address 172.30.200.33 255.255.255.240
Router configuration
1 Hostname
2 Banner motd
3 Password Console
Enable (Privilege)
Telnet (vty)
4 LAN interface Default gateway
5 WAN interface DTE
DCE (clock rate)
6 Ping 1) PC –> default gateway
2) Connected network -> Connected
network CLI to troubleshoot network
1. show ip int brief
7 Routing Static/ RIPv2/ EIGRP/ OSPF 2. show ip route
8 Ping (end to end) PCs -> PCs 3. show run
4. show ip protocols
5. debug ip rip
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 172.30.0.0
R1(config-router)#network 209.165.200.0
R1(config-router)#no auto-summary
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 10.0.0.0
R2(config-router)#network 209.165.200.0
R2(config-router)#no auto-summary
R3(config)#router rip
TIPS R3(config-router)#version 2
DETERMINE:
R3(config-router)#network 172.30.0.0
1. CONNECTED NETWORKS
2. CLASS OF THE CONNECTED R3(config-router)#network 209.165.200.0
NETWORKS R3(config-router)#no auto-summary
Disable Automatic Summarization
• The no auto-summary command is used to turn off automatic
summarization in RIPv2.
• Disable auto summarization on all routers.
• The routers will no longer summarize routes at major network
boundaries.
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 172.30.0.0
R1(config-router)#network 209.165.200.0
R1(config-router)#no auto-summary
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 10.0.0.0
R2(config-router)#network 209.165.200.0
R2(config-router)#no auto-summary
R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#network 172.30.0.0
R3(config-router)#network 209.165.200.0
R3(config-router)#no auto-summary
CLI to troubleshoot network