Lab - Implement GLBP
Lab - Implement GLBP
Instructor Note: Red font color or gray highlights indicate text that appears in the instructor copy only.
Addressing Table
Device Interface IP Address Default Gateway
D1
VLAN 99 2001:db8:99::1/64 N/A
D1
Loopback 0 172.16.1.1/24 N/A
D1
Loopback 0 2001:db8:172::1/64 N/A
D2
VLAN 99 2001:db8:99::2/64 N/A
D2
Loopback 0 172.16.1.1/24 N/A
D2
Loopback 0 2001:db8:172::1/64 N/A
2020 - 2021 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 1 of 28 www.netacad.com
Lab - Implement GLBP
PC1 NIC
SLAAC
PC2 NIC 192.168.99.99/24 192.168.99.1
PC2 NIC
SLAAC
Objectives
Part 1: Build the Network and Configure Basic Device Settings and Interface Addressing
Part 2: Configure and Observe GLBP for IPv4 and IPv6
Part 3: Configure and Observe GLBP Authentication
Part 4: Configure and Observe GLBP Object Tracking
Background / Scenario
Although HSRP and VRRP provide gateway resiliency for the standby members of the redundancy group, the
upstream bandwidth is not used while the device is in standby mode. Only the active router for HSRP and the
master for VRRP groups forward traffic for the virtual MAC. Resources associated with the standby router are
not fully utilized. Some load balancing can be accomplished with these protocols through the creation of
multiple groups and through the assignment of multiple default gateways, but this configuration creates an
administrative burden. Previous labs provided you with experience configuring HSRP and VRRP to act as
First Hop Redundancy Protocols. Gateway Load Balancing Protocol (GLBP) performs a similar function in
redundancy but offers the capability to load balance over multiple gateways.
GLBP is a Cisco-proprietary solution created to enable automatic selection and simultaneous use of multiple
available gateways in addition to automatic failover between those gateways. Multiple routers share the load
of frames that, from a client perspective, are sent to a single default gateway address.
Like HSRP and VRRP, an election occurs, but rather than a single active router winning the election, GLBP
elects an Active Virtual Gateway (AVG). The AVG assigns virtual MAC addresses to each of the routers in the
GLBP group (called Active Virtual Forwarders or AVFs). These virtual MAC addresses are then provided to
hosts in an algorithmic manner in response to ARP requests from hosts for the default gateway.
GLBP allows for simultaneous forwarding from routers participating in a GLBP group. GLBP can support up to
four routers in a group. GLBP also offers authentication and object tracking.
Note: This lab is an exercise in deploying and verifying GLBP and does not necessarily reflect networking
best practices.
Note: The switches used with CCNP hands-on labs are Cisco 3650 with Cisco IOS XE release 16.9.4
(universalk9 image) and Cisco 2960+ with IOS release 15.2 (lanbase image). Other routers and Cisco IOS
versions can be used. Depending on the model and Cisco IOS version, the commands available and the
output produced might vary from what is shown in the labs.
Note: Ensure that the switches have been erased and have no startup configurations. If you are unsure
contact your instructor.
Instructor Note: Refer to the Instructor Lab Manual for the procedures to initialize and reload devices.
Required Resources
2 Switches (Cisco 3650 with Cisco IOS XE release 16.9.4 universal image or comparable)
1 Switch (Cisco 2960 with Cisco IOS Release 15.2(2) lanbasek9 image or comparable)
1 PC (Choice of operating system with a terminal emulation program installed)
2020 - 2021 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 2 of 28 www.netacad.com
Lab - Implement GLBP
Console cables to configure the Cisco IOS devices via the console ports
Ethernet cables as shown in the topology
Instructions
Part 1: Build the Network and Configure Basic Device Settings and Interface
Addressing
In Part 1, you will set up the network topology and configure basic settings and interface addressing.
Switch D1
hostname D1
ip routing
ipv6 unicast-routing
no ip domain lookup
banner motd # D1, Implement GLBP #
line con 0
exec-timeout 0 0
logging synchronous
exit
line vty 0 4
privilege level 15
password cisco123
exec-timeout 0 0
logging synchronous
login
exit
interface range g1/0/1-24, g1/1/1-4, g0/0
shutdown
exit
interface range g1/0/1-6
switchport mode trunk
no shutdown
exit
interface range g1/0/1-4
channel-group 12 mode active
exit
interface range g1/0/5-6
channel-group 1 mode active
2020 - 2021 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 3 of 28 www.netacad.com
Lab - Implement GLBP
exit
vlan 99
name ALL_THE_HOSTS
exit
interface vlan 99
ip address 192.168.99.1 255.255.255.0
ipv6 address fe80::d1:1 link-local
ipv6 address 2001:db8:99::1/64
no shutdown
exit
interface loopback 0
ip address 172.16.1.1 255.255.255.0
ipv6 address fe80::d1:2 link-local
ipv6 address 2001:db8:172::1/64
no shutdown
exit
Switch D2
hostname D2
ip routing
ipv6 unicast-routing
no ip domain lookup
banner motd # D2, Implement GLBP #
line con 0
exec-timeout 0 0
logging synchronous
exit
line vty 0 4
privilege level 15
password cisco123
exec-timeout 0 0
logging synchronous
login
exit
interface range g1/0/1-24, g1/1/1-4, g0/0
shutdown
exit
interface range g1/0/1-6
switchport mode trunk
no shutdown
exit
interface range g1/0/1-4
channel-group 12 mode active
exit
interface range g1/0/5-6
channel-group 2 mode active
2020 - 2021 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 4 of 28 www.netacad.com
Lab - Implement GLBP
exit
vlan 99
name ALL_THE_HOSTS
exit
interface vlan 99
ip address 192.168.99.2 255.255.255.0
ipv6 address fe80::d2:1 link-local
ipv6 address 2001:db8:99::2/64
no shutdown
exit
interface loopback 0
ip address 172.16.1.1 255.255.255.0
ipv6 address fe80::d2:2 link-local
ipv6 address 2001:db8:172::1/64
no shutdown
exit
Switch A1
hostname A1
no ip domain lookup
banner motd # A1, Implement GLBP #
line con 0
exec-timeout 0 0
logging synchronous
exit
line vty 0 4
privilege level 15
password cisco123
exec-timeout 0 0
logging synchronous
login
exit
interface range f0/1-24, g0/1-2
shutdown
exit
interface range f0/1-4
switchport mode trunk
no shutdown
exit
interface range f0/1-2
channel-group 1 mode active
exit
interface range f0/3-4
channel-group 2 mode active
exit
vlan 99
2020 - 2021 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 5 of 28 www.netacad.com
Lab - Implement GLBP
name ALL_THE_HOSTS
exit
interface f0/23
switchport mode access
switchport access vlan 99
spanning-tree portfast
no shutdown
exit
interface f0/24
switchport mode access
switchport access vlan 99
spanning-tree portfast
no shutdown
exit
interface vlan 99
ip address 192.168.99.3 255.255.255.0
ipv6 address fe80::a1:1 link-local
ipv6 address 2001:db8:99::3/64
no shutdown
exit
ip default-gateway 192.168.99.254
b. Set the clock on each switch to UTC time.
c. Save the running configuration to startup-config.
Close configuration window
2020 - 2021 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 6 of 28 www.netacad.com
Lab - Implement GLBP
The standby address for VLAN 99 will be the host address 192.168.99.254. For IPv6, VLAN 99 will use
fe80::99:254 as the default gateway.
2020 - 2021 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 7 of 28 www.netacad.com
Lab - Implement GLBP
2020 - 2021 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 8 of 28 www.netacad.com
Lab - Implement GLBP
Windows OS
C:\Users\student> arp -a
<output omitted>
Internet Address Physical Address Type
-------------------------------------------- ----------------- -----------
fe80::99:254 00-07-b4-03-e4-02 Reachable (Router)
<output omitted>
b. Now that the PCs are operating and you can see the load balancing in effect, what happens when one of
the AVFs fail? To observe this, issue the shutdown command on D2 interface VLAN 99, ping 172.16.1.1
and 2001:db8:172::1 from PC1 and PC2, then look at the ARP and Neighbor tables on PC1 and PC2.
Linux OS
student@ linux-machine:~/Documents$ ip neigh show | grep 254
2020 - 2021 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 9 of 28 www.netacad.com
Lab - Implement GLBP
Windows OS
C:\Users\student> arp -a
2020 - 2021 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 10 of 28 www.netacad.com
Lab - Implement GLBP
2020 - 2021 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 11 of 28 www.netacad.com
Lab - Implement GLBP
2020 - 2021 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 12 of 28 www.netacad.com
Lab - Implement GLBP
2020 - 2021 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 13 of 28 www.netacad.com
Lab - Implement GLBP
D1(config-if)#
*Jan 22 21:53:50.687: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0,
changed state to down
*Jan 22 21:53:50.689: %LINK-5-CHANGED: Interface Loopback0, changed state to
administratively down
D1(config-if)#
*Jan 22 21:54:21.257: %GLBP-6-FWDSTATECHANGE: Vlan99 Grp 99 Fwd 1 state Active ->
Listen
*Jan 22 21:54:21.900: %GLBP-6-FWDSTATECHANGE: Vlan99 Grp 996 Fwd 1 state Active ->
Listen
c. After the GLBP state change on D1, look at the ping output. The ping should be continuing without fail,
and only experiencing a few lost packets.
d. Examine the output of show glbp for group 99.
D1# show glbp
Vlan99 - Group 99
State is Active
3 state changes, last state change 00:05:48
Virtual IP address is 192.168.99.254
Hello time 3 sec, hold time 10 sec
Next hello sent in 0.448 secs
Redirect time 600 sec, forwarder time-out 14400 sec
Authentication MD5, key-string
Preemption enabled, min delay 0 sec
Active is local
Standby is 192.168.99.2, priority 100 (expires in 8.384 sec)
Priority 150 (configured)
Weighting 80, low (configured 110), thresholds: lower 85, upper 105
Track object 7 state Down decrement 30
Load balancing: round-robin
Group members:
d8b1.9028.afdd (192.168.99.1) local
d8b1.905d.c35d (192.168.99.2) authenticated
There are 2 forwarders (0 active)
Forwarder 1
State is Listen
4 state changes, last state change 00:01:22
MAC address is 0007.b400.6301 (default)
Owner ID is d8b1.9028.afdd
Redirection enabled
Preemption enabled, min delay 30 sec
Active is 192.168.99.2 (secondary), weighting 110 (expires in 10.208 sec)
Client selection count: 15
Forwarder 2
State is Listen
8 state changes, last state change 01:09:16
MAC address is 0007.b400.6302 (learnt)
Owner ID is d8b1.905d.c35d
Redirection enabled, 598.400 sec remaining (maximum 600 sec)
Time to live: 14398.400 sec (maximum 14400 sec)
2020 - 2021 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 14 of 28 www.netacad.com
Lab - Implement GLBP
Switch D1
D1# show run
Building configuration...
2020 - 2021 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 15 of 28 www.netacad.com
Lab - Implement GLBP
!
hostname D1
!
vrf definition Mgmt-vrf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
no aaa new-model
switch 1 provision ws-c3650-24ts
!
ip routing
!
ip domain lookup
!
login on-success log
ipv6 unicast-routing
!
license boot level ipservicesk9
!
diagnostic bootup level minimal
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
redundancy
mode sso
!
transceiver type all
monitoring
!
track 7 interface Loopback0 line-protocol
!
class-map match-any system-cpp-police-topology-control
description Topology control
class-map match-any system-cpp-police-sw-forward
description Sw forwarding, L2 LVX data, LOGGING
class-map match-any system-cpp-default
description Inter FED, EWLC control, EWLC data
class-map match-any system-cpp-police-sys-data
description Learning cache ovfl, High Rate App, Exception, EGR Exception, NFL
SAMPLED DATA, RPF Failed
class-map match-any system-cpp-police-punt-webauth
description Punt Webauth
class-map match-any system-cpp-police-l2lvx-control
description L2 LVX control packets
class-map match-any system-cpp-police-forus
2020 - 2021 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 16 of 28 www.netacad.com
Lab - Implement GLBP
2020 - 2021 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 17 of 28 www.netacad.com
Lab - Implement GLBP
interface GigabitEthernet1/0/3
switchport mode trunk
channel-group 12 mode active
!
interface GigabitEthernet1/0/4
switchport mode trunk
channel-group 12 mode active
!
interface GigabitEthernet1/0/5
switchport mode trunk
channel-group 1 mode active
!
interface GigabitEthernet1/0/6
switchport mode trunk
channel-group 1 mode active
!
interface GigabitEthernet1/0/7
shutdown
!
interface GigabitEthernet1/0/8
shutdown
!
interface GigabitEthernet1/0/9
shutdown
!
interface GigabitEthernet1/0/10
shutdown
!
interface GigabitEthernet1/0/11
shutdown
!
interface GigabitEthernet1/0/12
shutdown
!
interface GigabitEthernet1/0/13
shutdown
!
interface GigabitEthernet1/0/14
shutdown
!
interface GigabitEthernet1/0/15
shutdown
!
interface GigabitEthernet1/0/16
shutdown
!
interface GigabitEthernet1/0/17
shutdown
!
interface GigabitEthernet1/0/18
2020 - 2021 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 18 of 28 www.netacad.com
Lab - Implement GLBP
shutdown
!
interface GigabitEthernet1/0/19
shutdown
!
interface GigabitEthernet1/0/20
shutdown
!
interface GigabitEthernet1/0/21
shutdown
!
interface GigabitEthernet1/0/22
shutdown
!
interface GigabitEthernet1/0/23
shutdown
!
interface GigabitEthernet1/0/24
shutdown
!
interface GigabitEthernet1/1/1
shutdown
!
interface GigabitEthernet1/1/2
shutdown
!
interface GigabitEthernet1/1/3
shutdown
!
interface GigabitEthernet1/1/4
shutdown
!
interface Vlan1
no ip address
shutdown
!
interface Vlan99
ip address 192.168.99.1 255.255.255.0
ipv6 address FE80::D1:1 link-local
ipv6 address 2001:DB8:99::1/64
glbp 99 ip 192.168.99.254
glbp 99 priority 150
glbp 99 preempt
glbp 99 weighting 110 lower 85 upper 105
glbp 99 authentication md5 key-string Super53cret
glbp 99 weighting track 7 decrement 30
glbp 996 ipv6 FE80::99:254
glbp 996 priority 150
glbp 996 preempt
glbp 996 weighting 110 lower 85 upper 105
2020 - 2021 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 19 of 28 www.netacad.com
Lab - Implement GLBP
Switch D2
D2# show run
Building configuration...
2020 - 2021 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 20 of 28 www.netacad.com
Lab - Implement GLBP
exit-address-family
!
address-family ipv6
exit-address-family
!
no aaa new-model
switch 1 provision ws-c3650-24ts
!
ip routing
!
no ip domain lookup
!
login on-success log
ipv6 unicast-routing
!
license boot level ipservicesk9
!
diagnostic bootup level minimal
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
redundancy
mode sso
!
transceiver type all
monitoring
!
track 7 interface Loopback0 line-protocol
!
class-map match-any system-cpp-police-topology-control
description Topology control
class-map match-any system-cpp-police-sw-forward
description Sw forwarding, L2 LVX data, LOGGING
class-map match-any system-cpp-default
description Inter FED, EWLC control, EWLC data
class-map match-any system-cpp-police-sys-data
description Learning cache ovfl, High Rate App, Exception, EGR Exception, NFL
SAMPLED DATA, RPF Failed
class-map match-any system-cpp-police-punt-webauth
description Punt Webauth
class-map match-any system-cpp-police-l2lvx-control
description L2 LVX control packets
class-map match-any system-cpp-police-forus
description Forus Address resolution and Forus traffic
class-map match-any system-cpp-police-multicast-end-station
description MCAST END STATION
class-map match-any system-cpp-police-multicast
description Transit Traffic and MCAST Data
class-map match-any system-cpp-police-l2-control
2020 - 2021 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 21 of 28 www.netacad.com
Lab - Implement GLBP
description L2 control
class-map match-any system-cpp-police-dot1x-auth
description DOT1X Auth
class-map match-any system-cpp-police-data
description ICMP redirect, ICMP_GEN and BROADCAST
class-map match-any system-cpp-police-stackwise-virt-control
description Stackwise Virtual
class-map match-any non-client-nrt-class
class-map match-any system-cpp-police-routing-control
description Routing control and Low Latency
class-map match-any system-cpp-police-protocol-snooping
description Protocol snooping
class-map match-any system-cpp-police-dhcp-snooping
description DHCP snooping
class-map match-any system-cpp-police-system-critical
description System Critical and Gold Pkt
!
policy-map system-cpp-policy
!
interface Loopback0
ip address 172.16.1.1 255.255.255.0
ipv6 address FE80::D2:2 link-local
ipv6 address 2001:DB8:172::1/64
!
interface Port-channel1
!
interface Port-channel2
switchport mode trunk
!
interface Port-channel12
switchport mode trunk
!
interface GigabitEthernet0/0
vrf forwarding Mgmt-vrf
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet1/0/1
switchport mode trunk
channel-group 12 mode active
!
interface GigabitEthernet1/0/2
switchport mode trunk
channel-group 12 mode active
!
interface GigabitEthernet1/0/3
switchport mode trunk
channel-group 12 mode active
!
2020 - 2021 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 22 of 28 www.netacad.com
Lab - Implement GLBP
interface GigabitEthernet1/0/4
switchport mode trunk
channel-group 12 mode active
!
interface GigabitEthernet1/0/5
switchport mode trunk
channel-group 2 mode active
!
interface GigabitEthernet1/0/6
switchport mode trunk
channel-group 2 mode active
!
interface GigabitEthernet1/0/7
shutdown
!
interface GigabitEthernet1/0/8
shutdown
!
interface GigabitEthernet1/0/9
shutdown
!
interface GigabitEthernet1/0/10
shutdown
!
interface GigabitEthernet1/0/11
shutdown
!
interface GigabitEthernet1/0/12
shutdown
!
interface GigabitEthernet1/0/13
shutdown
!
interface GigabitEthernet1/0/14
shutdown
!
interface GigabitEthernet1/0/15
shutdown
!
interface GigabitEthernet1/0/16
shutdown
!
interface GigabitEthernet1/0/17
shutdown
!
interface GigabitEthernet1/0/18
shutdown
!
interface GigabitEthernet1/0/19
shutdown
2020 - 2021 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 23 of 28 www.netacad.com
Lab - Implement GLBP
!
interface GigabitEthernet1/0/20
shutdown
!
interface GigabitEthernet1/0/21
shutdown
!
interface GigabitEthernet1/0/22
shutdown
!
interface GigabitEthernet1/0/23
shutdown
!
interface GigabitEthernet1/0/24
shutdown
!
interface GigabitEthernet1/1/1
shutdown
!
interface GigabitEthernet1/1/2
shutdown
!
interface GigabitEthernet1/1/3
shutdown
!
interface GigabitEthernet1/1/4
shutdown
!
interface Vlan1
no ip address
shutdown
!
interface Vlan99
ip address 192.168.99.2 255.255.255.0
ipv6 address FE80::D2:1 link-local
ipv6 address 2001:DB8:99::2/64
glbp 99 ip 192.168.99.254
glbp 99 preempt
glbp 99 weighting 110 lower 85 upper 105
glbp 99 authentication md5 key-string Super53cret
glbp 99 weighting track 7 decrement 30
glbp 996 ipv6 FE80::99:254
glbp 996 preempt
glbp 996 weighting 110 lower 85 upper 105
glbp 996 authentication md5 key-string Super53cret
glbp 996 weighting track 7 decrement 30
!
ip forward-protocol nd
ip http server
ip http authentication local
2020 - 2021 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 24 of 28 www.netacad.com
Lab - Implement GLBP
ip http secure-server
!
control-plane
service-policy input system-cpp-policy
!
banner motd ^C D2, Implement GLBP ^C
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
exec-timeout 0 0
privilege level 15
password cisco123
logging synchronous
login
line vty 5 15
login
!
end
Switch A1
A1# show run
Building configuration...
2020 - 2021 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 25 of 28 www.netacad.com
Lab - Implement GLBP
2020 - 2021 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 26 of 28 www.netacad.com
Lab - Implement GLBP
!
interface FastEthernet0/14
shutdown
!
interface FastEthernet0/15
shutdown
!
interface FastEthernet0/16
shutdown
!
interface FastEthernet0/17
shutdown
!
interface FastEthernet0/18
shutdown
!
interface FastEthernet0/19
shutdown
!
interface FastEthernet0/20
shutdown
!
interface FastEthernet0/21
shutdown
!
interface FastEthernet0/22
shutdown
!
interface FastEthernet0/23
switchport access vlan 99
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/24
switchport access vlan 99
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/1
shutdown
!
interface GigabitEthernet0/2
shutdown
!
interface Vlan1
no ip address
shutdown
!
interface Vlan99
ip address 192.168.99.3 255.255.255.0
2020 - 2021 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 27 of 28 www.netacad.com
Lab - Implement GLBP
2020 - 2021 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 28 of 28 www.netacad.com