0% found this document useful (0 votes)
30 views

Cisco DHCP Assignment

Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
0% found this document useful (0 votes)
30 views

Cisco DHCP Assignment

Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
You are on page 1/ 4

Cisco Packet Tracer DHCP Configuration Assignment

Objective:

Students will configure a router to function as a DHCP server to dynamically assign IP addresses to

the hosts in a network. The network should have three LANs, and the router will be responsible for

assigning IP addresses in different subnets.

Scenario:

You are a network administrator for a small organization. Your organization has three departments,

each with its own LAN. You need to configure the router to act as a DHCP server to assign IP

addresses to the hosts in each department dynamically.

Network Setup:

- Router: Connected to three switches, each representing a different department.

- Switches: Connected to the hosts.

- Hosts: Each host should get its IP address from the DHCP server.

IP Addressing Plan:

- LAN1 (Engineering Department): Subnet 192.168.10.0/24

- LAN2 (Sales Department): Subnet 192.168.20.0/24

- LAN3 (HR Department): Subnet 192.168.30.0/24

Tasks:

1. Network Topology: Set up a topology in Cisco Packet Tracer that includes:

- 1 Router

- 3 Switches

- 2 Hosts per switch (total of 6 hosts)


2. Subnet Configuration:

- Assign IP ranges for each subnet:

- LAN1: 192.168.10.0/24

- LAN2: 192.168.20.0/24

- LAN3: 192.168.30.0/24

3. Router Configuration:

- Configure the router interfaces for each LAN:

- Interface for LAN1: 192.168.10.1

- Interface for LAN2: 192.168.20.1

- Interface for LAN3: 192.168.30.1

4. DHCP Server Configuration:

- On the router, configure a DHCP pool for each LAN:

- Pool 1: Network: 192.168.10.0, Default gateway: 192.168.10.1

- Pool 2: Network: 192.168.20.0, Default gateway: 192.168.20.1

- Pool 3: Network: 192.168.30.0, Default gateway: 192.168.30.1

- Exclude the first 10 IP addresses from the pool.

5. Verify DHCP: Ensure that all hosts are receiving an IP address automatically from the DHCP

server. Test connectivity between hosts in different LANs using the 'ping' command.

6. Bonus Task: Configure a backup DHCP server on another router and set it as a secondary option

for one of the networks.

Configuration Commands

1. Assign IP addresses to router interfaces:


Router> enable

Router# configure terminal

Router(config)# interface gigabitEthernet 0/0

Router(config-if)# ip address 192.168.10.1 255.255.255.0

Router(config-if)# no shutdown

Router(config-if)# exit

Router(config)# interface gigabitEthernet 0/1

Router(config-if)# ip address 192.168.20.1 255.255.255.0

Router(config-if)# no shutdown

Router(config-if)# exit

Router(config)# interface gigabitEthernet 0/2

Router(config-if)# ip address 192.168.30.1 255.255.255.0

Router(config-if)# no shutdown

Router(config-if)# exit

2. Configure DHCP Pools:

Router(config)# ip dhcp excluded-address 192.168.10.1 192.168.10.10

Router(config)# ip dhcp excluded-address 192.168.20.1 192.168.20.10

Router(config)# ip dhcp excluded-address 192.168.30.1 192.168.30.10

Router(config)# ip dhcp pool LAN1

Router(dhcp-config)# network 192.168.10.0 255.255.255.0


Router(dhcp-config)# default-router 192.168.10.1

Router(dhcp-config)# exit

Router(config)# ip dhcp pool LAN2

Router(dhcp-config)# network 192.168.20.0 255.255.255.0

Router(dhcp-config)# default-router 192.168.20.1

Router(dhcp-config)# exit

Router(config)# ip dhcp pool LAN3

Router(dhcp-config)# network 192.168.30.0 255.255.255.0

Router(dhcp-config)# default-router 192.168.30.1

Router(dhcp-config)# exit

Deliverables:

- A screenshot of the working network topology in Cisco Packet Tracer.

- A document listing the IP addresses assigned to the hosts by the DHCP server.

- A brief explanation of the steps taken to configure DHCP and test the network connectivity.

You might also like