Lab 2
Lab 2
WLAN
Part 2
Common Icons
Router PC STA
1 CAPWAP Configuration
1.1 Introduction
1.1.1 Networking Topology
Figure 1-1 Lab0
Create VLANs
Configure IP address
Configure IP address
Configure ports
Configure CAPWAP
# After entering the system view, run the sysname command to change the device name to SW-LAB0.
[Huawei]sysname SW-LAB0
- [SW-LAB0]
# After entering the system view, run the sysname command to change the device name to AC
[AC6605]sysname AC3
[AC3]
# On the switch
[SW-LAB0]vlan 20
[SW-LAB0-vlan20]description Management-AP
[SW-LAB0-vlan20]quit
[SW-LAB0]vlan 400
[SW-LAB0-vlan400]description Management
[SW-LAB0-vlan400]q
[AC3]vlan 20
[AC3-vlan20]description Mgmt-AP
[AC3-vlan20]q
# Set the IP address of VLANIF 400 on the AC to 172.16.40.252 and the subnet mask to 24.
# Set the IP address of VLANIF 20 on the AC to 172.16.20.200 and the subnet mask to 24.
[AC3]interface vlanif 20
[AC3-Vlanif20]ip address 172.16.20.200 24
[AC3-Vlanif20]descritpion Mgmt AP
[AC3-Vlanif20]q
[AC3]
# Run the display this command on the AC's interface to verify the configuration result.
In the production environment, to prevent the configuration from becoming invalid after power-off or
fault recovery, save the device configuration.
# Run the save command in the user view of the AC and SW to save the device configurations. If the
message "saved successfully" is displayed, the configuration is savedsuccessfully.
[SW-LAB0]quit
<SW-LAB0>save
The current configuration will be written to the device.Are
you sure to continue? (y/n)[n]:y
It will take several minutes to save configuration file, please wait.......
Configuration file had been saved successfully
Note: The configuration file will take effect after being activated
<SW-LAB0>
[AC3]quit
<AC3>save
The current configuration will be written to the device.Are
you sure to continue? (y/n)[n]:y
# If the eNSP simulator is used for the lab, save the topology after saving the device configurations.
----End
2 Layer 2 Networking
1.3 Introduction
1.3.1 Networking Topology
Figure 1-1 Lab topology for Layer 2 Networking
[AC-FM]aaa
[AC-FM -aaa] local-user admin-web password cipher FM**2023
[AC-FM -aaa] local-user admin-web privilege level 15
[AC-FM -aaa] local-user admin-web service-type http
[AC-FM -aaa] quit
[AC-FM]
#Configure the interface G0/0/1 connecting to your laptop using the device Cloud
[SW-FM]interface GigabitEthernet 0/0/1
[SW-FM -GigabitEthernet0/0/1]port link-type access
[SW-FM -GigabitEthernet0/0/1] port default vlan 200
[SW-FM -GigabitEthernet0/0/1]description to AP01
[SW-FM -GigabitEthernet0/0/1]q
[AC-FM]dhcp enable
Info: The operation may take a few seconds. Please wait for a
moment.done.
[AC-FM]
# Enable DHCP server on AC-FM for vlan 10 using the interface vlanif 10
[AC-FM]interface Vlanif 10
[AC-FM-Vlanif10] ip address 192.168.10.100 255.255.255.0
[AC-FM-Vlanif10]dhcp select interface
[AC-FM-Vlanif10]dhcp server dns-list 8.8.8.8
[AC-FM-Vlanif10]q
# Run the ping command on SW to test the connectivity between the AC and SW. Thecommand
output shows that SW can ping the AC.
[SW-FM]ping 192.168.200.150
PING 192.168.200.150: 56 data bytes, press CTRL_C to break
Reply from 192.168.200.1: bytes=56 Sequence=1 ttl=255 time=90 ms
Reply from 192.168.200.1: bytes=56 Sequence=2 ttl=255 time=20 ms
Reply from 192.168.200.1: bytes=56 Sequence=3 ttl=255 time=10 ms
Reply from 192.168.200.1: bytes=56 Sequence=4 ttl=255 time=10 ms
Reply from 192.168.200.1: bytes=56 Sequence=5 ttl=255 time=10 ms
Then open the web browser Firefox or Google Chrome and put on bar tab, the IP address of the AC
Result :
Step 5 display the version of AP and verify if the Aps obtained IP addresses from DHCP
server.
# on AP01, run the display ip interface brief command to view the IP address of AP1
In the production environment, to prevent the configuration from becoming invalid after power-
off or fault recovery, save the device configuration.
# Run the save command in the user view of SW to save the device configurations. If the message
"saved successfully" is displayed, the configuration is savedsuccessfully.
<SW-FM>save
The current configuration will be written to the device.Are
you sure to continue? (y/n)[n]:y
It will take several minutes to save configuration file, please wait.......
Configuration file has been saved successfully
Note: The configuration file will take effect after being activated
<SW-FM>
#To save configuration, on AC you can use the web interface and click on save.
# If the eNSP simulator is used for the lab, save the topology after saving the device configurations.
----End
1.5 Verification
.
<AC-FM>dis current-configuration
#
set memory-usage threshold 0
#
ssl renegotiation-rate 1
#
vlan batch 10 200
#
authentication-profile name default_authen_profile
authentication-profile name dot1x_authen_profile
authentication-profile name mac_authen_profile
authentication-profile name portal_authen_profile
authentication-profile name macportal_authen_profile
#
diffserv domain default
#
vlan 10
description Mgmt-AP
vlan 200
description Mgmt
#
radius-server template default
#
pki realm default
rsa local-key-pair default
enrollment self-signed
Huawei & TMI Proprietary and
Confidential Copyright © Huawei
Technologies Co.,Ltd
Huawei WLAN Certification Training Lab Page 22
# Guide
ike proposal default
encryption-algorithm aes-256
dh group14
authentication-algorithm sha2-256
authentication-method pre-share
integrity-algorithm hmac-sha2-256
prf hmac-sha2-256
#
free-rule-template name default_free_rule
#
portal-access-profile name portal_access_profile
#
aaa
authentication-scheme default
authentication-scheme radius
authentication-mode radius
authorization-scheme default
accounting-scheme default
domain default
authentication-scheme radius
radius-server default
domain default_admin
authentication-scheme default
local-user admin password irreversible-cipher $1a$`fAl+G%waU$It>7:pS"PD|aed0MT_
"InZu)J21dxWDU+XX0tiN8$
local-user admin privilege level 15
local-user admin service-type http
local-user admin-web password irreversible-cipher $1a$NL`AI2=i69$e|O]FHsOWWGCw!
CMS&<+$f=k${A)AH>U^jXO9K=J$
local-user admin-web privilege level 15
local-user admin-web service-type http
#
interface Vlanif10
description interco-AC-AP
ip address 192.168.10.100 255.255.255.0
#
interface Vlanif200
ip address 192.168.200.150 255.255.255.0
management-interface
#
interface MEth0/0/1
undo negotiation auto
duplex half
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
decription to SW-FM
port link-type trunk
port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/3
#
interface GigabitEthernet0/0/4
#
interface GigabitEthernet0/0/5
#
interface GigabitEthernet0/0/6
#
interface GigabitEthernet0/0/7
#
Huawei & TMI Proprietary and
Confidential Copyright © Huawei
Technologies Co.,Ltd
Huawei WLAN Certification Training Lab Page 23
Guide
interface GigabitEthernet0/0/8
#
interface GigabitEthernet0/0/9
#
interface GigabitEthernet0/0/10
#
interface GigabitEthernet0/0/11
#
interface GigabitEthernet0/0/12
#
interface GigabitEthernet0/0/13
#
interface GigabitEthernet0/0/14
#
interface GigabitEthernet0/0/15
#
interface GigabitEthernet0/0/16
#
interface GigabitEthernet0/0/17
#
interface GigabitEthernet0/0/18
#
interface GigabitEthernet0/0/19
#
interface GigabitEthernet0/0/20
#
interface GigabitEthernet0/0/21
undo negotiation auto
duplex half
#
interface GigabitEthernet0/0/22
undo negotiation auto
duplex half
#
interface GigabitEthernet0/0/23
undo negotiation auto
duplex half
#
interface GigabitEthernet0/0/24
undo negotiation auto
duplex half
#
interface XGigabitEthernet0/0/1
#
interface XGigabitEthernet0/0/2
#
interface NULL0
#
snmp-agent local-engineid 800007DB03000000000000
snmp-agent
#
ssh server secure-algorithms cipher aes256_ctr aes128_ctr
ssh server key-exchange dh_group14_sha1
ssh client secure-algorithms cipher aes256_ctr aes128_ctr
ssh client secure-algorithms hmac sha2_256
ssh client key-exchange dh_group14_sha1
#
capwap source interface vlanif10
#
user-interface con 0
authentication-mode password
user-interface vty 0 4
Huawei & TMI Proprietary and
Confidential Copyright © Huawei
Technologies Co.,Ltd
Huawei WLAN Certification Training Lab Page 24
protocol inbound all Guide
user-interface vty 16 20
protocol inbound all
#
wlan
traffic-profile name default
security-profile name default
security-profile name default-wds
security-profile name default-mesh
ssid-profile name default
vap-profile name default
wds-profile name default
mesh-handover-profile name default
mesh-profile name default
regulatory-domain-profile name default
air-scan-profile name default
rrm-profile name default
radio-2g-profile name default
radio-5g-profile name default
wids-spoof-profile name default
wids-profile name default
wireless-access-specification
ap-system-profile name default
port-link-profile name default
wired-port-profile name default
serial-profile name preset-enjoyor-toeap
ap-group name default
provision-ap
#
dot1x-access-profile name dot1x_access_profile
#
mac-access-profile name mac_access_profile
#
return
<AC6605>
interface Vlanif1
ip address 192.168.1.1 255.255.255.0#
return