0% found this document useful (0 votes)
3 views

Configuration Command

Uploaded by

m.rslan1512
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
0% found this document useful (0 votes)
3 views

Configuration Command

Uploaded by

m.rslan1512
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
You are on page 1/ 15

1.

Lab_A
1. global config

Router>enable
Router#config t
Router(config)#hostname Lab_A
Lab_A(config)#enable secret todd

2. config 1st interface

Lab_A(config)#interface fa0/0
Lab_A(config-if)#ip address 192.168.10.1 255.255.255.0
Lab_A(config-if)#description Lab_A LAN Connection
Lab_A(config-if)#no shut

3. config 2nd interface WAN Connection to Lab_B

Lab_A(config-if)#interface serial 0/0


Lab_A(config-if)#ip address 192.168.20.1 255.255.255.0
Lab_A(config-if)#description WAN Connection to Lab_B
Lab_A(config-if)#no shut

4. exit from config interface to global config

Lab_A(config-if)#exit

5. config line console & set password & login

Lab_A(config)#line console 0
Lab_A(config-line)#password todd
Lab_A(config-line)#login

6. config line aux & set password & login


Lab_A(config-line)#line aux 0
Lab_A(config-line)#password todd
Lab_A(config-line)#login

7. config line vty & set password & login

Lab_A(config-line)#line vty 0 4
Lab_A(config-line)#password todd
Lab_A(config-line)#login

8. exit form line config to global config

Lab_A(config-line)#exit

9. send message of the day motd

Lab_A(config)#banner motd # This is the Lab_A router #

10. exit from global config to privilege

Lab_A(config)# ^z

11. copy from ram to nvram

Lab_A#copy running-config startup-config

12. show if route

Lab_A#sh ip route
192.168.10.0/24 is directly connected, FastEthernet0/0
192.168.20.0/24 is directly connected, Serial 0/0

2.Lab_B
1. global config

Router>enable
Router#config t
Router(config)#hostname Lab_B
Lab_B(config)#enable secret todd

2. config 1st interface

Lab_B(config)#interface fa0/0
Lab_B(config-if)#ip address 192.168.30.1 255.255.255.0
Lab_B(config-if)#description Lab_B LAN Connection
Lab_B(config-if)#no shut

3. config 2nd interface WAN Connection to Lab_A

Lab_B(config-if)#interface serial 0/0


Lab_B(config-if)#ip address 192.168.20.2 255.255.255.0
Lab_B(config-if)#description WAN Connection to Lab_A
Lab_B(config-if)#clock rate 64000
Lab_B(config-if)#no shut

4. config 3rd interface WAN Connection to Lab_C

Lab_B(config-if)#interface serial 0/0


Lab_B(config-if)#ip address 192.168.40.1 255.255.255.0
Lab_B(config-if)#description WAN Connection to Lab_C
Lab_B(config-if)#clock rate 64000
Lab_B(config-if)#no shut

5. exit from config interface to global config

Lab_B(config-if)#exit

6. config line console & set password & login

Lab_B(config)#line console 0
Lab_B(config-line)#password todd
Lab_B(config-line)#login

7. config line aux & set password & login

Lab_B(config-line)#line aux 0
Lab_B(config-line)#password todd
Lab_B(config-line)#login

8. config line vty & set password & login

Lab_B(config-line)#line vty 0 4
Lab_B(config-line)#password todd
Lab_B(config-line)#login

9. exit form line config to global config

Lab_B(config-line)#exit

10. send message of the day motd

Lab_B(config)#banner motd # This is the Lab_B router #


11. exit from global config to privilege

Lab_B(config)# ^z

12. copy from ram to nvram

Lab_B#copy running-config startup-config

13. show if route

Lab_B#sh ip route

192.168.20.0/24 is directly connected, Serial0/0


192.168.40.0/24 is directly connected, Serial0/1
192.168.30.0 is directly connected FastEthernet 0/0

3.Lab_C
1. global config

Router>enable
Router#config t
Router(config)#hostname Lab_C
Lab_C(config)#enable secret todd

2. config 1st interface

Lab_C(config)#interface fa0/0
Lab_C(config-if)#ip address 192.168.50.1 255.255.255.0
Lab_C(config-if)#description Lab_C LAN Connection
Lab_C(config-if)#no shut
3. config 2nd interface WAN Connection to Lab_B

Lab_C(config-if)#interface serial 0/0


Lab_C(config-if)#ip address 192.168.40.2 255.255.255.0
Lab_C(config-if)#description WAN Connection to Lab_B
Lab_C(config-if)#no shut

4. exit from config interface to global config

Lab_C(config-if)#exit

5. config line console & set password & login

Lab_C(config)#line console 0
Lab_C(config-line)#password todd
Lab_C(config-line)#login

6. config line aux & set password & login

Lab_C(config-line)#line aux 0
Lab_C(config-line)#password todd
Lab_C(config-line)#login

7. config line vty & set password & login

Lab_C(config-line)#line vty 0 4
Lab_C(config-line)#password todd
Lab_C(config-line)#login

8. exit form line config to global config

Lab_C(config-line)#exit
9. send message of the day motd

Lab_C(config)#banner motd # This is the Lab_C router #

10. exit from global config to privilege

Lab_C(config)# ^z

11. copy from ram to nvram

Lab_C#copy running-config startup-config

12. show if route

Lab_C#sh ip route

192.168.50.0/24 is directly connected, FastEthernet0/0


192.168.40.0/24 is directly connected, Serial0/0

4. Static Routing
ip route [destination_network] [mask] [next-hop_address or exitinterface]
[administrative_distance] [permanent]

1. ip route: The command used to create the static route.


2. destination_network The network you're placing in the routing table.
3. mask The subnet mask being used on the network.
4. next-hop_address The address of the next-hop router that will receive the packet
5. exitinterface You can use it in place of the next-hop address if you want,
6. administrative_distance By default, static routes have an administrative distance of 1
7. permanent If the interface is shut down, or the router can't communicate to the next-
hop router

1. Lab_A
1. routing table:

. 192.168.30.0
. 192.168.40.0
. 192.168.50.0

2. config routing

Lab_A(config)#ip route 192.168.30.0 255.255.255.0


192.168.20.2 => next hop

Lab_A(config)#ip route 192.168.40.0 255.255.255.0


192.168.20.2

Lab_A(config)#ip route 192.168.50.0 255.255.255.0


192.168.20.2

3. show of route

Lab_A#sh ip route
192.168.50.0 [1/0] via 192.168.20.2
192.168.40.0 [1/0] via 192.168.20.2
192.168.30.0 [1/0] via 192.168.20.2
192.168.20.0 is directly connected, Serial 0/0
192.168.10.0 is directly connected, FastEthernet0/0
2. Lab_B
1. routing table:

. 192.168.10.0
. 192.168.50.0

2. config routing

Lab_B(config)#ip route 192.168.10.0 255.255.255.0


192.168.20.1

Lab_B(config)#ip route 192.168.50.0 255.255.255.0


192.168.40.2

3. show of route

Lab_B#sh ip route
192.168.50.0 [1/0] via 192.168.40.2
192.168.40.0 is directly connected, Seria10/1
192.168.30.0 is directly connected, FastEthernet 0/0
192.168.20.0 is directly connected, Serial0/0
192.168.10.0 [1/0] via 192.168.20.1

3. Lab_C
1. routing table:

192.168.30.0
192.168.20.0
192.168.10.0

2. config routing
Lab_C(config)#ip route 192.168.30.0 255.255.255.0
192.168.40.1

Lab_C(config)#ip route 192.168.20.0 255.255.255.0


172.16.40.1

Lab_C(config)#ip route 192.168.10.0 255.255.255.0


192.168.40.1

3. show of route

Lab_C#sh ip route
192.168.50.0 is directly connected, FastEthernet0/0
192.168.40.0 is directly connected, Serial0/0
192.168.30.0 [1/0] via 192.168.40.1
192.168.20.0 [1/0[ via 192.168.40.1
192.168.10.0 [1/0] via 192.168.40.1

5. Default Routing
Lab_C(config)#no ip route 192.168.10.0 255.255.255.0
192.168.40.1
Lab_C(config)#no ip route 192.168.20.0 255.255.255.0
192.168.40.1
Lab_C(config)#no ip route 192.168.30.0 255.255.255.0
192.168.40.1
Lab_C(config)#ip route 0.0.0.0 0.0.0.0 192.168.40.1
6. Dynamic Routing
1. Configure RIP Routing
1. Lab_A

Lab_A(config)#no ip route 192.168.30.0 255.255.255.0


192.168.20.2
Lab_A(config)#no ip route 192.168.40.0 255.255.255.0
192.168.20.2
Lab_A(config)#no ip route 192.168.50.0 255.255.255.0
192.168.20.2

Lab_A(config)#router rip
Lab_A(config-router)#network 192.168.10.0
Lab_A(config-router)#network 192.168.20.0
Lab_A(config-router)#^Z
Lab_A#

2. Lab_B

Lab_B#config t
Lab_B(config)#no ip route 192.168.10.0 255.255.255.0
192.168.20.1
Lab_B(config)#no ip route 192.168.50.0 255.255.255.0
192.168.40.2

Lab_B(config)#router rip
Lab_B(config-router)#network 192.168.20.0
Lab_B(config-router)#network 192.168.30.0
Lab_B(config-router)#network 192.168.40.0
Lab_B(config-router)#^Z
Lab_B#
3. Lab_C

Lab_C#config t
Lab_C(config)#no ip route 0.0.0.0 0.0.0.0 192.168.40.1

tab_C(config)#router rip
Lab_C(config-router)#network 192.168.40.0
Lab_C(config-router)#network 192.168.50.0
Lab_C(config-router)#^Z
Lab_C#

Holding Down RIP Propagations

Lab_A#config t
Lab_A(config)#router rip
Lab_A(config-router)#network 192.168.10.0
Lab_A(config-router)#passive-interface serial 0/0

This command will stop RIP updates from being propagated out serial interface 0, but
serial
interface 0 can still reccive RIP updates.

2. Configure IGRP Routing

Lab_A#config t
Enter configuration commands, one per line. End with CN
Lab_A(config)#router igrp ?
<1-65535> Autonomous system number

1. Lab_A
Lab_A(config)#router igrp 10
Lab_A(config-router)#netw 192.168.10.0
Lab_A(config-router)#netw 192.168.20.0
Lab_A(config-router)#^Z
Lab_A#

2. Lab_B

Lab_B#config t
Enter configuration commande, one per line. End with CNTL/Z.
Lab_B(config)#router igrp 10
Lab_B(config-router)#netw 192.168.20.0
Lab_B(config-router)#netw 192.168.30.0
Lab_B(config-router)#netw 192.168.40.0
Lab_B(config-router)#^Z
Lab_B#

3. Lab_C

Lab_C#config t
Enter configuration commands yone per line. End with CNTL/Z.
Lab_C(config)#router igrp 10
Lab_C(config-router)#netw 192.168.40.0
Lab_C(config-router)#netw 192.168.50.0
Lab_C(config-router)#^Z
Lab_C#

7. Debuging
1. rip
Lab_B#debug ip rip
RIP protocol debugging is on
Lab_B#
07:12:56: RIP: received v1 update from 192.168.40.2 on
Seria10/1

07:12:56: 192.168.50.0 in 1 hops

07:12:56: RIP: received v1 update from 192.168.20.1 on


Seria10/0

07:12:56: 192.168.10.0 in 1 hops

07:12:58: RIP: sending vl update to 255.255.255.255 via

2. igrp

Lab_B#debug ip igrp ?
events IGRP protocol events
transactions IGRP protocol transactions

The difference between these commands is explained in the following


sections.

Lab_B#debug ip igrp events


IGRP event debugging is on
07:13:50: IGRP: received request from 192.168.40.2 on
Serial0/1
07:13:50: IGRP: sending update to 192.168.40.2 via Serial1

You might also like