0% found this document useful (0 votes)
6 views

CCNA Workbook static routing v1.0

This document outlines a lab exercise for configuring static routes between three routers (R1, R2, R3) as part of the CCNA 200-301 curriculum. It includes detailed instructions for setting up IP addresses, configuring static routes, and validating the configuration using ping and traceroute commands. The lab aims to enhance understanding of static route configuration methods on Cisco routers.

Uploaded by

hoj7988
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
0% found this document useful (0 votes)
6 views

CCNA Workbook static routing v1.0

This document outlines a lab exercise for configuring static routes between three routers (R1, R2, R3) as part of the CCNA 200-301 curriculum. It includes detailed instructions for setting up IP addresses, configuring static routes, and validating the configuration using ping and traceroute commands. The lab aims to enhance understanding of static route configuration methods on Cisco routers.

Uploaded by

hoj7988
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
You are on page 1/ 6

CCNA 200-301

STATIC ROUTING

Topology

LAB : Static Route v1.0

Level: CCNA / Basic

Approximate time: 20 minutes

Preferred image: vios-adventerprisek9-m.SPA.159-3.M6

This LAB will cover topics of

Chapter 16: Configuring IPv4 Addresses and Static Routes

For more information we suggest “CCNA 200-301, Volume 1 Official Cert Guide”

Commands Guide:
All commands in this document have this style:
# Interface gig 0/0
If any option specified with italic letters means that you must replace the key word with a desired value for example:
# ip address ip_address subnet_mask
# ip address 192.168.10.1 255.255.255.0
And finally, if we mention something in {} mean that you must use one of options
# spanning-tree vlan vlan_id root {Primary| secondary}

Table 1 - LAB Addressing

Router Loop Back 0 Gi 0/0 Gi 0/1


R1 1.1.1.1/32 192.168.12.1/24 ---
R2 2.2.2.2/32 192.168.12.2/24 192.168.23.2/24
R3 3.3.3.3/32 192.168.23.3/24 ---

1
CCNA 200-301
STATIC ROUTING

Lab Objective:

The objective of this lab exercise is to configure static routes via Ethernet interfaces
between 3 routers. This lab also goes through the validation of the configured static
routes.

Lab Purpose:

Static route configuration is a fundamental skill. There are several methods to configure
static routes on a Cisco router, and each way has its pros and cons. As a Cisco engineer,
as well as in the Cisco CCNA exam, you will be expected to know how to configure static
routes via any of the methods available in Cisco IOS.

2
CCNA 200-301
STATIC ROUTING

Task 1:
Configure the hostnames on routers R1, R2, R3 as illustrated in the topology. And assign
addresses as mentioned in table 1.

Go to R1 and set the basic configuration as this instruction


Router>en
Router#conf ter
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#interface gi 0/0
R1(config-if)#ip add 192.168.12.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#interface loopback 0
R1(config-if)#1.1.1.1
R1(config-if)#ip address 1.1.1.1 255.255.255.255
R1(config-if)#end
R1#show ip interface brief
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 192.168.12.1 YES manual up up
GigabitEthernet0/1 unassigned YES unset administratively down
down
GigabitEthernet0/2 unassigned YES unset administratively down
down
GigabitEthernet0/3 unassigned YES unset administratively down
down
Loopback0 1.1.1.1 YES manual up up
R1#

Go to R2 and set the basic configuration as this instruction


Router>en
Router#conf ter
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#interface gi 0/0
R2(config-if)#ip address 192.168.12.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#interface loopback 0
R2(config-if)#ip address 2.2.2.2 255.255.255.255
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#interface gi 0/1
R2(config-if)#ip address 192.168.23.2 255.255.255.0
R2(config-if)#no shut
R2(config)#end
R2#show ip interface brief
Interface IP-Address OK? Method Status
Protocol
GigabitEthernet0/0 192.168.12.2 YES manual up
up

3
CCNA 200-301
STATIC ROUTING
GigabitEthernet0/1 192.168.23.2 YES manual up
up
GigabitEthernet0/2 unassigned YES unset administratively down
down
GigabitEthernet0/3 unassigned YES unset administratively down
down
Loopback0 2.2.2.2 YES manual up up

Go to R3 and set the basic configuration as this instruction

Router>en
Router#conf ter
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R3
R3(config)#interface gi 0/0
R3(config-if)#ip address 192.168.23.3 255.255.255.0
R3(config-if)#no shut
R3(config-if)#
*Sep 26 13:57:39.161: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed
state to up
*Sep 26 13:57:40.162: %LINEPROTO-5-UPDOWN: Line protocol on Interface
GigabitEthernet0/0, changed state to up
R3(config-if)#exit
R3(config)#interfce loop
R3(config)#interf
R3(config)#interface loo
R3(config)#interface loopback 0
R3(config-if)#ip addr
*Sep 26 13:57:59.991: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Loopback0, changed state to upes
R3(config-if)#ip address 3.3.3.3 255.255.255.255
R3(config-if)#no shut
R3(config-if)#exit
R3(config)#exit
R3#
*Sep 26 13:58:15.458: %SYS-5-CONFIG_I: Configured from console by console
R3#show ip interfac
R3#show ip interface brief
Interface IP-Address OK? Method Status
Protocol
GigabitEthernet0/0 192.168.23.3 YES manual up
up
GigabitEthernet0/1 unassigned YES unset administratively down
down
GigabitEthernet0/2 unassigned YES unset administratively down
down
GigabitEthernet0/3 unassigned YES unset administratively down
down
Loopback0 3.3.3.3 YES manual up
up
R3#

Task 2:
Configure static routes on routers.

4
CCNA 200-301
STATIC ROUTING

R1 Configuration:
Due to diagram, R1 need to reach 2.2.2.2/32 and 3.3.3.3/32 and also 192.168.23.0/24
networks, all of these networks are reachable via R2. So, we have to configure 3 static
routes for R1 to make this possible. Maybe you guessed, in this specific example, we can
just do that with adding one default route to R2. for now, we prefer to define 3 separate
routes. Look at the example:

R1>en
R1#conf ter
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#ip route 192.168.23.0 255.255.255.0 192.168.12.2
R1(config)#ip route 2.2.2.2 255.255.255.255 192.168.12.2
R1(config)#ip route 3.3.3.3 255.255.255.255 192.168.12.2
R1(config)#

With these commands, R1 can reach for example R3 but R3 has no idea where is for
example 1.1.1.1/32 and how can reach it. So, we need to config R2 and R3 too.

Go to R2 router, and for first step check the routing table. As you can see R2 has 2
connected routes for 192.168.12.0/24 and 192.168.23.0/24. So, we need to configure 2
routes for 1.1.1.1/32 and 3.3.3.3/32

R2>en
R2 #show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

2.0.0.0/32 is subnetted, 1 subnets


C 2.2.2.2 is directly connected, Loopback0
192.168.12.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.12.0/24 is directly connected, GigabitEthernet0/0
L 192.168.12.2/32 is directly connected, GigabitEthernet0/0
192.168.23.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.23.0/24 is directly connected, GigabitEthernet0/1
L 192.168.23.2/32 is directly connected, GigabitEthernet0/1
R2#conf ter
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#ip route 1.1.1.1 255.255.255.255 192.168.12.1
R2(config)#ip route 3.3.3.3 255.255.255.255 192.168.23.3
R2(config)#

5
CCNA 200-301
STATIC ROUTING

R3 configuration almost is the same with R1. We need 3 routes for 1.1.1.1/32, 2.2.2.2/32
and 192.168.12.0/24. But this time lets use a default gateway instead them!

R3>en
R3#conf ter
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)#ip route 0.0.0.0 0.0.0.0 192.168.23.2
R3(config)#exit

Task 3:
After completing our configuration let’s check it with ping and traceroute commands.
We did the test just from R3, but you can do same thing from the others.

R3#ping 1.1.1.1 source 3.3.3.3


Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 3.3.3.3
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/7 ms
R3#traceroute 1.1.1.1 source 3.3.3.3
Type escape sequence to abort.
Tracing the route to 1.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.23.2 3 msec 3 msec 3 msec
2 192.168.12.1 8 msec 12 msec *
R3#

You might also like