0% found this document useful (0 votes)
3 views

CompTIA_A+_Commands

The document lists essential commands for Windows, Linux, and macOS used for troubleshooting and system management. Each command is accompanied by a brief description and an example of its usage. These commands include network configuration, file management, and system settings adjustments.

Uploaded by

Dor
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
0% found this document useful (0 votes)
3 views

CompTIA_A+_Commands

The document lists essential commands for Windows, Linux, and macOS used for troubleshooting and system management. Each command is accompanied by a brief description and an example of its usage. These commands include network configuration, file management, and system settings adjustments.

Uploaded by

Dor
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
You are on page 1/ 3

CompTIA A+ Most Used Commands

Windows Commands

1. ipconfig - Displays network configuration details.


Example: ipconfig /all

2. ping - Tests network connectivity.


Example: ping google.com

3. netstat - Displays active network connections.


Example: netstat -an

4. tracert - Traces the route packets take to a destination.


Example: tracert google.com

5. nslookup - Queries DNS servers for domain name resolution.


Example: nslookup google.com

6. netsh - Configures network settings.


Example: netsh wlan show profile

7. gpresult - Displays applied Group Policy settings for a user or computer.


Example: gpresult /r

Linux Commands

1. ls - Lists directory contents.


Example: ls -l

2. pwd - Prints the current directory.


Example: pwd
3. grep - Searches for a specific text pattern in a file.
Example: grep "error" /var/log/syslog

4. chmod - Changes file permissions.


Example: chmod 755 script.sh

5. sudo - Executes a command with administrative privileges.


Example: sudo apt update

6. traceroute - Traces the route packets take to a destination.


Example: traceroute google.com

7. dig - Queries DNS information.


Example: dig google.com

8. ifconfig/ip - Displays network interface details.


Example: ifconfig or ip addr show

9. mv - Moves or renames a file or directory.


Example: mv oldfile.txt newfile.txt

10. rm - Removes files or directories.


Example: rm file.txt

11. cp - Copies files or directories.


Example: cp file.txt /home/user/Documents/

12. chown - Changes file ownership.


Example: chown user:group file.txt

13. su - Switches to another user account.


Example: su - username
14. cat - Displays the contents of a file.
Example: cat file.txt

15. apt-get - Manages software packages on Debian-based systems.


Example: sudo apt-get install package-name

macOS Commands

1. diskutil - Manages disk partitions and storage.


Example: diskutil list

2. say - Converts text to speech.


Example: say "Hello, world!"

3. open - Opens files and applications.


Example: open /Applications/Notes.app

4. screencapture - Takes a screenshot.


Example: screencapture -i screenshot.png

5. defaults - Modifies macOS system preferences.


Example: defaults write com.apple.finder AppleShowAllFiles YES

6. networksetup - Manages network interfaces.


Example: networksetup -listallhardwareports

7. scutil - Configures system-wide network settings.


Example: scutil --dns

These commands are essential for troubleshooting and system management in different operating systems

You might also like